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��  WARNING ��
Thank you for purchasing automation equipment from Automationdirect.com®, doing business as,
AutomationDirect. We want your new automation equipment to operate safely. Anyone who installs or
uses this equipment should read this publication (and any other relevant publications) before installing or
operating the equipment.

To minimize the risk of potential safety problems, you should follow all applicable local and national codes
that regulate the installation and operation of your equipment. These codes vary from area to area and
usually change with time. It is your responsibility to determine which codes should be followed, and to
verify that the equipment, installation, and operation is in compliance with the latest revision of these
codes.

At a minimum, you should follow all applicable sections of the National Fire Code, National Electrical
Code, and the codes of the National Electrical Manufacturer's Association (NEMA). There may be local
regulatory or government offices that can also help determine which codes and standards are necessary for
safe installation and operation.

Equipment damage or serious injury to personnel can result from the failure to follow all applicable codes
and standards. We do not guarantee the products described in this publication are suitable for your
particular application, nor do we assume any responsibility for your product design, installation, or
operation.

Our products are not fault-tolerant and are not designed, manufactured or intended for use or resale as on-
line control equipment in hazardous environments requiring fail-safe performance, such as in the
operation of nuclear facilities, aircraft navigation or communication systems, air traffic control, direct life
support machines, or weapons systems, in which the failure of the product could lead directly to death,
personal injury, or severe physical or environmental damage ("High Risk Activities"). AutomationDirect
specifically disclaims any expressed or implied warranty of fitness for High Risk Activities.

For additional warranty and safety information, see the Terms and Conditions section of our catalog. If
you have any questions concerning the installation or operation of this equipment, or if you need
additional information, please call us at 770-844-4200.

This publication is based on information that was available at the time it was printed. At
AutomationDirect we constantly strive to improve our products and services, so we reserve the right to
make changes to the products and/or publications at any time without notice and without any obligation.
This publication may also discuss features that may not be available in certain revisions of the product.

Trademarks
This publication may contain references to products produced and/or offered by other companies. The
product and company names may be trademarked and are the sole property of their respective owners.
AutomationDirect disclaims any proprietary interest in the marks and names of others.

Copyright 2013, Automationdirect.com® Incorporated
All Rights Reserved

No part of this manual shall be copied, reproduced, or transmitted in any way without the prior, written
consent of Automationdirect.com® Incorporated. AutomationDirect retains the exclusive rights to all
information included in this document.



��  ADVERTENCIA ��

Gracias por comprar equipo de automatización de Automationdirect.com®. Deseamos que su nuevo equipo de
automatización opere de manera segura. Cualquier persona que instale o use este equipo debe leer esta
publicación (y cualquier otra publicación pertinente) antes de instalar u operar el equipo.

Para reducir al mínimo el riesgo debido a problemas de seguridad, debe seguir todos los códigos de seguridad
locales o nacionales aplicables  que regulan la instalación y operación de su equipo. Estos códigos varian de área
en área y usualmente cambian con el tiempo. Es su responsabilidad  determinar cuales códigos deben ser
seguidos y verificar que el equipo, instalación y operación estén en cumplimiento con la revisión mas reciente
de estos códigos.

Como mínimo, debe seguir las secciones aplicables del Código Nacional de Incendio, Código Nacional
Eléctrico, y los códigos de (NEMA) la Asociación Nacional de Fabricantes Eléctricos  de USA. Puede haber
oficinas de normas locales o del gobierno que pueden ayudar a determinar cuales códigos y normas son
necesarios para una instalación y operación segura.

Si no se siguen todos los códigos y normas aplicables, puede resultar en daños al equipo o lesiones serias a
personas.  No garantizamos los productos descritos en esta publicación para ser adecuados para su aplicación en
particular, ni asumimos ninguna responsabilidad por el diseño de su producto, la instalación u operación.

Nuestros productos no son tolerantes a fallas y no han sido diseñados, fabricados o intencionados para uso o
reventa como equipo de control en línea en ambientes  peligrosos que requieren una ejecución sin fallas, tales
como operación en instalaciones nucleares, sistemas de navegación aérea, o de comunicación, control de tráfico
aéreo,  máquinas de soporte de vida o sistemas de armamentos en las cuales la falla del producto puede resultar
directamente en muerte, heridas personales, o daños físicos o ambientales severos ("Actividades de Alto Riesgo").
Automationdirect.com específicamente rechaza cualquier garantía ya sea expresada o implicada para
actividades de alto riesgo.
Para información adicional acerca de garantía e información de seguridad, vea la sección de Términos y
Condiciones de nuestro catálogo.  Si tiene alguna pregunta sobre instalación u operación de este equipo, o si
necesita información adicional, por favor llámenos al  número 770-844-4200 en Estados Unidos.
Esta publicación está basada en la información disponible al momento de impresión.  En
Automationdirect.com nos esforzamos constantemente para mejorar nuestros productos y servicios, así que
nos reservamos el derecho de hacer cambios al producto y/o a las publicaciones en cualquier momento sin
notificación  y sin ninguna obligación.  Esta publicación también puede discutir características que no estén
disponibles en ciertas revisiones del producto.

Marcas Registradas
Esta publicación puede contener referencias a productos producidos y/u ofrecidos por otras compañías.  Los nombres de las
compañías y productos pueden tener marcas registradas y son propiedad única de sus respectivos dueños.  Automationdirect.com,
renuncia cualquier interés propietario en las marcas y nombres de otros.

PROPIEDAD LITERARIA 2013, AUTOMATIONDIRECT.COM® INCORPORATED
Todos los derechos reservados

No se permite copiar, reproducir, o transmitir de ninguna forma ninguna parte de este manual sin previo consentimiento por escrito de
Automationdirect.com® Incorprated.  Automationdirect.com retiene los derechos exclusivos a toda la información incluida en este
documento. Los usuarios de este equipo pueden copiar este documento  solamente para instalar, configurar y mantener el equipo
correspondiente. También las instituciones de enseñanza pueden usar este manual para propósitos educativos.



��  AVERTISSEMENT ��
Nous vous remercions d'avoir acheté l'équipement d'automatisation de Automationdirect.com®, en faisant des
affaires comme, AutomationDirect. Nous tenons à ce que votre nouvel équipement d'automatisation fonctionne en
toute sécurité. Toute personne qui installe ou utilise cet équipement doit lire la présente publication (et toutes les
autres publications pertinentes) avant de l'installer ou de l'utiliser.

Afin de réduire au minimum le risque d'éventuels problèmes de sécurité, vous devez respecter tous les codes locaux et
nationaux applicables régissant l'installation et le fonctionnement de votre équipement. Ces codes diffèrent d'une
région à l'autre et, habituellement, évoluent au fil du temps. Il vous incombe de déterminer les codes à respecter et
de vous assurer que l'équipement, l'installation et le fonctionnement sont conformes aux exigences de la version la
plus récente de ces codes.

Vous devez, à tout le moins, respecter toutes les sections applicables du Code national de prévention des incendies,
du Code national de l'électricité et des codes de la National Electrical Manufacturer's Association (NEMA). Des
organismes de réglementation ou des services gouvernementaux locaux peuvent également vous aider à déterminer
les codes ainsi que les normes à respecter pour assurer une installation et un fonctionnement sûrs. 

L'omission de respecter la totalité des codes et des normes applicables peut entraîner des dommages à l'équipement
ou causer de graves blessures au personnel. Nous ne garantissons pas que les produits décrits dans cette publication
conviennent à votre application particulière et nous n'assumons aucune responsabilité à l'égard de la conception, de
l'installation ou du fonctionnement de votre produit.

Nos produits ne sont pas insensibles aux défaillances et ne sont ni conçus ni fabriqués pour l'utilisation ou la revente
en tant qu'équipement de commande en ligne dans des environnements dangereux nécessitant une sécurité absolue,
par exemple, l'exploitation d'installations nucléaires, les systèmes de navigation aérienne ou de communication, le
contrôle de la circulation aérienne, les équipements de survie ou les systèmes d'armes, pour lesquels la défaillance du
produit peut provoquer la mort, des blessures corporelles ou de graves dommages matériels ou environnementaux
(«activités à risque élevé»). La société AutomationDirect nie toute garantie expresse ou implicite d'aptitude à
l'emploi en ce qui a trait aux activités à risque élevé.

Pour des renseignements additionnels touchant la garantie et la sécurité, veuillez consulter la section Modalités et
conditions de notre documentation. Si vous avez des questions au sujet de l'installation ou du fonctionnement de cet
équipement, ou encore si vous avez besoin de renseignements supplémentaires, n'hésitez pas à nous téléphoner au
770-844-4200.

Cette publication s'appuie sur l'information qui était disponible au moment de l'impression. À la société
AutomationDirect, nous nous efforçons constamment d'améliorer nos produits et services. C'est pourquoi nous
nous réservons le droit d'apporter des modifications aux produits ou aux publications en tout temps, sans préavis ni
quelque obligation que ce soit. La présente publication peut aussi porter sur des caractéristiques susceptibles de ne
pas être offertes dans certaines versions révisées du produit.

Marques de commerce
La présente publication peut contenir des références à des produits fabriqués ou offerts par d'autres entreprises. Les
désignations des produits et des entreprises peuvent être des marques de commerce et appartiennent exclusivement à
leurs propriétaires respectifs. AutomationDirect nie tout intérêt dans les autres marques et désignations.

Copyright 2013, Automationdirect.com® Incorporated
Tous droits réservés

Nulle partie de ce manuel ne doit être copiée, reproduite ou transmise de quelque façon que ce soit sans le
consentement préalable écrit de la société Automationdirect.com® Incorporated. AutomationDirect conserve les
droits exclusifs à l'égard de tous les renseignements contenus dans le présent document.
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Introduction

Purpose of this Manual
Thank you for purchasing the AutomationDirect Point of View Scada software. This quick
start guide provides information that will help you set up and program your Point of View
software for use with our ADC communication drivers.

About Getting Started
If you are familiar with SCADA in general, then following the simple steps in the following
chapters may be all you require to start being productive using the Point of View software.
After you have completed the steps, your Point of View software will be running a project that
you programmed. If you are new to the world of SCADA software, be sure to also read the
chapters in the software help file.

Online Help Files and Other Documentation
The Point of View Programming Software, POV-PGMSW, can be downloaded free from the
AutomationDirect web site (link shown below under Technical Support). The free download
is limited to 40 hrs. of use, but all features and functions are enabled. The Point of View
Programming Software includes searchable online help topics covering all aspects of the
software and object sets.

Technical Support
We strive to make our manuals the best in the industry. We rely on your feedback to let us
know if we are reaching our goal. If you cannot find the solution to your particular application,
or, if for any reason you need technical assistance, please call us at:

770–844–4200

Our technical support group will work with you to answer your questions. They are available
Monday through Friday from 9:00 A.M. to 6:00 P.M. Eastern Time. We also encourage you
to visit our web site where you can find technical and non-technical information about our
products and our company.

http://www.automationdirect.com
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1–3

Conventions Used

When you see the “note pad” icon in the left-hand margin, the paragraph to its immediate right will be a
special note. Notes represent information that may make your work quicker or more efficient. The word
NOTE: in boldface will mark the beginning of the text.

Whenever the “lightbulb” is shown in the left-hand margin, the paragraph to its immediate right will
provide a special tip. The word TIP: in boldface will mark the beginning of the text.

Key Topics for Each Chapter
The beginning of each chapter will list the key
topics that can be found in that chapter.

Getting Started! CHAPTER
1

In This Chapter...

.............................................................................1-2

....................................................................1-3Conventions Used

Introduction
....................................................................1-2Purpose of this Manual

......................................................................1-2About Getting Started!
............................................1-2Supplemental Manuals and Other Help

.............................................................................1-2Technical Support
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P3000 Using Tag Integration

Using Point of View along with the P3000 communications driver allows you to easily import
the PAC tag database into your POV project using tag integration. With tag integration, all the
tags from the PAC can be browsed in the Object Finder, but individual tags are not added to
your project tag database nor counted against the project's tag limit until you actually use it
somewhere in your project.

In this example, we are going to cover how to read the clock seconds from a P3000 PAC via
Ethernet.

NOTE: An IP address will need to be setup in the PAC prior to starting this exercise.

1.) Open the Productivity Suite Software and create a new project.

2.) Click on File > Save As > and name ‘POV example’.

3.) Connect to the PAC, download the project and ensure the PAC is in RUN.

4.) Open the Point of View software.

5.) Click on the Application Menu button and select New.

6.) Enter 'P3000 Example' as the project name. Select the product type that is currently licensed on
the USB key for the PC you are using, then hit OK. (Ignore if in Demo Mode)

7.) The Project Wizard will open > Hit OK.



Chapter 2: P3000 Driver

2–3Quick Start Guide for AutomationDirect Drivers, 1st Ed. Rev. E - PV-ADCDRV-M

Next, we will use tag integration to setup the communications to the P3000:

8.) Click on the Project tab > select Communication on the ribbon bar.

9.) Under Tag Integration, click on Add.

10.) Select the drop down next to Provider, and choose AutomationDirect PAC 3000.

11.) In the Name field the default name is ‘DEV’, change this to ‘P3K’ > Click on Add.

12.) Next for PLC station, type in your PAC IP address.

13.) Click on the Browse button > now browse for your PAC project .csv file we saved in step 2 ‘POV
example’.

14.) Click on the OK button > Click on the OK once again.

NOTE: All the tags from the .csv have now been imported into your POV project.

NOTE: Integrated tags are not added to a Main or Standard driver worksheet, these tags are found using
the Object Finder which is located in the Tags section of the Home ribbon. Open the Object Fnder and then
expand the Devices.

Next, we will create a text object to read the clock seconds:

15.) Click on the Graphics tab at the bottom of the Project Explorer pane.

16.) Now right click on Screens and select Insert > then select OK.
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17.) On the ribbon bar under the Graphics tab select Active Objects > then Text. This will give you a
cross-hair, left click and place anywhere on the screen work area.

18.) Now type in 'P3KSeconds: ##' > Hit Enter.

19.) Double left click on the above entry to open the properties.

20.) Click on 'Text data link'.

21.) At the end of the Tag/Expression field, click on the Browse button.

22.) In the left hand column, you will see a P3K folder under Devices. Click on
the P3K folder and in right hand window you will see all of the tags
brought in during the Tag Integration process. 

NOTE: These tags are shown in grey indicating that you still need to select and
Import the desired tags to be used in the project.

23.) Next type ‘Clock Seconds’ in the Selection Field, this will filter the tags listed.

24.) Left click on the Clock Seconds tag, the Import Selected Tags will now be highlighted for you to
select.

25.) Select Yes on the next pop up > hit OK once successfully adding the tag > then select OK to
close the object finder and apply this tag to your object.

NOTE: The Clock Seconds tag is now in black indicating the tag has been imported and can be used in your
project. In addition, notice your tag count (bottom right hand corner) increased by one.

26.) Now you should see P3K.Clock_Seonds in the Tag/Expression Field.



27.) Close the Object Properties window.

28.) Right click on the current screen tab and select Close.

29.) On the pop up, select Yes to save changes.

30.) Change the file name to 'P3K Main Menu', then select Save.

31.) Under the screen folder > right click on our newly created screen > select 'Set as Startup’.

We will now run the project to verify communications between the PC and the PAC:

NOTE: Ensure your PC is connected to the P3000 PAC Ethernet port or switch prior to placing in Run.

32.) On the ribbon bar > under the 'Home' tab and Local Management >
select the Run button.

33.) You should now see the seconds updating on your screen.

NOTE: If any part of the project doesn't work as expected (or to exit the runtime application), switch back
to the development application (ALT+TAB) and then click Stop on the Home tab of the ribbon. Then if
needed, begin troubleshooting.

NOTE: If tag changes were made in the P3000 project, you must save the changes and then select “Refresh
Devices” in the POV Object Finder window in order to update the window and reflect these changes.

Chapter 2: P3000 Driver
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DirectLOGIC Using Tag Integration

Using Point of View along with the Koyo DirectLogic communications driver, allows you to
easily import the TagDB into your POV project using tag integration.

By using tag integration, all tags from the PLC can be browsed in the Object Finder, but an
individual tag is not added to your project tags database nor counted against the project's tag
limit until you actually use it somewhere in your project.

In this example, we are going to cover how to read the clock seconds from a Koyo D2-260 via
Ethernet.

NOTE: An IP address will need to be setup in the H2-ECOM100 prior to starting this exercise.

1.) Open DirectSOFT Software and create a new project, name this project "POV Example".

2.) Click on Tools > Documentation Editor.

3.) Use shortcut Ctrl + F (Find), and type in V7766 > Hit enter.

4.) For V7766, under Nickname, type in "Clock Seconds".

5.) On rung 1, enter an END statement.

6.) Click on File > Save Project > To Disk.

7.) Download the project to the PLC. 

8.) Now click on File > Export > Element Documentation > Save.

9.) Open Point of View software.

10.) Click on Application Menu button              and select New.

11.) Enter a 'Koyo DirectLogic Example' as a project name, select your product type that is currently
licensed on the USB key for the PC you are currently using > Then hit OK. (Ignore if in Demo
Mode)

12.) Project Wizard will open > Hit OK.

Next, we will use tag integration to setup the
communications to the Koyo D2-260:

13.) Click on the Project tab > select
Communication on the ribbon bar.

14.) Under Tag Integration, click on Add.

15.) Select the drop down next to Provider, and
choose AutomationDirect Koyo.
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16.) In the Name field the default name is ‘DEV’, change this to ‘DL’ > Click on Add.

17.) Next for Communication Mode, select EthernetIP.

18.) Enter the IP address of your ECOM-100 into the Device IP field.

19.) Click on the Browse button > now browse for your DirectSoft project .csv file we exported in
Step 8 "POV example".

20.) Click on the OK button > Click on the OK once again.

NOTE: All the tags from the .csv have now been imported into your POV project.

NOTE: Integrated tags are not added to a Main or Standard driver worksheet, these tags are found using
the Object Finder which is located in the Tags section of the Home ribbon. Open the Object Fnder and then
expand the Devices.

NOTE: Integrated tags can not have an optional format modifier added. You will need to manually add the
tag to a Main or Standard driver worksheet to used modifiers.

Next, we will create a text object to read the clock seconds:

21.) Click on the Graphics tab at
the bottom of the Project
Explorer pane.

22.) Now right click on Screens
and select Insert > then select
OK.
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23.) On the ribbon bar under the Graphics tab select Active Objects > then Text. This will give you a
cross-hair, left click and place anywhere on the screen work area.

24.) Now type in 'DLSeconds: ##' > Hit Enter.

25.) Double left click on the above entry to open the properties.

26.) Click on 'Text data link'.

27.) At the end of the Tag/Expression field, click on the Browse button.

28.) In the left hand column, you will see a DL folder under Devices. Click on
the DL folder and in right hand window you will see all of the tags
brought in during the Tag Integration process. 

NOTE: These tags are shown in grey indicating that you still need to select and
Import the desired tags to be used in the project.

29.) Left click on the Clock Seconds tag, the Import Selected Tags will now be highlighted for you to
select.

30.) Select Yes on the next pop up > then hit OK once successfully adding the tag.

NOTE: The Clock Seconds tag is now in black indicating the tag has been imported and can be used in your
project. In addition, notice your tag count (bottom right hand corner) increased by one.

31.) Click the OK button > you should see DL.Clock_Seonds in the Tag/Expression Field.

3–4 Quick Start Guide for AutomationDirect Drivers, 1st Ed. Rev. E - PV-ADCDRV-M



32.) Close the Object Properties window.

33.) Right click on the current screen tab and select Close.

34.) On the pop up, select Yes to save changes.

35.) Change the file name to 'DL Main Menu', then select Save.

36.) Under the screen folder > right click on our newly created screen > select 'Set as Startup'

We will now run the project to verify communications between the PC and the D2-260:

NOTE: Ensure your PC is connected to the H2-ECOM100 Ethernet port or switch prior to placing in Run.

37.) On the ribbon bar > under the 'Home' tab and Local Management
> select the Run button.

38.) You should now see the seconds updating on your screen.

NOTE: If any part of the project doesn't work as expected (or to exit the runtime application), switch back
to the development application (ALT+TAB) and then click Stop on the Home tab of the ribbon. Then if
needed, begin troubleshooting.
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DirectLOGIC Addressing in Point of View

DirectLogic POV Addressing for Koyo Driver

DirectLogic POV Addressing for Modbus

Data Types DirectLogic Address POV Address Data Format Read/Write
X X0 X:0 BOOL Read
Y Y0 Y:0 BOOL Read/Write
C C0 C:0 BOOL Read/Write
S S0 S:0 BOOL Read/Write
SP SP0 SP:0 VARIES Varies
T T0 T:0 BOOL Read/Write
CT CT0 CT:0 BOOL Read/Write
V V2000 (bit of word) V:2000.0 INTEGER Read/Write
V V2000 (unsigned) V:2000 INTEGER Read/Write
V V2000 (signed) V:2000:S INTEGER Read/Write
V V2000 (BCD) V:2000:B INTEGER Read/Write
V V2000 (BCD double word) V:2000:LB INTEGER Read/Write
V V2000 (unsigned double word) V:2000:D INTEGER Read/Write
V V2000 (signed double word) V:2000:SD INTEGER Read/Write
V V2000 (floating point) V:2000:F REAL Read/Write
V V2000 (ASCII string) V:2000:A.#* STRING Read/Write

*  [# is equal to the length of the string]

Data Types DirectLogic Address POV Address Data Format Read/Write
X X0 1X:2049 BOOL Read
Y Y0 0X:2049 BOOL Read/Write
C C0 0X:3073 BOOL Read/Write
V V2000 (bit of word) 4X:1025.0 INTEGER Read/Write
V V2000 (unsigned) 4x:1025 INTEGER Read/Write
V V2000 (signed) 4X:S1025 INTEGER Read/Write
V V2000 (BCD) BCD:1025 INTEGER Read/Write
V V2000 (BCD double word) BCDDW:1025 INTEGER Read/Write
V V2000 (BCD double word w byte swap) BCDDWS:1025 INTEGER Read/Write
V V2000 (double word) DW:1025 INTEGER Read/Write
V V2000 (double word w byte swap) DWS:1025 INTEGER Read/Write
V V2000 (floating point) FP:1025 REAL Read/Write
V V2000 (floating point with byte swap) FPS:1025 REAL Read/Write
V V2000 (string) ST:1025:#* STRING Read/Write
V V2000 (string with byte swap) STS:1025:#* STRING Read/Write

*  [# is equal to the length of the string]
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CLICK Using Driver Worksheet

The CLICK PLC has two communications ports (RS-232 or RS-485) available that may be
used to communicate to a PC running Point of View software.

In this example, we are going to read the clock seconds from the CLICK PLC using port 2 (RS-
232).

NOTE: You must have a CLICK with a Real Time Clock / Calendar to start this exercise.

1.) Open the Point of View software.

2.) Click on the Application Menu button and select New.

3.) Enter 'CLICK Example' as the project name. Select the product type that is currently licensed on
the USB key for the PC you are using, then hit OK. (Ignore if in Demo Mode)

4.) The Project Wizard will open > Hit OK.

Next, we will set up the driver communications to the CLICK:

5.) Select the Comm tab at the bottom
of the Project Explorer pane.

6.) Right click on Drivers and select 
Add/Remove drivers.
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7.) Scroll down in the list of available drivers and select the MODBU 'Modbus Protocol
RTU/ASCII'.

8.) Click on the Select button, this will move the driver down to the selected drivers list.

9.) Now select OK and a new MODBU driver sheet will be created.

10.) Under the Drivers folder > right click on MODBU folder > select Settings.

11.) Verify these settings match your CLICK settings and that the correct communications port is
selected.

Setup of tag in driver worksheet to read from the CLICK:

12.) Click on the Comm tab at the bottom of the Project Explorer pane.

13.) Open the Driver folder > select MODBU > double left click on Main Driver Sheet.

Default CLICK RS232 Port Setup
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NOTE: You can refer to the MODBU driver help file by selecting Help from the ribbon bar, then selecting
'Communications Drivers'.

14.) Under Tag Name, type in 'CSeconds' and hit Enter.

15.) On the pop up window select Yes, leave settings at default and hit OK.

16.) For the Station entry, type in the node address. For our example enter '1'.

17.) Under I/O Address, enter '4X:61466'

NOTE: You can find a list of assigned Modbus address in the CLICK by using the Address picker and
selecting 'Display Modbus Addresses.'

18.) Close the worksheet, select 'Yes’ to save changes.

Next, we will create a text object to read the clock seconds:

19.) Click on the Graphics tab at the bottom of the Project Explorer pane.

20.) Now right click on Screens and select Insert > then select OK.

21.) On the ribbon bar under the Graphics tab select Active Objects > then Text. This will give you a
cross-hair, left click and place anywhere on the screen work area.

22.) Now type in 'CSeconds: ##' > Hit Enter.

23.) Double left click on the above entry to open the properties.

24.) Click on 'Text data link'.

25.) In the Tag/Expression field, enter the tag we created back in step 14 'CSeconds'.

NOTE: You can enter a tag manually by double left clicking in the tag field, or by clicking on the Browse
button.

26.) Close the Object Properties window.

27.) Right click on the current screen tab and select Close.



28.) On the pop up, select Yes to save changes.

29.) Change the file name to 'CLICK Main Menu', then select Save.

30.) Under the screen folder > right click on our newly created screen > select 'Set as Startup'

We will now run the project to verify communications between the PC and the CLICK:

NOTE: Ensure your PC is connected to the CLICK PLC port 2 prior to placing in Run.

31.) On the ribbon bar > under the 'Home' tab and Local Management >
select the Run button.

32.) You should now see the seconds updating on your screen.

NOTE: If any part of the project doesn't work as expected (or to exit the runtime application), switch back
to the development application (ALT+TAB) and then click Stop on the Home tab of the ribbon. Then if
needed, begin troubleshooting.
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Data Types CLICK Address Modbus Address POV Address Data Format Read/Write
X X1 100001 1X:1 BOOL Read
Y Y1 8193 0X:8193 BOOL Read/Write
C C1 16385 0X:16385 BOOL Read/Write
T T1 145057 1X:45057 BOOL Read
CT CT1 149153 1X:49153 BOOL Read
SC SC1 161441 1X:61441 BOOL Read
DS DS1 400001 4X:1 INTEGER Read/Write
DD DD1 416385 DW:16385 INT (double word) Read/Write
DH DH1 424577 4X:24577 HEX Read/Write
DF DF1 428673 FP:28673 REAL Read/Write
XD XD0 357345 3X:57345 HEX Read
YD YD0 457857 4X:57857 HEX Read/Write
TD TD1 345057 3X:45057 INTEGER Read/Write
CTD CTD1 349153 DW3:49153 INT (double word) Read/Write
SD SD1 361441 3X:61441 INTEGER Varies
TXT TXT1 436865 STS:36865:5* STRING Read/Write

*  [String prefix : Modbus address : length]

Register Type Description Read/Write
0X: Coil Status (Function code 1, 5, 15) Read/Write
1X: Input Status (Function code 2) Read
3X: Input Register (Function code 4) Read
4X: Holding Register (Function code 3, 6, 16) Read/Write
STA: Exception Status (Function code 7) Read
FP: Floating Point Read/Write
FPS: Floating Point (byte swap) Read/Write
FP3: Floating Point Read Only Read
FP3S: Floating Point Read (byte swap) Read
DW: Double Word Read/Write
DWS: Double Word (byte swap) Read/Write
DW3: Double Word Read Only Read
DW3S: Double Word Read (byte swap) Read
BCD: BCD (Function code 3, 6, 16) Read/Write
BCD3: BCD Read Only (Function code 4) Read
BCDDW: BCD Double Word Read/Write
BCDDWS: BCD Double Word (byte swap) Read/Write
BCDDW3: BCD Double Word Read Only Read
BCDDW3S: BCD Double Word Read (byte swap) Read

ID: Report Slave ID (Function code 17) Read
ST: String Read/Write
STS: String (byte swap) Read/Write
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Do-more Using Tag Integration
Using Point of View along with the Do-more communications driver allows you to easily
import the Do-more addressing (Built-in memory, Heap, Structures, Nicknames) into your
POV project using tag integration. By using tag integration, all tags from the PLC can be
browsed in the Object Finder, but an individual tag is not added to your project tags database
nor counted against the project's tag limit until you actually use it somewhere in your project.

In this example, we are going to cover how to read the clock seconds from a Do-more PLC via
Ethernet.

NOTE: Any time that the memory configuration in the Do-more Designer software is changed in a project,
the memory version is changed and will be loaded into the PLC on project transfer. Performing
“File>Export>Element Documentation” will create the CSV file that POV uses and will also contain
this memory version.

During run time, the .csv version is compared to the PLC version to make sure that they match.
If there is a mismatch between versions, only tags referencing Heap, Nicknames, user defined
blocks in a SDS or MDS, or any object referencing a tag integration tag will cause invalid data
???? for those tags and you will get an 'Out-of-Sync: The version of the CSV file does not match
with the PLC' error. This can be verified by turning on the Protocol Analyzer option in the
Output Window:

Steps to recover an 'Out-of Sync:' Error caused by Do-more project download:
1.  Update .csv file that POV is referencing to match the Do-more PLC version.

2.  Stop the POV project runtime.

3.  Click Run to start the runtime project.

NOTE: You can alternatively download the previous Do-more project file that matches the POV version to
recover from the error.

NOTE: An IP address will need to be set up in the Do-more using either a H2-DM1E, T1H-DM1E or H2-
DM1 with a H2-ECOM100 (with firmware version 4.0.1808 or higher) installed prior to starting this
exercise.

1) Open the Do-more Designer Software and create a new project.

2) Download the project to the Do-more PLC.

3) Click on File > Export > Element Documentation.
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4) Choose 'Cmore Do-more driver format' (non-plus version) > save this to a location on your PC
as 'POV example'.

5) Open Point of View software.

6) Click on Application Menu button and select New.

7) Enter 'Do-more Example' as a project name, select your product type that is currently licensed
on the USB key for the PC you are currently using > select OK. (Ignore if in Demo Mode.)

8) Project Wizard will open > select OK (seen on right).

Next we will use tag integration to setup the
communications to the Do-more:

9) Click on Project tab > then select Communication on
the ribbon bar.

10) Under Tag Integration, click on Add.

11) Select the drop down next to Provider, and choose
AutomationDirect DoMore.

12) In the Name field the default name is "DEV", change this to "Do-more" > click on Add.

13) Next, for IP address type in your Do-more IP address.

14) Optional: Change port number (default 28784) and enter a password if needed.

15) Click on the Browse button > then browse for your Do-more project .csv file we saved in step 2
"POV example".

Menu Button



16) Click on the OK button > then click on OK once again.

All the tags from the .csv have now been imported into your POV project. In the next steps, we will
create a text object to read the clock seconds.

17) Click on the Graphics tab at the bottom of the
Project Explorer pane.

18) Now right click on Screens and select Insert > then
select OK.

19) On the ribbon bar under the 'Graphics' tab > select
'Active Objects' > select Text.

20) This will give you a cross-hair, left click and place anywhere on the screen work area.

21) Now type in 'Do-more Seconds: ##' and select Enter.

22) Double left click on the above entry to open the properties.

23) Click on 'Text data link'.

24) At the end of the Tag/Expression field, click on the browse button

25) In the left-hand column, you will see a Do-more folder under Devices. 

Expand the Do-more folder > click on Memory Blocks > then select any folder to see the tags
listed on the right that were brought in during the Tag Integration process.

NOTE: These tags are shown in gray indicating that you still need to select and Import the selected tags to
be used in the project.

26) Next, select SDT folder> SDT0 Class tag > select member and choose Second > select OK.

NOTE: Make sure 'show only imported tags' is unchecked.
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27) In the selection field it will show 'Do_more.SDT0.Second' > select OK >.

NOTE: Snce the SDT0 class tag is a Structure, it is now in black indicating that all members of that
Structure have been imported and can be used in your project. In addition, notice your tag count
(bottom right hand corner) has increased by nine.

28) Click the OK button > you should see Do_more.SDT0.Second in the Tag/Expression Field.

29) Close the Object Properties window.

30) Right click on the current screen tab and select Close.

31) On the pop up, select Yes to save changes.

32) Change the file name to 'Do-more Main Menu', then select Save.

33) Under the screen folder right-click on our newly created screen > select 'Set as Startup'.

We will now run the project to verify communications between the PC and the Do-more:

NOTE: Make sure the Do-more is in Run mode. Also make sure your PC is connected to the Do-more
Ethernet port or switch prior to placing the project in Run.

34) On the ribbon bar > 'Home' tab > Local management > select the Run button.

35) You should now see the seconds updating on your screen.

NOTE: If any part of the project doe not work as expected, switch back to the development application
(ALT+TAB) and then click Stop on the Home tab of the ribbon. Begin troubleshooting.
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Notes:
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