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Como comenzar con LookoutDirect
Este capítulo contiene los tres siguientes cursos guiados. Cada curso está diseñado para dar al
lector una  exposición práctica a LookoutDirect.

Curso de funciones básicas - introduce los fundamentos del ciclo de desarrollo de un proceso
con LookoutDirect. Usted usará las funciones más comunes de LookoutDirect para crear un
proceso que funcione localmente en su PC sin necesidad de una conexión entre la PC con
LookoutDirect y un PLC.

Curso de PLC conectado - suministra una demostración inmediata de comunicaciones
bidireccionales entre LookoutDirect y un PLC usando señales numéricas y lógicas. Para
completar este curso, la PC en la cual usted está haciendo funcionar LookoutDirect se debe
conectar correctamente con un controlador programable DirectLogic. 

Vea al apéndice B para más información sobre como establecer comunicaciones.

Curso de funciones avanzadas - le muestra cómo crear funcionalidad dentro de
LookoutDirect que usted puede usar para realzar y manejar los procesos que usted crea.

Para beneficiarse completamente de los cursos, le recomendamos que usted termine cada curso
en la orden dada. Antes de comenzar los cursos, asegúrese de que esté instalada la llave de
hardware provista para LookoutDirect. 

Sin la llave de hardware, la funcionalidad de LookoutDirect estará limitada a una hora de uso y
a diez puntos de entradas y salidas. 

Vea el capítulo 1, Sobre la llave de hardware, para más información sobre como usar la llave de
hardware.

Después de terminar los tres cursos, usted sentirá que usted está listo para comenzar a crear  su
propio proceso. 

Si usted quiere una información más profunda sobre LookoutDirect, lea el capítulo 4,
Fundamentos de LookoutDirect: Windows, herramientas, archivos, y nombres de trayectoria y el
capítulo 5, Usando LookoutDirect.
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Curso de funciones básicas 
En este curso, usted creará un proceso que contenga funciones simples asociadas a una planta
de tratamiento de aguas. El archivo de proceso terminado creado por este curso, con nombres
de archivo en inglés, se puede encontrar en 

C:\DirectSoft32\Projects\Examples\LookoutDirect\WaterWorks.l4p.

Usted puede encontrar útil tener el ejemplo del proceso abierto mientras se completa este curso.

Comenzando un nuevo proceso
Usted comenzará el ciclo de desarrollo de un proceso comenzando LookoutDirect, colocando un
nombre a su proceso, y creando su primer panel de control.

Nota: La primera vez que se comienza una versión de desarrollo de LookoutDirect, la cuenta del
administrador no tiene ninguna contraseña. En cualquier momento que la cuenta del administrador no tiene
contraseña, LookoutDirect se abre como administrador activo, sin requerir ninguna conexión. Esto es una
conveniencia para cuando se creen procesos de LookoutDirect, pero es mejor asignar una contraseña a la
cuenta del administrador antes de permitir a otros que no deban tener privilegios de administrador de usar
su copia de LookoutDirect. Vea como crear una cuenta más adelante en esta sección, para más información.

1. Haga clic en Start>Programs (Comienzo>Programas). Seleccione DirectSOFT32>
LookoutDirect Tools, y después haga clic en  LookoutDirect.

Aparece la pantalla principal de LookoutDirect. Cuando usted comienza un nuevo proceso,
LookoutDirect se abre en el modo de modificación (Edit mode).

2. Seleccione File>New.

Aparece el cuadro de diálogo Create Process.

3. En el cuadro Process Name, teclee  Tratamientoagua. Éste es el nombre del proceso de
ejemplo.

4. Teclee OK.
·   Aparece el cuadro de diálogo New Control Panel. Note que el panel de alarmas aparece en

el fondo de la pantalla principal.
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5. En el campoo Name, teclee PNLprincipal.
Éste es el nombre del objeto del panel de control. 

En la caja de Title (título), teclee  Principal. Éste es el título que aparecerá en la parte
superior del panel de control. El panel de control que usted creó sirve como plataforma en la
cual usted construirá y organizará el proceso.

Deje las propiedades restantes del cuadro de diálogo como están. Usted tendrá la oportunidad
de cambiar la manera que el control se vé más adelante en este curso.

Sugerencia Comience el nombre de cada objeto que usted crea con la abreviatura de dos o tres
letras para el tipo de objeto. Por ejemplo, la abreviatura  PNL se utiliza arriba para señalar  el
objeto panel. Si consistentemente usa esta convención de nombrar el obejto, usted podrá
localizar rápidamente objetos en el árbol de proceso del directorio que usted utilizará a través de
los tres cursos.

6. Teclee OK.

Aparece el nuevo panel de control Principal. Maximice el panel de control. Observe
que el título del panel de control se mueve a la barra del título de la ventana.

7.  Seleccione  Alarms>Display Options y configure el estilo de la ventana a Bottom y  la altura
de la ventana a 5  líneas.

Esto establece la localización y la cantidad de líneas de la ventana de alarmas.

Nota  Si la PC en la cual usted está creando un proceso no tiene la misma resolución del monitor que la  PC(s)
en el cual el proceso estará funcionado, configure la resolución del monitor de la PC de desarrollo a la misma
resolución del monitor de proceso a la resolución más baja en la cual usted espera que el proceso sea
mostrado .



Agregando un objeto  
Agregar objetos es la ación básica de construir un proceso en LookoutDirect. En esta parte, usted
comenzará agregando un objeto potenciómetro al nuevo panel de control. El potenciómetro será usado
para controlar el nivel de agua en un tanque simulado.

1. Seleccione Object >Object Explorer.

Aparece el cuadro de diálogo de Object Explorer . Note que el nombre de proceso Tratamientoagua
aparece en la estructura de archivos.  Arrastre el Object Explorer al lado derecho del panel de control
para mantenerlo apartado del panel de control.

Nota: ·El Object Explorer suministra una localización única, conveniente, desde donde usted puede tener
acceso y modificar el objeto que usted agrega a sus procesos de LookoutDirect. Vea al capítulo 4, Como
comenzar con LookoutDirect, Object Explorer para mas información de como usar el explorador del objetos.

2. Haga clic con el botón derecho en tratamientoagua, y seleccione New object. Aparece el
cuadro de diálogo Select object class.
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Haga clic con el botón derecho aquí para
obtener el cuadro de diálogo Select
Object Class 



3. Haga clic doble en la carpeta de Control, y después navege  la lista de objetos y destaque el
objeto Pot (potenciómetro).

La información de cualquier objeto que usted destaque (antes de seleccionar), en este caso el
objeto  potenciómetro, aparece a la derecha del cuadro de diálogo.

Nota  Desmarcando el cuadro de verificación de Categorize, situada en la parte superior  del cuadro de diálogo
Select Object Class, cambia el directorio del objeto desde un formato de carpeta a un formato continuo de
lista. Cuando está mostrado en un formato de lista, los objetos pueden ser encontrados tecleando la primera
letra del nombre del objeto. Cuando esté más familiarizado con los nombres de una cantidad de objetos,
usted encontrará esto útil para localizarlos de este modo.

4. Teclee OK.

Aparece la caja de diálogo Select location for new Object. El cuadro de diálogo muestra la
estructura de su red en un formato de árbol de directorios. En este ejemplo el nombre de su
computadora y del proceso tratamientoagua debería estar visible en el árbol del directorio.

5. Seleccione tratamientoagua, y después haga clic en OK.

Aparece el cuadro de diálogo de propiedades para el nuevo objeto potenciómetro.

6. Complete las propiedades del cuadro de diálogo.

Tag (Etiqueta) : POTNivelsim
Éste es el nombre del nuevo objeto potenciómetro.Observe que comenzamos el nombre del
nuevo objeto con la abreviatura de las tres letras de Potenciómetro.
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No a escala
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Mínimum y máximum: 0  y  50 respectivamente.

Para este objeto, los valores mínimo y máximo que usted entra representan el rango del
potenciómetro.

·  Resolución:  0.1
7. Deje las propiedades restantes del cuadro de diálogo como están y haga clic en OK.

8. Seleccione el nuevo objeto del árbol del explorador de objetos, y después arrástrelo y suéltelo
sobre el panel.

Aparece un cuadro de diálogo que contiene el gráfico que se puede utilizar para representar
el nuevo objeto del potenciómetro.

9. Seleccione el accionador vertical de potenciómetro y después haga clic en OK.

El nuevo objeto potenciómetro aparece en el panel de control.

Pruebe el potenciómetro nuevo con  Ctrl  +  espacio para salir o entrar del modo
Edit y luego haga clic y arrastre el accionador hacia arriba y hacia abajo con el puntero del
mouse. Vuelva al modo Edit cuando haya terminado.



Creando y trabajando con expresiones 
Ya que el objeto potenciómetro POTNivelsim tiene un rango numérico asociado, usted
puede representar visualmente el rango usando una expresión. Para este ejemplo, se creará una
expresión gráfica en la forma de un gráfico de barras y una expresión numérica en la forma de
un indicador digital.

1. Haga clic en Insert>Expresion.

Aparece el cuadro de diálogo Insert Expresion. El cuadro de diálogo Insert Expresion le
proporciona un método conveniente para localizar objetos y sus miembros de datos y para
copiarlos en una sola expresión.

2. Amplíe el árbol del directorio de la red en su PC haciendo clic en el símbolo + al lado
derecho del archivo tratamientoagua hasta que la lista de objetos en el proceso
tratamientoagua sea revelado y luego seleccione PotNivelsim.

Sugerencia Al hacer el proceso tratamientoagua la raíz del árbol del directorio, usted puede
evitar de tener que ampliar el árbol varias ocasiones, cada vez que desea seleccionar un objeto.
Para hacer el proceso tratamientoagua la raíz del árbol, haga clic en el botón derecho en
tratamientoagua y seleccione Make Root.

3.  Deje las propiedades restantes del cuadro de diálogo como están y haga clic en Paste (copie!).
POTNivelsim aparece en el campo amarillo de la expresión.

4.  Haga clic en OK.

Aparece el cuadro de diálogo Display numeric signal. Aparece este cuadro de diálogo
particular porque la propiedad tipo de exhibición, seleccionada por defecto en el cuadro de
diálogo Insert Expression, fue configurado como numérico. LookoutDirect le permite
seleccionar las propiedades de exhibición de las señales numéricas.

5. Termine el cuadro de diálogo Display numeric signal. 

Display Style (Estilo de la Exhibición):  Barra (para arriba) 

Bar Color (Color de la barra):  azul obscuro 

Mínimo y máximo: 0  y  50  respectivamente.

Observe que estos valores corresponden al rango que usted seleccionó previamente para el
objeto POTNivelsim.
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6. Deje las propiedades restantes del cuadro de diálogo como están y haga clic en OK.  El gráfico de barras
aparece en el panel de control.

Creando un indicador digital 
1. Seleccione el gráfico de barra, mantenga la tecla SHIFT (tecla de mayúsculas) apretada, y

luego arrastre el gráfico de barras en cualquier dirección y suéltelas.

Se crea una copia del gráfico de barras. Duplicar objetos de este modo es una manera
conveniente de crear nuevos objetos.

2. Haga clic en el botón derecho en el gráfico de barras duplicado y luego seleccione Display
Properties (propiedades de exhibición).

3. En la caja de grupo  Display style (estilo de exhibición), haga clic en Digital y después haga
clic en OK.

El formato de representación de la expresión duplicada cambia de un gráfico de barras a una
lectura digital. La lectura se exhibirá inicialmente como "####". Aumente la caja de
presentación de la lectura, arrastrando una esquina, para exhibir correctamente el valor
numérico y cambie el font a 20 y el formato numérico a 0.0.

4  Mueva el nuevo indicador digital a la derecha del gráfico de barras.

Salga fuera del modo de Edit, y después mueva el accionador del potenciómetro hacia arriba y
hacia abajo con el puntero del mouse para ver la función gráfica de ambas expresiones.  

La barra y el número cambiará de acuerdo a la posición del accionador del potenciómetro.
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Salvando el  proceso
Como con cualquier aplicación, es una buena idea salvar a menudo el proceso creado. 

1. Seleccione  File > Save.

Aparece el diálogo Select process to Save con el proceso tratamientoagua, el único abierto,
destacado.

2.Haga clic en OK y después haga clic en Save para salvar el proceso en el nombre de
tratamientoagua.l4p.

Conectando Objetos 
Anteriormente  en este curso, usted creó el objeto POTNivelsim y mostró gráficamente su valor
en un punto fijo en el tiempo usando un gráfico de barras. En esta parte del curso, usted creará
un objeto hypertrend que supervise el estado del objeto y mostrará POTNivelsim, en tiempo
real, su valor en la forma de una línea de gráfico en un registrador simulado.

Para comenzar, usted creará un objeto hypertrend, y después le asigna la señal del objeto
POTNivelsim al hypertrend. Para permitir al hypertrend exhibir la actividad del objeto
POTNivelsim, usted activará el registro en tiempo real de la señal POTNivelsim a una base de
datos histórica.

Cree el objeto Hypertrend 
1. En el Object Explorer, haga clic en el botón derecho en tratamientoagua y luego seleccione

New Object (nuevo objeto).
2. Localice y seleccione el objeto HyperTrend desde el árbol del directorio, debajo de Display

y  después haga clic en OK.

3. Seleccione el proceso tratamientoagua y haga clic en OK. 

Aparece el cuadro de diálogo Create HyperTrend.

4. En la caja de texto Name, teclee  HT tanque.

5. Haga clic en Add Group.

Aparece el cuadro de diálogo Add Group. La función del grupo le  permite que organice y que
exhiba lógicamente señales múltiples al mismo tiempo. En este ejemplo sin embargo, usted
agregará solamente una señal al grupo.

6. En la caja de texto Name, teclee  HT tanque, seleccione el azul obscuro como el Grid
color (color de la rejilla), y después haga clic en OK.

Agregue una señal al registrador gráfico Hypertrend 
1. Haga clic en Add Item en el cuadro de diálogo Create Hypertrend..

Aparece el cuadro de diálogo Add
Item. Las propiedades de este cuadro
de diálogo definen el origen de la señal
que usted está agregando al grupo
Nivel_agua_Tanque.
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2. Haga clic  el botón derecho en el campo verde
URL =.

Aparece el cuadro de diálogo URL Editor. El
cuadro de diálogo URL Editor se utiliza para
localizar rápidamente el origen de una señal
remota.

3. Amplíe el árbol del directorio, seleccione  el
objeto POTNivelsim, y haga clic en Paste.

El URL para  el objeto POTNivelsim se copia
en el campo verde del URL.

4. Haga clic en OK.

Aparece el origen, o el URL, de la señal POTNivelsim en el URL field del cuadro de diálogo
Add Item.

5. Seleccione rojo como el color para Line Color (color de línea), y después haga clic en OK.

El nuevo artículo se agrega al grupo de WaterTankTrend en el cuadro de diálogo Create
HyperTrend.

6.Haga clic en OK, y después seleccione el nuevo objeto del árbol del Object Explorer
(explorador de objetos) y arrástrelo y suéltelo sobre el panel.

Aparece un cuadro de diálogo que contiene los gráficos que se pueden utilizar para representar
el nuevo objeto.

7. Seleccione el gráfico deseado y haga clic en OK.

El nuevo registrador gráfico virtual  aparece en el panel de control.

8  Arrastre el nuevo registrador a la izquierda, y después modifique el tamaño arrastrando una
de las esquinas.  Ud. debe tener un panel como el mostrado en la próxima figura.
Los objetos que usted ha agregado al panel de control pueden parecer  ahora fuera de
proporción o mal arreglados. Usted limpiará el panel de control más adelante en este curso.
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Active la base de datos histórica
Si usted sale fuera del modo Edit  (Ctrl + Shift) y ajusta el nivel del objeto POTNivelsim,
usted notará que una línea del grafico no aparece en la carta hypertrend.  Para que la línea del
gráfico aparezca, usted debe primero activar el registro de datos en tiempo real del objeto
POTNivelsim a una base de datos histórica.

1. Vaya de nuevo al modo Edit y luego haga clic del botón derecho en el objeto POTNivelsim
en el explorador de objetos.

Aparece el cuadro de diálogo de Edit Object database (Modificación de la base de datos de
objetos).

2. Haga clic doble en el objeto POTNivelsim y luego en Edit Database .

Aparece el cuadro de diálogo de la base de datos. El título del cuadro de diálogo refleja el
nombre del objeto que usted está modificando.

3. En la caja de grupo Filter Group, teclee  0.1 para el desvío.

4. Haga clic en Log to historical database para marcar el cuadro(registro de base de datos
histórica). 
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5. Haga clic en Save, y después Quit.

Para probar el nuevo objeto hypertrend, salga del modo Edit y mueva el accionador del
potenciómetro hacia arriba y hacia abajo. Cuando mueve el accionador, aparece una línea roja
del gráfico que representa la señal del objeto POTNivelsim como línea de gráfico en el
registrador gráfico.

Creando interacciones útiles entre objetos
Para agregar un grado de automatización al proceso, usted ahora creará un segundo objeto
potenciómetro, esta vez en la forma de un selector de tres posiciones  manual-OFF-automático
(HOA); un objeto neutralzone que supervisará una banda muerta predeterminada del objeto
POTNivelsim y una expresión lógica que tomará la forma de un símbolo gráfico de una bomba
roja o verde y que tendrá como sus variables, miembros de datos de objetos del selector HOA
y del neutralzone. 
Juntos, estos objetos crearán una funcionalidad tal que encenderá automáticamente la bomba
(según lo simulado por nuestra expresión lógica) solamente cuando el interruptor HOA esté en
la posición automática y el POTNivelsim (nuestro nivel simulado del tanque de agua) esté entre
40 y 46.

Cree el selector Manual-OFF-Automático 
1.Utilice el explorador de objetos para agregar un nuevo objeto potenciómetro al proceso

tratamientoagua.

Después de que usted seleccione el proceso tratamientoagua como la localización para el
nuevo objeto, aparece el cuadro de diálogo New Potentiometer (nuevo potenciómetro).

2. Complete el cuadro de diálogo del New Potentiometer:

Name (nombre) : POTHOA 
Mínimo: 1 
Éste es el extremo inferior del rango del potenciómetro.
Máximo:  3 
Éste es el alto extremo del rango del potenciómetro.
Resolución:  1 

Utilizamos uno como la resolución del potenciómetro puesto que queremos que el rango del
potenciómetro sea dividido en segmentos en tres partes: manual, OFF, y automático.

Deje las propiedades de cuadro de diálogo como están.

Manual de cómo comenzar LookOutDirect 3–13

Capítulo 3:  Como comenzar con LookoutDirect

1

2

3

4

5

6

7

8

9

10

11

12

13

14

A

B

C

D



3. Haga clic en OK.

4. Seleccione el nuevo objeto del árbol del explorador de objetos, y después arrástrelo sobre el
panel.
Aparece el cuadro de diálogo Insert (POTHOA). 

5. Seleccione el gráfico knob (perilla), y después haga clic en OK.

6. Arrastre la perilla a un área abierta en el panel de control.
Salga fuera del modo Edit y pruebe el nuevo selector de tres posiciones. 

Por ahora, dejaremos las posiciones del interruptor sin rótulos. Más adelante en el curso
agregaremos las placas de identificación descriptivas para ayudar a identificar cada posición del
interruptor.

Cree el objeto Neutralzone 
1. Utilice el explorador de objetos para agregar un nuevo objeto Neutralzone al proceso

tratamientoagua.

Después de que usted seleccione el proceso tratamientoagua como la localización para el nuevo
objeto, aparece el cuadro de diálogo Create Neutralzone.

2. Termine el cuadro de diálogo Create Neutralzone.
Nombre: NZPumpAuto 
Éste es el nombre del nuevo objeto.
Señal: POTNivelsim
Esto señala que es el valor del objeto POTNivelsim que se está asignando una zona neutra
(banda muerta).

Sugerencia si nuestro proceso del ejemplo es complejo, y usted no está seguro de la localización
o nombre exacto del objeto POTNivelsim, usted podría hacer clic en el botón derecho en en la
caja de texto amarilla para  exhibir Expression Editor (Editor de  expresión).

Usando el editor de expresión, usted podría localizar el objeto POTNivelsim (señal) y después
utilizar la función Paste.
High límit (limite superior): 46 

Low Limit (Límite bajo):      40
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3. Haga clic en OK

Cree la expresión lógica
1. Seleccione Insert>Expression.

Aparece el cuadro de diálogo Expression Editor (redactor de expresión).

2. En la caja de texto amarilla de la expresión, teclee 

·               POTHOA = 1 or (POTHOA = 3 and NZPumpAuto.below).
Esta expresión coloca una condición tal que la bomba funcionará solamente si el selector
HOA está en la posición 1 o  en la posición tres (automático)  y  el nivel del tanque está dentro
de la banda muerta (Neutralzone).

3. Haga clic en OK.

Aparece el cuadro de diálogo Display logical signal (Muestre la señal lógica) porque el tipo
de exhibición por defecto para una expresión es una señal lógica. De este cuadro de diálogo
se puede seleccionar cómo quiera que sea mostrado el resultado lógico de la expresión.

4. Haga clic en  Custom, y después haga clic en  la caja gráfica ON.

Aparece el diálogo Select Graphic.
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5.Navegue a la carpeta Pumps (bombas) y luego haga clic doble en el gráfico de la bomba verde
Pmp_3gn.wmf.

El gráfico de la bomba aparece en  el cuadro de diálogo Display logical signal  como  el gráfico
ON. 

6. Haga clic en la caja de grupo gráfica  OFF y luego haga clic doble en el gráfico de la bomba
roja  Pmp_3rd.wmf.

Ahora se puede seleccionar ambas cajas de grupo gráficas ON y OFF .

7. Haga clic en OK.

Aparece el gráfico verde de la bomba  en el panel de control.

8. Arrastre la bomba a la derecha del panel de control.

Para probar la nueva funcionalidad, salga del modo Edit y arrastre el accionador en el selector
POTHOA con el puntero del mouse desde la posición izquierda (posición 1 o manual) a la
posición del mediodía  (posición  2 u OFF) para ver el cambio gráfico de la bomba del verde
al rojo. 

Ahora arrastre el accionador a la posición a la derecha (posición 3 o automática), y después
deslice el potenciómetro POTNivelsim hacia arriba y hacia abajo. El gráfico de la bomba debe
hacerse verde cuando el POTNivelsim está entre 40 y 46.
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Completando el panel de control 
Ahora que se ha creado la funcionalidad para el proceso tratamientoagua, el panel de control
debe parecerse a la ilustración siguiente.

Para hacer el panel de control intuitivo y fácil de usar, ahora se ajustará el tamaño y se
arreglarán los objetos y se agregarán varios gráficos, placas de legenda y  escalas.

Ajustando el tamaño y arreglando objetos en el panel  de control 

1. Asegúrese de que usted esté en el modo Edit y luego seleccione el registrador gráfico
HyperTrend y ajuste el  tamaño de modo que tome aproximadamente la mitad del panel de
control.

2. Arrastre el registrador gráfico al lado izquierdo del panel de control.

3. Seleccione, ajuste el tamaño, y arregle cada uno de los objetos restantes hasta que su panel de
control parezca similar a la ilustración  que sigue.



Agregando símbolos gráficos 
1. Seleccione Insert>Graphic, abra la carpeta Tanks, y haga clic doble en el gráfico
Tank1_A.wmf.
El gráfico del tanque aparece en el panel de control.  El gráfico del tanque servirá como
plantilla sobre el gráfico de barras que da el aspecto de que el nivel del agua sube y baja en el
tanque.

2. Ajuste el tamaño del gráfico de barras y el tanque hasta que la porción azul del gráfico de
barras llene el tanque en su punto más ancho. Usted puede necesitar salir al modo Edit y
ajustar  el potenciómetro POTNivelsim para comprobar la configuración del tanque sobre el
gráfico de barras.

3.Mueva el indicador digital  del POTNivelsim al centro del tanque.

Cuando complete ésto, su panel de control debe parecer similar a la ilustración siguiente.
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Agregando etiquetas
En este procedimiento usted creará las placas de legenda para etiquetar las tres posiciones del
selector HOA.

1. Seleccione Insert>Text/Plate/Inset.

Aparece el cuadro de diálogo Inset>Text/Plate/Insert. Utilice este cuadro de diálogo para
diseñar etiquetas  y para agregar un fondo al panel de control. Las opciones de diseño
disponibles incluyen  cambiar el estilo de la placa de fondo: tipo, color, y tamaño  y
justificación del texto.

2. En la caja de texto, teclee manual, y después seleccione negro para el color del texto.
Mientras usted teclea, el texto aparece en la ventana de la inspección en el font de texto por
defecto (10 pintas.Arial, en negrilla).

Usted puede experimentar con otros fonts, colores de fondo y  estilos de marco o usted puede
aceptar las configuraciones por defecto.

3. Teclee OK.

4. Arrastre la placa nueva de texto al lado izquierdo del selector HOA.

5. Con  el método de tecla Shift + arrastre, haga dos copias duplicadas  de la placa de texto
manual, y después mueva una de las placas de texto a la parte superior del selector HOA y la
otra a la derecha del selector HOA.

6. Cambie el texto de la placa media del texto a OFF y el texto de la placa derecha a Auto,
haciendo clic derecho en cada placa de texto, seleccionando Display properties
(características de exhibición) y después corrija el contenido de la caja de texto.

7. Para hacer más fácil colocar en la posición deseada el selector HOA  y las placas de texto,
arrastre una caja alrededor de los cuatro objetos y luego seleccione Arrange >Group.
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Agregando escala a objetos 
Realce la utilidad del objeto registrador gráfico hypertrend y del potenciómetro de POTNivelsim
agregando barras de escala.

1. Seleccione Insert>Scale.

·   Aparece el cuadro de diálogo Insert Scale. 

2. Termine el cuadro de diálogo.
Caja de grupo Orientation:  Right side (derecha), estilo Increasing up define la orientación.

·   Mínimo: 0 

·   Máximo: 50 

Mayor unit (Unidad Importante): 10 

Minor Unit (Unidad de menor importancia): 2.5 

3. Deje las otras características como están y haga clic en OK.
4. Arrastre la nueva escala a la derecha del registrador gráfico hypertrend y ajuste el tamaño para

alinear con la parte superior e inferior del registrador.

Para tener más lugar a la derecha del registrador, usted ahora cambiará las propiedades de
exhibición del potenciómetro POTNivelsim de un accionador vertical a un accionador
horizontal y agregará una escala a ella.

5. Haga clic derecho en el potenciómetro POTNivelsim y seleccione Display properties
(características de exhibición).

6. Seleccione el accionador horizontal (Horizontal slider), y después haga clic en OK.

7. Mueva el accionador horizontal para abajo y ajuste el tamaño al ancho del registrador.

8. Duplique la escala usada a la derecha del registrador, cambie las propiedades de exhibición de
la escala a Bottom, increasing right (abajo, aumentando a la derecha), muévalas debajo del
accionador horizontal, y después ajuste el tamaño de la escala para caber el accionador.



Para practicar, termine de complementar el panel de control con lo siguiente:

• agregue placas de texto, sin cualquier texto, detrás del selector HOA y del accionador
horizontal, 

• Coloque un texto de etiqueta del registrador, 

• Ajuste el tamaño y arregle el tanque sobre el grupo del selector HOA

• remueva la placas desde las etiquetas de posición del selector HOA

• mueva del indicador digital del POTNivelsim dentro de la parte superior del gráfico del
tanque, y 

• cree y coloque una placa grande de texto, sin texto, detrás de todos los objetos en el panel
de control usando los comandos suministrados en el menú Arrange (Arregle).

Cuando está acabado, su panel de control debe parecer similar a la ilustración siguiente.
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Agregando alarmas 
Para terminar el curso básico, usted ahora agregará funciones de alarmas al proceso
tratamientoagua. Usted creará una alarma simple y una alarma generada por la base de datos. 

Una alarma simple es un objeto de alarmas que se activa solamente cuando se cumple una
condición en un parámetro de alarma específico. 
Una alarma generada por la  base de datos se diferencia de una alarma simple en que puede
utilizar el valor o la condición de uno o más miembros de datos de un objeto existente para sus
parámetros de activación.

Por propósitos de organización se pueden clasificar alarmas en áreas. Estas áreas de alarmas le
permiten a los operadores filtrar grupos de alarmas y reconocer alarmas de acuerdo a areas.
LookoutDirect tiene varias áreas por defecto o tambin se pueden crear áreas 

Cuando se crea una área de alarma, LookoutDirect crea una carpeta en el objeto global $Alarm
para mantener esas alarmas. Una de las áreas es el área LookoutDirect.

Creando una alarma simple
1. Utilice el explorador de objetos para agregar un nuevo objeto Alarm (alarma) al proceso

tratamientoagua.

Aparece  el cuadro de diálogo Create Alarm (crear alarmas) .

2. Complete el cuadro de diálogo.
Nombre: Alarm Man Mode
Alarm Area: Lookoutdirect 
Message: "bomba en modo manual"
Éste es el mensaje que aparecerá en el panel de alarma. Note que el texto del mensaje se debe
incluir entre comillas.
Condition: POTHOA=1
Esta expresión simple especifica que la alarma se debe activar cuando el selector POTHOA
está en la posición manual .

3. Deje las otras características como están y haga clic en OK.

Salga fuera del modo Edit y coloque el interruptor POTHOA en Manual.  La alarma que usted
ha creado se debe activar. Para silenciar esta alarma, haga clic derecho en el panel de alarmas y
seleccione Acknowledge All (reconozca todas las alarmas). Usted puede incorporar un
comentario para la alarma o solamente haga clic en OK.



Creando una alarma generada por la base de datos
1. En explorador de objetos, en el proceso tratamientoagua, Haga clic en el botón derecho en el

objeto POTNivelsim y  luego seleccione Edit database. 

Aparece el diálogo de la base de datos para el objeto POTNivelsim. 

2. Complete las propiedades de la caja de grupo Alarm Conditions (condiciones de alarma). 
• Área:  Lookoutdirect
• HiHi:  48, prioridad  8 
• Hi:  42, prioridad  6
• Lo:  22, prioridad  5 
• LoLo: 10, prioridad  7 
• Deadband:  3 

Estas características especifican que debe activarse una alarma cuando el valor numérico del
objeto POTNivelsim es  48, 42, 22, o 10. 

3. Haga clic en Update y luego Quit.

Salga fuera del modo Edit y mueva el potenciómetro hacia uno y otro lado. Mientras que el
valor numérico del objeto POTNivelsim cambia, cada alarma se activa correspondientemente. 
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Curso de PLC conectado 
Si usted ya ha instalado su PLC y las comunicaciones están establecidas entre el PLC y la PC
donde está funcionando LookoutDirect , este curso demostrará la capacidad de leer y de escribir
datos numéricos con LookoutDirect desde su PLC. Si usted no ha configurado ya su PLC o no
ha establecido comunicaciones entre el PLC y la PC que tiene funcionando LookoutDirect, vea
al Apéndice B.

Los ejemplos en este curso muestran los tipos siguientes de conexión entre LookoutDirect y su
PLC.

• Como usar un interruptor virtual para accionar ON y OFF a una salida discreta del PLC.
• Como escribir un valor numérico a un registro del PLC, y después leer el valor de vuelta y

mostrarlo en la forma de una línea virtual en el registrador gráfico. 

• Como leer una señal discreta desde el PLC y usar una expresión gráfica para mostrar el
estado de la señal con la ayuda de un indicador luminoso y 

• Como usar un contador digital para mostrar el número de barridos desde la última vez que
se energizó el PLC o hubo una transición  del modo Program para Run.

El archivo de proceso del ejemplo usado para este curso se puede encontrar en 

C:\DirectSoft32\Projects\Examples\LookoutDirect\ConnectedTour.l4p.

Vea el curso básico para información sobre cómo crear y manejar objetos usando LookoutDirect.

Accionando una salida discreta del PLC
En este ejemplo, usted creará un objeto driver, y después conectará el objeto a una salida discreta
en su PLC usando una conexión nueva o existente. Para probar la conexión entre el objeto
driver y su PLC, usted creará un objeto switch (interruptor) para accionar  la salida discreta. Para
indicar el estado de la salida en el panel de control, usted creará una expresión lógica en la forma
de un indicador luminoso.

Creando el objeto del driver

1. Cree un nuevo proceso. Utilice ConnectedTour como el nombre de etiqueta y
PNLConnectedTour como el título del panel de control.

2. Seleccione Object>Object Explorer.

Mueva el diálogo “explorador de objetos” a la derecha de la exhibición.

3. Use el explorador de objetos para agregar un nuevo objeto driver DirectLogic al proceso
ConnectedTour.

Aparece el diálogo Create  DirectLogic como en la primera figura de la próxima página.

4. Coloque el nombre del objeto driver como DRConnectedTour, y después haga clic en el botón
de 3 puntos a la derecha de la caja de texto de Comm Link.. (Vea la figura siguiente)

Nota:  cuando usted cree sus propios objetos driver, use el prefijo DR para identificar el objeto como un driver
y nombre la CPU de su PLC como el sufijo de la etiqueta.



Aparece el cuadro de diálogo Select Link (seleccione conexiones).

5. Haga una de las acciones siguientes:.
• Si la caja de lista de Links (conexiones) contiene los puentes de comunicaciones activos

encontrados por el mago de conexiones durante el proceso de instalación, destaque la
conexión que usted desea usar.

• Si no hay una conexión activa disponible, o, si usted no desea usar una de las conexions
activas, haga clic en Add, y luego siga las instrucciones suministradas en el Link Wizard
(mago de conexiones). Haga clic en Finish para cerrar al mago.

6. En el cuadro de diálogo Select Links, haga clic en Select.

Aparece el nombre de la nueva conexión en el campo de texto Comm Link.

7. Haga clic en OK, y después corresponde crear el objeto interruptor. 

Creando el objeto Switch (interruptor)
1. Use el explorador de objetos para agregar el nuevo objeto Switch (interruptor) al proceso

ConnectedTour.

Aparece el cuadro de diálogo New switch (nuevo interruptor).
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2. Coloque el nombre SWsalidadiscreta al interruptor, y después haga clic en OK.

Aparece el cuadro de diálogo Display switch (Muestre un interruptor).

3. Seleccione una de las opciones de interruptor estándares, y después haga clic en OK.
Aparece el interruptor en el panel de control ConnectedTour. 

4.  Continúe con las instrucciones de más abajo. 

Ligando el objeto del interruptor a una salida del PLC 
1. En Object Explorer (explorador de objetos), haga clic el el botón derecho en el objeto

DRConnectedTour y luego seleccione Edit Connections (modifique la conexión).

Aparece el cuadro de diálogo de conexiones para el objeto driver.
2. En la lista Writable Members (miembros escribibles), haga clic doble en el miembro Y0. Si

el miembro Y0 está en uso, seleccione a cualquier otro miembro disponible y escribible de
datos y luego haga clic en el botón Select. (En este caso es Y5)

3. En la caja de grupo Signals (señales), navegue con el árbol del directorio al proceso
ConnectedTour y luego haga clic doble en SWsalidaDiscreta.

Mire en el centro del cuadro de diálogo de conexiones. Note que la conexión entre el objeto del
driver y el interruptor está definida como: 

DRConnectedTour.Y5 = SWsalidadiscreta.

4. Haga clic en Accept, y después Quit..
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Creando un indicador luminoso 
1. Seleccione Insert>Expression,  seleccione SWsalidaDiscreta del árbol del directorio, haga clic

doble en el campo Contents y luego haga clic en OK.

Aparece el cuadro de diálogo exhibición de la señal lógica.

2. Haga clic en Costum, y después haga clic en la caja de grupo ON.

3. Abra la carpeta Indicators y luego haga clic doble  en la luz verde nombrada  Light0G.wmf.

4. Haga clic en la caja de grupo OFF y luego haga clic doble  en la luz roja nombrada
Light0R.wmf.

5. Haga clic en OK

Aparece el indicador luminoso que representa la expresión lógica.

Salga fuera del modo Edit y pruebe la conexión  entre el objeto interruptor de LookoutDirect
y el PLC. 

Cuando el interruptor está encendido, la salida LED en el PLC y el indicador virtual en el
panel de control debe encenderse. Si la conexión no trabajó y ocurrió un error de alarma,
compruebe la conexión desde la PC al PLC. Si la conexión no trabajó y no ocurrió ningún
error de alarma, hay un problema con la configuración de la conexión. 

Repase este procedimiento y confirme que la conexión fue configurada correctamente.

Manual de cómo comenzar LookOutDirect 3–27

Capítulo 3:  Como comenzar con LookoutDirect

1

2

3

4

5

6

7

8

9

10

11

12

13

14

A

B

C

D



Escribiendo y leyendo un valor numérico 
En este ejemplo, usted utilizará un objeto potenciómetro, en la forma de una entrada digital,
para escribir un valor numérico al PLC. Para confirmar que los datos se están escribiendo al
PLC, usted creará un objeto hypertrend para leer y para exhibir los valores numéricos enviados
al PLC.

Creando el objeto potenciómetro
1. Cree un nuevo objeto  potenciómetro digital. Utilice los valores siguientes para completar el

cuadro de diálogo nuevo potenciómetro.
• · Name: PotNumRWTest
• Min: 0
• Max: 9999 
•   Resolution: 1

2. Haga clic en OK.

Conectando el objeto potenciómetro con  el PLC
1. En el diálogo explorador de objetos, haga clic derecho en el objeto DRConnectedTour y luego

seleccione Edit connection.

2. En la lista de miembros escribibles, haga clic doble  en V1400-7377. V1400 aparece en la caja
de la selección. 

3. Substituya la selección V1400 por V2000.

Nota:  Se utiliza el registro V2000 puesto que es común a todos los PLCs DirectLogic  .

4. En la caja de grupo Signals (señales), haga clic doble en el objeto PotNumRWTest.
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5. Haga clic en Accept, y después Quit.
Aparece el nuevo potenciómetro digital en el panel de control. 

Creando el objeto Hypertrend
1. Cree un nuevo objeto hypertrend nombrado HyperRWTest.

2. Agregue un grupo al hypertrend. Use los valores siguientes para completar  el cuadro de
diálogo Add Group.
• Name (Nombre): RWTest 
• Major Increments (Incrementos importantes): 10 
• Minor Increments (Incrementos de menor importancia):  1 

3. Agregue un artículo al grupo RWTest. Utilice los valores siguientes para completar el cuadro
de diálogo Add Group (Agregue un grupo).
• Mínimo Numérico: 0 
• Máximo Numérico: 9999 

4. Haga clic en el botón derecho en el campo URL =.

5. En el cuadro de diálogo URL Editor (redactor de URL), destaque DRConnectedTour y luego
haga clic doble  en V1400-7377 en el campo Contents (contenido).

6. En la caja de texto URL, substituya V1400 por V2000, y después haga clic en OK.

7. Haga clic en OK en las cajas de diálogo  Add Item y Create  HyperTrend. Aparece el nuevo
objeto hypertrend en el panel de control.
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8. Active el registro de datos para el nuevo objeto hypertrend. Seleccione Object>Edit Database
y seleccione el objeto DRConnectedTour.

9. En la lista Native members (miembros nativos), haga clic doble  en V1400-1737, substituya
V1400 por V2000, y después actualice el cuadro de diálogo de la base de datos.

• Deviation: 0.
1

• Log to Historical Database (Registro a base de datos histórica):  selected.

10. Haga clic en Update y luego Quit.
Pruebe la conexión entre el potenciómetro y el PLC saliendo del modo Edit, haciendo clic en
el objeto potenciómetro, y entrando un nuevo valor. El objeto hypertrend muestra el cambio al
valor entrado. 

Lectura de una señal discreta
En el ejemplo anterior, usted podía activar una salida discreta de un PLC usando el objeto
interruptor. En este ejemplo, usted leerá una señal discreta del PLC y exhibirá el estado usando
un objeto indicador luminoso.

1. Seleccione Insert>Expression.

2. En el cuadro de diálogo Insert>Expression, haga clic doble en el objeto DRConnectedTour.
3. Corrija el campo amarillo de la expresión de modo que la expresión muestre:  

DRConnectedTour.SP4 y luego haga clic en OK.

Nota:    El relevador especial SP4 se refiere a una función especial de relevador en el controlador DirectLogic
que suministra una señal de pulso con un período de un segundo.

4. En la caja de grupo Standard, seleccione cualquier indicador luminoso y después haga clic
en OK.

La expresión lógica, en la forma de indicador luminoso que usted seleccionó, aparece en el
panel de control y comienza a destellar en un intervalo de un segundo.

Para confirmar que la expresión está exhibiendo la señal del relevador SP4, salga fuera del modo
Edit, apague el PLC, y observe que el indicador para de destellar.



Mostrando el número de barridos
En este ejemplo del curso de PLC conectado, usted creará una expresión numérica que muestre
continuamente el total instantáneo del número de barridos realizados por su controlador
DirectLogic.

1. Seleccione Insert>Expression.
2. En el cuadro de diálogo Insert>Expression, haga clic doble en el objeto DRConnectedTour.

3. Corrija el campo amarillo de la expresión de modo que la expresión muestre:
DRConnectedTour.V7765:B, donde ":B"es el modificador de los datos que especifica la
conversión de datos al formato BCD. 
Vea el apéndice B, Modificadores de datos, para más información de como usar modificadores de
datos.

4. En la lista Display type (tipo de exhibición), seleccione Numeric y luego haga clic en OK.

5. En  el cuadro de diálogo Display Numeric Signal, acepte las configuraciones por defecto y
haga clic en OK.

Aparece la lectura numérica en el panel de control y comienza inmediatamente a exhibir el
número total de barridos.
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Curso de funciones avanzadas 

Muchas de las funciones de LookoutDirect, como paneles de control, funciones de alarmas,
servicios de seguridad, etc. son ellas mismas parte de una clase de objetos y pueden, por lo tanto,
ser modificados para requisitos particulares y crear funciones útiles de administración del
proceso.

Este curso le presentará algunas de las propiedades avanzadas de LookoutDirect que usted puede
utilizar para mejorar  y manejar un proceso.

En este curso usted :

• crea botones que permitirán que usted navegue rápidamente entre los paneles de control, 

• importa un gráfico hecho por Ud. en un panel de control de proceso, 

• establece permisos de seguridad para limitar acceso a todos o una parte del proceso y 

• crea un registro de datos para registrar actividades de proceso a una hoja de cálculo 

Este curso asume que usted entiende los conceptos del proceso de desarrollo introducidos en el
curso básico.

Creando botones de navegación entre paneles 
En situaciones donde LookoutDirect está instalado en un panel con celdas táctiles (touch
screen), donde no hay disponible un mouse de la PC, puede ser necesario suministrar medios
de navegación entre los paneles de control de proceso. 

En este ejemplo usted creará un sistema de botones simples que permitan que usted navegue
entre el panel de control PNLConnectedTour y un panel nuevo que usted creará en este ejemplo. 

La segunda porción de este ejemplo explica cómo crear un "panel pricipal" para su proceso.

La funcionalidad creada en este ejemplo se puede encontrar en el archivo de proceso de
ConnectedTour.l4p en la carpeta de ejemplos.

1. Cree un nuevo objeto de panel nombrado PNLNavTest en el proceso ConnectedTour. Dé a
panel el título Prueba de navegación. 

2. Seleccione el panel de control PNLConnectedTour.

3. Cree un nuevo objeto de botón nombrado PBNavTest.  En la caja Button Text, teclee
Prueba de navegacisn.

4. En explorador de objetos, haga clic en el botón derecho en el objeto PNLNavTest y luego
seleccione Edit connection.

Aparece el cuadro de diálogo Edit Connection.

5. En la lista Writable members (miembros escribibles), haga clic doble en activate y luego haga
clic doble  en PBNavTest en el árbol del directorio del grupo Signals (señales).
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Aparece la conexión lógica que usted acaba de crear entre el panel Prueba de navegación y el
botón  de Prueba de navegación en el centro del cuadro de diálogo.

Nota · Tome un momento para repasar la lista de miembros escribibles para aprender sobre otras acciones
que usted puede generar al corregir una conexión.

6. Haga clic en Accept, y después Quit.

Pruebe el botón nuevo de control entre paneles  saliendo fuera del modo Edit y haciendo clic
en el nuevo botón.

Continúe creando un segundo botón para volver al panel del curso de PLC conectado.

7. Con el panel de prueba de navegación todavía seleccionado, cree un nuevo objeto de botón
nombrado PBNavTestReturn.  Teclee  Return para el texto del botón.

8. En explorador de objetos, haga clic en el botón derecho en el objeto PNLConnectedTour y
luego seleccione Edit Connection. 

9. En la lista de miembros escribibles, haga clic doble en activate y luego haga clic doble  en
PBNavTestReturn en el árbol del directorio del grupo de señales.

Aparece  en el centro del cuadro de diálogo la conexión lógica que usted acaba de crear entre
el panel de control Prueba de navegación y el nuevo botón Return.

Salga fuera del modo Edit y pruebe el nuevo botón Re
tu
rn

. 

Creando un panel Home
Para que los usuarios estén seguros  de que no se pierdan al cambiar entre paneles, usted puede
ser que defina un panel principal como su panel de control de inicio, o panel Home o panel con
el menú pricipal de la computadora.

Usted podría conectar al miembro de datos de activar de su panel Home  a
<$Keyboard.Shift.F1>, o talvez con un objeto botón. 

Si está conectado con la tecla de funcionamiento, en cualquier momento que el usuario presione
< Shift-F1 > (no importa qué panel se esté viendo), aparece el panel Home, lo que hace que  el
operador vuelva a un panel de control familiar.



Puede ser que también se quiera que el panel Home se maximice durante el incio. Si usted ha
creado ya un botón para llamar el panel Home, usted puede conectarlo con el miembro de datos
de maximización.

El punto de exclamación (!) manda a LookoutDirect a utilizar el contrario del valor del botón.
En la partida, el botón no se presiona de modo que su valor es FALSO. Pero ya que usted está
usando el contrario del valor del botón, Panel1.maximize es TRUE en la partida. En cualquier
momento que un usuario presione CallHomePb después de que se haga esta conexión, nada
sucede hasta que el botón sea soltado, y en ese momento aparece el panel.

Importando símbolos gráficos 
Aunque la biblioteca de símbolos gráficos de LookoutDirect es muy grande, usted puede desear
de vez en cuando modificar un panel de control para requisitos particulares de proceso usando
sus propios gráficos. 

Usted puede importar gráficos salvados en el formato metafile(.wmf) o el archivo BITMAP
(.bmp)  de Windows. Para inserir su propio símbolo gráfico, primero salve los símbolos gráficos
en C:\DirectSOFT32\Bin\Graphics, y después insiéralo usando el comando Insert>Graphic.

Creando botones de administración de alarmas
Para reconocer más eficientemente alarmas de proceso, usted puede crear  objetos de botón que
pueden reconocer o silenciar una alarma con un solo clic en el mouse. Normalmente, la acción
de reconocimiento y de silenciar las alarmas requiere un procedimiento de varios pasos que se
debe ejecutar desde el menú de alarmas.

La funcionalidad creada en este ejemplo se puede encontrar en el archivo de proceso
ConnectedTour.l4p en la carpeta de ejemplos.

1. Cree dos nuevos objetos de botón, uno nombrado PBAlarmAck con la Rec Alarma como
texto del botón y el otro PBAlarmSilence nombrado con Silencio como texto del botón.

2. En explorador de objetos, haga clic en el botón derecho en el objeto $Alarm y luego
seleccione  Edit Connection.

Aparece el cuadro de diálogo $Alarm>Connections.

3. En la caja de lista de los miembros escribibles, haga clic doble en Ack y luego, en el árbol del
directorio de las señales, haga clic doble en PBAlarmAck.

Aparece la conexión lógica que suministra la funcion de alarma de reconocimiento automático
en el centro del cuadro de diálogo.

4. Haga clic en Accept.
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5. En la caja de lista de miembros escribibles haga clic doble en Silence, y luego en el árbol del
directorio de las señales, haga clic doble en PBAlarmSilence.

Aparece la conexión lógica que suministra la función de silenciar la alarma en el centro del
cuadro de diálogo.

6. Haga clic en Quit.

Objeto para establecer permiso de seguridad
Para prevenir cambios no autorizados o accidentales a su proceso, usted puede restringir el
acceso a objetos específicos de ciertos niveles del proceso usando permisos de seguridad.
Típicamente, los permisos de seguridad se asignan a objetos del tipo de control tales como
potenciómetros, interruptores, etc., pero pueden también ser asignados al proceso en su
totalidad o a un panel de control dentro del proceso. 

Cuando un usuario, que se registra en el proceso en una cuenta válida que contiene el nivel de
seguridad, trata de tener acceso a un objeto con un permiso de seguridad,  se compara el nivel
de seguridad  del usuario con el del objeto, y se concede o se niega el acceso al objeto.

Creando una cuenta de usuario
Complete el procedimiento siguiente para crear cuentas para cuatro usuarios ficticios. 

1. Seleccione Options > User Manager.

Aparece el cuadro de diálogo User Manager. 

2. Seleccione New User (Nuevo Usuario).

Aparece un  cuadro de diálogo New User (nuevo usuario).

3. Cree el primero de los cuatro usuarios completando el cuadro de diálogoNew User. 

Username : User1

Full Name (Nombre): UserOne
Password (Contraseña): 1111 

Condirm password (Confirme la contraseña): 1111 

Security level (Nivel de seguridad) = 1  

4  Haga clic en OK.

Aparece User1 en la ventana User manager.
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5. Repita el paso 2 hasta el  4 para crear las cuentas para los usuarios nombrados User2, User3
y User4.

Use 2222 como contraseña de User2 y asigne un nivel de seguridad 2. 
Continúe esta secuencia para los otros tres usuarios.

Configurando el nivel de seguridad de un objeto 
1. Abra el archivo de proceso BasicSecurity.L4p situado en la carpeta de ejemplos.

Este proceso contiene un panel de control con cuatro objetos simples.

2. Haga clic en el botón derecho en Switch #1 y seleccione Object Properties. 

3. En el cuadro de diálogo Control security level (nivel de seguridad de control), teclee 1.

4. Modifique las propiedades del objeto para cada uno de los tres interruptores restantes,
configurando su nivel de seguridad  a 2, a 3, y a 4 respectivamente.

Para probar los niveles de la seguridad que usted estableció para los cuatro interruptores, usted
ahora se registrará en LookoutDirect con cada una de las cuentas de usuario que usted creó.

5.  Seleccione  "File> Log On” .
Aparece el diálogo Login.

6. Haga Log in como User1 (password=1111) y luego haga clic en OK.

7. Salga fuera del modo Edit y active el interruptor # 1. Ahora trate de activar cualquiera de los
otros interruptores.

Cuando usted lleva el cursor del mouse al interruptor # 2, 3, o 4, note que el cursor cambia
a un símbolo de prohibición. El símbolo de prohibición indica que la cuenta corriente no
tiene permiso para usar estos controles.



8. Haga el Log in como User2 y luego User3 y finalmente User4; cada vez que usted se abre una
sesión como nuevo usuario, trate de activar los interruptores restantes para ver a cuáles tiene
acceso.

Registro de datos de proceso
Una característica extremadamente valiosa de LookoutDirect es su capacidad de registrar eventos
de proceso para archivar. Usando el objeto de registro Spreadsheet (hoja de cálculo) usted puede
salvar dinámicamente el estado o el valor de cualquier miembro de datos a un archivo de hoja
de cálculo con archivos de formato de valor separado por coma (.CSV).

En este ejemplo, usted creará un objeto de registro en una hoja de cálculo para registrar, en
intervalos de 10 segundos, el valor de dos objetos que usted creó durante el curso conectado.
Para automatizar el proceso del registro de datos, usted creará un objeto botón y  un indicador
para comenzar el proceso de registro.

La funcionalidad creada en este ejemplo se puede encontrar en el archivo de proceso
WaterWorks.l4p en la carpeta de ejemplos.

Creando el objeto hoja de cálculo 
1. Abra el archivo de proceso tratamientoagua en la carpeta de ejemplos y después maximice el

panel de control Overview.

2. Agregue un nuevo objeto Spreadsheet (hoja de cálculo) al proceso tratamientoagua.

Aparece el diálogo Create Spreadsheer storage Object (creación del objeto de almacenaje de
la hoja de cálculo). 

3. Complete las propiedades del cuadro de diálogo.
• Name: SSDataLogging
• File configuration/File name: "ProcessData"
El nombre del archivo completo debe aparecer como ProcessData.csv.
• Interval Logging/Interval (Intervalo): 00:00:10.00 

Esto especifica que los datos serán escritos al archivo de la hoja de cálculo cada 10 segundos.

4. En el grupo Data fields, seleccione New Field (nuevo campo) y luego haga clic en el botón
derecho en la caja de texto amarilla de la expresión.

Aparece el redactor de la expresión.
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5. En el grupo Signals del árbol del directorio, seleccione el objeto POTNivelsim, haga clic doble
en el miembro de datos value (valor) en la caja Contents, y después haga clic en OK.

6. Haga clic en Save.

El valor del potenciómetro del nivel de simulación se agrega a la lista de las zonas de
informaciones que serán incluidas en la hoja de cálculo ProcessData.

7. Repita los pasos 4 a 6, excepto que este caso, agregue el miembro de datos valor del objeto
POTHOA a la caja de lista Data Fields.

8. Haga clic en OK.

Creando un botón para comenzar el registro de datos 
1. Cree un nuevo objeto botón llamado PBStartLogging en el Proceso tratamientoagua. Use

Registre como el texto del botón.

2. Cree un nuevo objeto de control de flip-flop llamado FFStartLogging en el proceso
tratamientoagua. Cuando aparece el diálogo Create flip-flop, haga clic en el botón derecho en
la expresión de texto Input =.

Aparece el redactor de expresión.

3. Haga clic doble  en el objeto PBStartLogging y luego haga clic en OK.

4. Haga clic en OK para cerrar el cuadro de diálogo Create flip-flop.

Aparece el redactor de expresión  otra vez. 

5. Haga clic en OK.

6. Seleccione  un indicador luminoso verde (ON) y rojo (OFF), y después haga clic en OK.

7. Agrupe el botón PBStartLogging y el indicador luminoso flip-flop en la esquina derecha más
baja del panel de control.
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8. Seleccione Object>Object Explorer, haga clic en el botón derecho en el objeto
SSDataLogging, y seleccione Properties.

Aparece el diálogo Revise spreadsheet storage object.

9. Haga clic en el botón derecho en el campo de expresión Logging, haga clic doble  en
FFStartLogging y luego haga clic en OK.

Probando la función de registro de datos
1. Salga fuera del modo Edit y luego haga clic en Start Logging.

2. Mueva el interruptor HOA a Auto (o Hand si ya está en Auto), y después mueva el
accionador de nivel simulado hacia adelante y hacia atrás a través del rango completo del
movimiento.

3. Repita el paso 2 aproximadamente cada 10 segundos, por un minuto. 

4. Haga clic en Start Logging otra vez para parar el registro de datos.

5. Use Microsoft EXCEL u otro programa de hoja de cálculo para abrir el archivo ProcessData.csv
localizado en:  C:\DirectSOFT32\Projects \ [ ] \ [ del Año Mes ]. Note que el archivo contiene
una columna de tiempo más las columnas para los dos miembros de datos que usted seleccionó
cuando usted creó el objeto SSDataLogging.

Nota: El archivo de hoja de cálculo EXCEL debe ser cerrado antes de comenzar a registrar o los datos no se
pueden escribir al archivo.
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