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ERM Workbench Software
Ethernet Remote Master (ERM) Workbench is a software utility that must be used to
configure the ERM and its remote Ethernet slaves. The ERM Workbench supports two
methods of configuring the ERM I/O network. Both methods are explained later in this
chapter. 

The two configuration methods are:
• ERM Workbench PLC Wizard – simplifies the ERM I/O network configuration procedure when a

PLC is used as the CPU Interface.

• ERM Workbench – configures an ERM I/O network whether the CPU Interface is a PLC or
WinPLC, and allows access to all ERM I/O network parameters.

NetEdit, a software utility within ERM Workbench, can be used to set the Ethernet
master/slave Module ID, set an IP address if necessary or configure 405 EBCs with analog
I/O modules. Both ERM Workbench and NetEdit can be used to monitor the remote I/O
network and to perform diagnostic and troubleshooting tasks.

ERM Workbench software is installed as a utility program when you install DirectSOFT or
Do-more Designer. The latest version of ERM Workbench is also available for download from
Host Engineering’s web site (www.hosteng.com). ERM Workbench consists of several files, all
of which must be located in the same directory. The installation process places the files in the
C:\HAPTools directory (default). The files may be placed in another directory, but remember
all of the ERM Workbench files must be placed within the same directory.

Launching ERM Workbench
There are four methods to launch ERM Workbench:

•   using the Windows Start menu
Programs>AutomationDirect Tools>ERM Workbench
(on right) 

•   launching DirectSOFT, then select PLC
>Tools>ERM Workbench

•   launching DirectSOFT, then select
Utilities>ERM Workbench (on left)

•   launching Do-more Designer, then
select ERM Workbench from the
Launchpad (on left)
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Adding IPX Network Protocol Support on PCs with Windows XP (32 bit only)
or Earlier Operating Systems

You may have already set up your PC with selected networking protocols for Ethernet
communications. If not, you will need to select the protocols now for communication with
the ERM module. We strongly recommend that you include the IPX protocol. The
description below applies to Windows 2000 (Windows 98/NT/XP have slightly different
steps). If you are not familiar with this procedure, you may need to have your Network
Administrator perform this task.

For Windows 2000, go from My Computer on your Windows desktop to Control Panel.
Double click on Network and Dial–up Connections, then double click on the desired
Network Device to see the installed Protocols. If IPX is not listed among the protocols already
loaded, add it now by clicking on the Install button. For Windows XP, go from
Start>Settings>Control Panel. The steps are the same as Windows 2000 from this point.

Add the TCP/IP protocol if it is necessary for your application. The TCP/IP selection will
give you support for the UDP/IP protocol. Also, add the IPX protocol if it is not already
active.

NOTE: We strongly recommend you load IPX protocol on your PC for the connectionfrom your PC to the
ethernet modules. Use UDP/IP in your application, if required,but also add IPX to your list of active
protocols. Having IPX loaded on your PC gives you a backup for troubleshooting communication problems.



Chapter 4: Configuring the ERM And Slave Modules with ERM Workbench

1

2

3

4

5

6

7

8

9

10

11

12

13

14

A

B

C

D

Running ERM Workbench PLC Wizard
Run ERM Workbench PLC Wizard by launching DirectSOFT or Do-more Designer, then
select ERM Workbench as mentioned on the prevous page. The Wizard allows the ERM
network to be easily and completely configured without having to use the more advanced
ERM Workbench utility.

NOTE: The ERM module and ERM Workbench utility factory default settings are located in Appendix C.
These defaults will be applied during the ERM network configuration unless otherwise changed. Some of
the settings can be changed within the ERM PLC Wizard, but all can be changed using the ERM
Workbench utility.

Step 1: Choosing the ERM Network Configuration
Select either Hub or Point–to–point to describe the ERM network system that will be used.
This example assumes that a Hub network is used. Once a selection has been made, click on
the Next button.

Step 2: Connecting the ERM Workbench PC to the ERM Network
Connect the ERM Workbench PC to the dedicated ERM network hub. If only one slave is
used, connect the PC directly to that slave. Then click on the Next button.
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Establishing Communication with the ERM
The following window will be displayed if an ERM module is found on the network. Click
on the Flash Error Light button to confirm that the correct ERM module has been found
(the ERM’s LED will flash for 3 seconds). If the PC is connected directly to the slave in a
Point–to–point network, this window will not be displayed until the PC is connected directly
to the ERM module.

Step 3: Select and Configure the Slaves
The Select and Configure Slaves window will display all of the slaves found on the dedicated
ERM network. The order of how the I/O is mapped into the PLC is based on the slave order.
The ERM to Slave Address Mode selection determines the address mode in which the ERM
module will use to communicate with its slaves. Chapter 2 describes the ERM / Slave
Addressing Modes. Click on the Next button once the slave list is configured.

NOTE: Due to the manner in which I/O is grouped into PLC addresses, it is advisable, for future expansion
purposes, to pad the base with extra I/O. The wizard does not offer the option to add unused addresses. To
pad the addresses, add extra I/O before running the wizard. If the padding is not created, adding an I/O
module to the base in the future will offset a wide range of I/O in the PLC’s memory map. 
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Step 4: Map I/O to PLC Memory
Select the starting PLC memory addresses for each of the four I/O types: Discrete Inputs,
Discrete Outputs, Analog Inputs and Analog Outputs. Be sure that the selected starting
addresses do not conflict with any local I/O or any memory locations used in the ladder logic
program. Note that the first two words of memory in the Discrete Input table is reserved for
ERM status information and the first word of memory in the Discrete Output table is
reserved for Disable Slave Command bits. For more detailed information on PLC I/O
mapping, refer to the “PLC Map” section on page 4–10 and the “Reserved PLC Memory for
ERM” section on page 4–15. Click on the Next button once the starting PLC addresses have
been selected.

Step 5: Download Configuration to ERM
The following window displays how the slave I/O will be mapped into the PLC memory. The
network I/O modules and I/O points are listed by slave and slot number. This configuration
is written to the ERM by clicking on the “Write to ERM” button. If any advanced
configuration needs to be done, click on the ERM Workbench button. The modified
configuration can then be downloaded from the ERM Workbench utility to the ERM
module.

DirectLOGIC

Do-more

Ethernet Remote Master User Manual, 2nd Edition - H24-ERM-M 4-7
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ERM Workbench Main Configuration Window
The ERM Workbench main configuration window will be displayed once the configuration is
written to the ERM. Refer to the “Write Configuration to ERM” section on page 4–14 for a
complete description of the window fields.

In the Slave Status box, the status of a specific slave can be displayed by clicking on the slave
number 1–16. The numbers are highlighted in either normal, green, yellow or red. Normal
(default) indicates that the slave is not configured. Green indicates the ERM is successfully
communicating with that particular slave. Yellow indicates I/O is being updating, but some
error exists within the I/O of that slave (i.e. module missing 24VDC, unused analog channels
exist, broken transmitter or module missing terminal block, etc.). Red indicates I/O is not
being updating and that the ERM is not communicating with that slave. Clicking on the
Slave’s Error List button will display the error conditions for that particular slave. The error
codes are then defined under the Error List button.
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Running ERM Workbench
First, run the ERM Workbench PLC Wizard by launching DirectSOFT or Do-more
Designer, then select ERM Workbench as previously mentioned in the Launching ERM
Workbench Section. With the wizard opened, click the ERM Workbench button in the lower
left hand side of the ERM Workbench PLC Wizard window. Checking the “Please do Not
Launch PLC Wizard at startup” box will disable the Wizard from launching, but can be
accessed from View menu>PLC Wizard. The following window will be displayed.

Connecting the ERM Workbench PC to the Network Modules
The ERM Workbench PC will need to be connected to the ERM network to configure the
modules as described in this chapter. A hub is not necessary if only one network slave is used.
In this case, the PC will need to be connected directly to the slave module to configure the
slave. Then, the PC will need to be connected directly to the ERM module to configure the
ERM.

405EBC POWER
ERROR
RELAY

LINK GOOD
ACTIVITY
BATT LOW

H4-EBC         110/220VAC

H2-DM1E

Do-more PLC

Terminator I/O 
with  EBC Module

GS-EDRV100

DirectLogic
DL205 I/O with 
EBC Module

DirectLogic
DL405 I/O with 
EBC Module

ERM
Module

Stride
Ethernet
Switch

AC
Drive
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Configure the ERM

NOTE: The ERM module and ERM Workbench utility factory default settings are located in Appendix C.
These defaults will be applied during the ERM network configuration unless otherwise changed. The default
settings can be changed during configuration, module by module, within the ERM Workbench. Also, the
ERM Workbench> View menu>Options allows the default settings to be change at a system level that will
apply to all the new module configurations.

Configuring the ERM
Click on “1. Configure ERM” button. Then select either DirectLOGIC PLC, Do-more PLC
or WinPLC as the ERM / CPU Interface.

Selecting PLC as Interface
If either PLC is selected, the
PLC Map is enabled. If
WinPLC is selected, the PLC
Map will remain disabled.
The PLC Map is explained
on the next page. Clicking on
the PLC Memory Map
button displays the valid
memory ranges for each PLC
that supports the ERM
module.
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PLC Map
A starting PLC memory address must be specified for each of the four types of I/O. The
ending address for each I/O type is determined by the amount of each I/O type used by the
slaves. The PLC Map is divided into 4 separate tables.

1.  Discrete Inputs: This is where the ERM will Write all of the slaves’ Discrete Input data.

2.  Discrete Outputs: The ERM will Read this from the PLC and Write it to the slaves
Discrete Outputs.

3.  Analog Inputs: This is where the ERM will Write all of the slaves’ Analog Input data.

4.  Analog Outputs: The ERM will Read this from the PLC and Write it to the slaves Analog
Outputs.

It is recommended to use the V404xx or DLX3xx (X’s) for Discrete inputs and V405xx or
DLY3xx (Y’s) for Discrete Outputs that are beyond the expansion base I/O that exists. The
default addresses are V40414 (X300) and V40514 (Y300) for DirectLOGIC users and
DLX300 and DLY300 for Do-more users. Note that the Starting PLC address and the
Starting Discrete I/O Address are not the same. The first two words of memory in the
Discrete Input table is used for ERM/slave status information, and the first word of memory
in the Discrete Output table is for Disable Slave Command bits. Adjust these address as
needed, but do not map over local I/O used and be sure the PLC supports the alternate
addresses selected.

Advanced ERM Configuration
Clicking on the ERM Configuration “Advance” button displays the following window.

Standby Cycle Time is the time the ERM will wait before trying to communicate with a slave
that had a communication error. Enabling this feature will help overall I/O throughput when
one slave errors in a multi–slave network. If the Standby Cycle Time is disabled, the ERM
will try to communicate with the slave in error every I/O cycle. If enabled, the ERM will try
to communicate with the slave in error at the given time interval.
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PLC Scan Timeout is the time for the ERM to wait on the PLC when the PLC is not
responding due to long PLC scan times. It is recommended to keep it at the default of 100ms
or twice the maximum PLC scan time, whichever is greater.

Unsupported Slave Cycle Time is the time the ERM will wait before trying to communicate
with a slave that cannot be supported by the ERM. An unsupported slave may have an I/O
configuration that does not match the ERM’s or may have obsolete firmware. If disabled, the
ERM will not try to communicate with the unsupported slave again until ERM power is
cycled. If enabled, the ERM will check slave support at the given time interval. If the slave is
then supported, the slave will be included in the ERM’s I/O cycle.

Advanced ERM Network Settings are used to configure the ERM’s UDP/IP subnet mask for
IP address handling. Consult your network administrator if needed.

Select the Slaves

Selecting the Slaves
Select “2. Select Slaves” button. In order to select and configure the slaves, the PC running
ERM Workbench needs to be connected to the specific remote Ethernet slave network.

NOTE: A Think & Do WinPLC can only support one slave per ERM module. A PLC can support up to
sixteen slaves per ERM modules.

A. In the upper left corner of the Select Slaves window is a “PC Network Slaves on Protocol
Group List”. Clicking on either the IPX or UDP/IP radio button determines which
protocol is used by the PC running ERM Workbench to communicate with the remote
master and slave modules. The ERM and its slave modules understand either protocol.
Only one of the protocols needs to be installed on the PC to configure the ERM.

B. The left column displays the Ethernet Address, IP Address, Module ID and Model number
of the slaves currently on the remote I/O network. If slaves are added or removed from the
network, click on the Query Network button (1) to update the list.

Ethernet Remote Master User Manual, 2nd Edition - H24-ERM-M4-12
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C. The center column displays the ERM’s Slave List. To add a slave to the ERM’s List, either
double click on a slave in the PC Network Slave List or select the slave and click on the
Add to Slave List button (2). Slaves can also be removed from the ERM’s List by clicking
on the Remove button. One ERM can support up to 16 remote slaves.

D. The right column displays the Slave Configuration of the slave that is selected in the
ERM’s Slave List. 

E. NetEdit can be used to assign IP Addresses to the remote I/O network modules if required.
NetEdit is also required if Module ID is to be software set or if the 405 EBC is used with
analog I/O modules. Normally, a network administrator will assign an IP Address to each
module on the network. Since it is recommended to use a dedicated remote I/O network,
it is not necessary to assign IP Address unless the UDP/IP protocol must be used. Refer to
Chapter 4 “Using NetEdit” for more information.

Configure the Slaves

Setting the Slave’s Parameters
Remote slave parameters (protocol, address mode, timeout, etc.) are set individually for each
slave. To configure a slave, select a specific slave in the ERM’s Slave List by either double
clicking on that slave or by clicking on the “Configure” button once the slave is highlighted.
The following window will display the settings of the selected slave module.

A. The left column, ERM to Slave Communication Settings, determines the protocol, address
mode and the communication Timeout Settings the ERM module will use to
communicate with the specific slave selected.

B. In the Protocol box, click on either the IPX or UDP/IP radio button to select which
protocol the ERM will use to communicate with the selected slave. If UDP/IP protocol is
selected, a valid IP address must be assigned using NetEdit. The Address Mode determines
which network identifier will be used by the ERM to address the selected slave. IPX
protocol supports either Module ID or Ethernet Address. UDP/IP protocol supports only
IP Addressing.

Ethernet Remote Master User Manual, 2nd Edition - H24-ERM-M 4-13
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C. ERM Timeout to Slave Response, Retries and Consecutive Failures Before Standby Mode
times can be set for each slave. The default time values should be adequate for most
applications. The values may need to be raised in applications where IP addressing and
routers are used or if a dedicated remote I/O network is not used.

D. Enabling the Slave’s Watchdog Timeout runs in the slave and allows the slave to turn off
all outputs when the slave no longer receives any I/O requests from the ERM module.
Any outputs that were on at the time of the error will turn off after the specified time
elapses. Set the ERM Pet Frequency runs in the ERM to reset the watchdog timer in the
slave to avoid any nuisance timeouts due to main CPU inconsistent logic times or ERM
I/O cycle times. Disabling the the slave’s WatchDog timer will cause all of the outputs to
remain in their last state indefinitely (hold) when the slave no longer receives any I/O
requests.

E. Reserve PLC Addresses for Expansion allows future I/O modules to be added or existing
modules to be removed from a slave without affecting the PLC addresses of the other slaves
on the network. Pad the discrete inputs and outputs using bytes (8 points per byte) and the
analog I/O using words (2 bytes). Padding can only be done for I/O at the end of a slave
I/O base, not between two I/O modules on the slave.

F. The Make Offline Feature may be useful for users or OEMs that require duplicating a
system several times. For example, a system may consist of 3 EBCs. An offline ERM
configuration allows each additional ERM to be configured without actually connecting its
slaves at configuration time. Once the initial ERM system is configured, its ERM
Workbench configuration file can be used to create another configuration file with different
slave addresses. Checking the Make Offline checkbox allows slave addresses to be manually
set that should be used by the ERM. This does not change the address in the slave, but
changes the ERM configuration to address a different slave without connecting it on the
network when configuring the ERM. 

Once the CPU Interface and Slaves have been selected and configured, the network I/O
modules and I/O points will be listed by slave and slot number as shown on the next page
(A.). The next step will be to write the configuration to the ERM module.
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Write Configuration to ERM
After the ERM CPU interface has been selected and the slaves have been configured, click on
the “3. Write to ERM” button to write the configuration information to the ERM module.
Once the download is complete, the following window can be used to check slave status and
view detailed ERM status, etc.

A. Once the CPU Interface and Slaves have been configured using the steps on the previous
pages, the network I/O modules and I/O points will be listed by slave and slot number.
This configuration will be written to the ERM by clicking on the “3. Write to ERM”
button. If using a PLC CPU as the interface, note that the Starting PLC address and the
Starting Discrete I/O Address are not the same. The first two words of memory in the
Discrete Input table is reserved for ERM/slave status information, and the first word of
memory in the Discrete Output table is reserved for Disable Slave Command bits. The
PLC memory map information is not displayed if a WinPLC is selected as the CPU
interface. See the following section “Reserved PLC Memory for ERM” for detailed
information. This table can be sorted by I/O module address or PLC Memory Address.

B. The top row lists the ERM’s Ethernet Address, IP Address and Module ID. It is highly
recommended that the Ethernet Address of the modules is place on a label near the
module in a visible location.

C. The PLC CPU or WinPLC Interface information is listed.

D. In the Slave Status box, the status of a specific slave can be displayed by clicking on the
slave number 1–16. The numbers are highlighted in either normal, green, yellow or red.
Normal (default) indicates that the slave is not configured. Green indicates the ERM is
successfully communicating with that particular slave. Yellow indicates I/O is being
updating, but some error exists within the I/O of that slave (i.e. module missing 24VDC,
unused analog channels exist, broken transmitter or module missing terminal block, etc.).
Red indicates I/O is not being updating and that the ERM is not communicating with
that slave. Clicking on the Slave’s Error List button will display the error conditions for
that particular slave. The error codes are then defined under the Error List button.

Ethernet Remote Master User Manual, 2nd Edition - H24-ERM-M 4-15



Ethernet Remote Master User Manual, 2nd Edition - H24-ERM-M4-16

Chapter 4: Configuring the ERM And Slave Modules with ERM Workbench

1

2

3

4

5

6

7

8

9

10

11

12

13

14

A

B

C

D

E. When the CPU Interface is in the Run Mode, the “Read ERM Status” button will be
highlighted. Each time the button is clicked, the most current ERM Status information
will be read and displayed.

F. “Detailed ERM Status” provides status
of the module including ERM I/O
Cycle Times. This is the time required
for the ERM module to update all of
its I/O points. Remember the ERM
and the PLC CPU operate
asynchronously from one another. The
PLC CPU scan will be faster than the
ERM I/O Cycle Time. Thus, the
remote I/O points will not be updated
every PLC CPU scan.

Analog I/O Data Registers

Analog I/O Data Registers
Analog input data is mapped channel by channel in decimal format (binary) into consecutive
memory locations when used in an EBC base. Each individual analog I/O channel has its
own 16–bit memory location. For example, an 8 channel analog input module with starting
DirectLOGIC PLC V memory address of V2000 would map the 8 channels of analog data
into V2000 – V2007, respectively. 

Analog output data needs to be in decimal format (binary). For DirectLOGIC users, be sure
to convert any BCD values to decimal before sending the data to the analog output registers.
Refer to the Analog I/O Manuals for conversion examples. Terminator analog I/O modules
consume two (Double) words per channel (32–bits). See Appendix E for configuring
Terminator I/O analog output module control byte. 

The EBC slave modules automatically maps the analog I/O data in/out of memory, thus
multiplexing ladder logic or pointer method is not necessary.

Note that the 205/405 analog I/O
channels are listed as 16-bit Binary
consecutive data registers (1 word) and
the Terminator analog I/O channels are
listed as 32-bit Binary non-consecutive
data registers (Double Word).
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Reserved PLC Memory for ERM
The first two words of memory in the Discrete Input table is used for ERM/slave status
information, and the first word of memory in the Discrete Output table is for Disable Slave
Command bits. The default memory addresses DLX300/X300 and DLY300/Y300 are used
in this example.

The Slave Status Bits can
be monitored to detect if a

slave is in error.

The ERM Status Word
contains the ERM error
code and Status Bits (see
the following description

and Error Codes in
Appendix B). Bit 8

indicates that the ERM is
disabling a slave.

The Disable Slave Bits can
be used to disable a slave

from communicating with
the ERM module. Bit ON
= disable that specific slave.

RESET = re-enable the
specific slave.

X
3
1
7

BSLBSM V40414

Slave Status Bits

X
3
0
0

Slave 1Slave 16

X
3
3
7

BSLBSM V40415

ERM Status Word

X
3
2
0

X
3
2
7

X
3
3
0

Status Bits Error Code

Y
3
1
7

BSLBSM V40514

Disable  Slave Bits

Y
3
0
0

Slave 1Slave 16

ERM Status Word / Reset Slave Code
The ERM Status Word contains the current ERM Error Code in the Least Significant Byte
and the Status Bits in the Most Significant Byte. When using the Slave Disable Bits, the
ERM must recognize the request to disable a slave before attempting to re–enable that slave.
This closed loop feedback is necessary due to the asynchronous scans of the ERM and PLC.
X330 (DLX330 for Do-more) is the only feedback bit for ALL slave disabling bits (Y300 –
Y317 or DLY300 - DLY317). Either disable multiple slaves all on the same scan or serialize
the disable process by using ladder logic interlocks. 

Use the following ladder logic code to manually reset a slave. For example, use this resetting
method when “Hot Swapping” a Terminator I/O module on a slave that is set up to be
manually reset using ladder logic. The default for the Terminator EBC is automatic rescan
after “Hot Swapping” and I/O module.

DLX
3
1
7

BSLBSM

Slave Status Bits

DLX
3
0
0

Slave 1Slave 16

DLX
3
3
7

BSLBSM

ERM Status Word

DLX
3
2
0

3
2
7

DLX
3
3
0

Status Bits Error Code

DLY
3
1
7

BSLBSM

Disable  Slave Bits

DLY
3
0
0

Slave 1Slave 16

DirectLOGICDo-more



Saving ERM Configuration to Disk
The ERM configuration can be saved to disk as an ERM Workbench File (*.erm). The Save
command allows you to specify a name and location for the configuration. See File>Save.

Clear ERM Configuration
The Clear ERM command allows you to clear the existing configuration from an ERM
module. This function is useful when changing the ERM network configuration or
experiencing configuration difficulties. See File>Clear ERM.

Printing/Exporting the ERM Configuration
The ERM Configuration can be printed or exported as a text(.txt) or comma separated
variable(.csv) file. The ERM Configuration can be sorted by either the Slave/Base/Slot
Address or the PLC Memory Address. The ERM/Slave Status can also be included with the
print or export. See File>Print/Export.
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C0

PD

C200

Direct SOFT

C0

SET

Y300

Y300

RST 

Y300X330

Event occurs to reset Slave 1

Disable Slave 1

Wait to re–enable Slave 1 until X330 (ERM
Disable Request Bit) is ON.

C0

PD

C200

Do-more Designer

Event occurs to reset Slave 1

Disable Slave 1

Wait to re–enable Slave 1 until DLX330 (ERM
Disable Request Bit) is ON.
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