
��
Key Concepts

�� ���� ��	
��� � � �

� �������

� ������ �����	� 	�� ���	��

� ����� �������

� ����� �	��

� ���	� �	��

� ������ 	 �	�

� �������

�  ��!	
�

� "�#���

� ��� �����	�



K
ey

 C
on

ce
pt

s
K

ey
 C

on
ce

pt
s

3–2
Key Concepts

Projects
A project is the set of screens and data (such as PLC protocol, baud rate and panel
type) managed under a specific project name. Each project can correspond to a
specific application. The Project Tutorial has the example of an application in a pulp
mill, so the project is titled ’Pulp’.

Screens (Global and Local)
In ScreenCreator, a screen is an image of the actual screen displayed on the
DirectTouch panel. There are two types of screens, global and local.
A project must have one, and only one, global screen. The global screen is created
at the same time the project is created and has the same name as the project. The
global screen can be used for displaying faults (alarms), or a clock/calendar. It
functions like a window in front of any screen that is being displayed on the panel. So
when nothing is being displayed on the global screen, it is transparent to the user.
There can be up to 1024 local screen names in any given project. The actual
number of screens you can download to a panel depends on how much
memory the screens use. Local screens each function like a separate Operator
Interface Panel having parts such as pushbuttons, meters and indicator lights, etc.
When nothing is being displayed on the global screen, the current local screen is
fully visible and functional.
Anything that can be placed on a screen may be called a Screen Object, including
Parts, Figures (circles, polygons, lines, etc.), Text, Bitmaps, and Textures. Figures
may also be referred to as Drawing Objects or Patterns. This chapter also discusses
Library Objects (Parts, Textures and Bitmaps in the Library), which are like Originals
from which the Copies (Screen Objects) are made.
Screen Parts are the most important type of Screen Objects. The major classes of
parts are found in the Part Toolbar below.

Text Displays

Numerical
Displays

Lights

Clocks/Calendars

Host CommandKeypads

Pushbuttons/Switches Select Screen
Graphs

Meters Alarms/Faults

Texture Displays

Special User Parts

Access of a part
refers to the way it is
displayed within both
ScreenCreator and
on the panel.
Normal: Displayed on the screen, including any data, and functional.
Frozen: Displayed as normal, but the pushbutton/switch is not functional.
Shaded: Displayed in shaded fashion, with no data or function.
Closed: Not displayed or functioning. (Must also be Selectable.)
Selectable: The access can be changed by a screen or part program.
Before a part has closed access, it must be made Selectable.
A good example of a part made Closed and Selectable is a Ten–key pad
being called by pressing a Numerical Input Display part. The Ten-key pad
is opened by the part program of the display and closed by its own
program once the Ent or Esc buttons are pressed.

The Global Screen

Local Screens

Screen
Objects

Screen Parts

Part Toolbar

Access of a Part
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Key Concepts

When you click on any tool
icon in the Part Toolbar, the
Select Part window
appears, with that type of
part selected in the Class
List. If you click on the
Meters Tool, the window to
the right comes up, allowing
you to select one of the
specific meter types below
the ’Meters’ heading. The
Class List is much like a
folder of folders in Windows
95/98 or NT.

When you select the
’Analog Meter’, the window
then contains all the analog
meters stored under that
heading in the library.

The Class (or Heading) and Part Tool labeled ’User Parts’ is reserved for any custom
parts which you create. You may also store custom parts under any other heading if
you prefer but it might not be as convenient. Creating new parts is covered in greater
detail below.
The difference between what are called Screen Parts and what are called Library
Parts is fairly simple. Screen Parts reside on a screen and have particular settings,
like a PLC address referenced, BCD type, or a special color assigned. Whereas,
Library Parts are like templates for creating actual Screen Parts–– they have no
specific PLC address but do have a default type, color and texture, etc. Library Parts
are the Originals and Screen Parts are the Copies.

Adding Parts to a
Screen

User Parts

Screen Parts
versus Library
Parts
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3–4
Key Concepts

Library Parts

All Library Parts are contained in the library file of ScreenCreator. Each part in the
library is a template used to create actual parts on the screen. These library parts
can be edited and saved as a new library part or edited and saved under the same
name, overwriting the original part. Below you will find an example of editing and
saving as a new name. Very often, this is how you will create a new library part (you
will use an existing library part, change it and save it under a new name).

To edit a library part, click on
Library > Open > Part... to
bring up the Open Part
window. This window looks
just like the Select Part
window, but the Open Part
window opens the actual
Library Part for editing. Be
careful when opening a
library part, because any
changes you make will affect
all future uses of that library
part.

Remember, the Select Part
window allows you to choose
a Library Part to copy to the
screen, but the Open Part
window allows you to choose
a Library Part to edit.

Like Part
Templates

Editing Library
Parts



K
ey C

oncepts
K

ey C
oncepts

3–5
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To edit an existing Labeled
Pushbutton w/ Light Part to create
a new one with “CYCLE” on it.
Select the Pushbutton as shown
on the right (any with a label would
do).

The Part window appears as
shown on the right.

Click on the Browse List button to
view the components of this part.
Select the Text item and click
Attributes/Properties to edit the
Text. Remember, we want it to
have “CYCLE” on the pushbutton.

Type “CYCLE” in place of “SET”
and click OK. Notice that the new
text is not centered on the part.
Click and drag the text to center it
(the pointer has four arrows when
moving an object).

Creating a New
Library Part from
an Existing One
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3–6
Key Concepts

Click the Save button and the
Save Part window appears with
the original heading “Labeled
Pushbutton w/Light” selected. If
we clicked Save, the changes
would be made to the original
library part: #CLS4002.

Instead, let’s select the User Parts
class, change the name to CYCLE
and click Save.

Finally, click the X to close the new
Part window which is now labeled
CYCLE.

Creating a New
Library Part from
an Existing One
(Continued...)
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What follows below are step-by-step instructions for creating a new library part.

In some cases, you may find it necessary
to build a totally different type of Part. To
create a brand new Library Part, click on
Library > New > Part... and the Part Edit
window appears, on the right. The Select
Control tool is now active on the Drawing
Toolbar and the control tools are colored
and selectable in the Control Toolbar.
This is because we are now editing a
part, which can contain controls, versus a
screen which cannot have controls
alone.

Click the Size Window to Screen tool as
shown above right, and the window
becomes full sized with the dotted-line
frame of the part.

Next, turn on the grid by clicking the
Options tool in the Standard Toolbar. In
the Options window, click to enable the
Snap to Grid and enter 20 as the Grid
Size. After clicking OK, notice the thin
grid lines on the screen.

Click the Meter tool in the Control Toolbar
which opens the Meter window and
select medium for the needle thickness,
then click the Arrangement and Color
tab. Enter all of the settings as shown on
the right and click Arrangement to place it
on the window. The pointer becomes a
mouse. Click the left mouse button and it
becomes a cross–hair. Move the
cross-hair to the upper left corner of the
window and click to place the meter. This
is what you should see.

If you do not see the outline of the meter,
click on the the Display tool and select
“Both” for View of Parts and View of
Controls.

If the Controls Toolbar is not already
open, select it from Tools > Display, and
click New Default.

Creating a New
Library Part from
Scratch
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3–8
Key Concepts

Now that the meter control has been
built, we will create a Figure of 10 meter
lines for the meter face. Click on the
Circular Scale tool, enter 10 and click
Create.

The cross-hair appears again. This time
bring the inside circle to the center grid
block as shown, and click.

The cross-hair appears again. Click on
the upper left corner as before and move
the pointer to the bottom left until the
white circle fits the meter, then click again
and the outside diameter is set in place.

Creating a New
Library Part from
Scratch
(Continued...)
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3–9
Key Concepts

Now, carefully move the cross-hair
to the bottom left line of the meter
and click when the cursor line
matches the meter line. Do the
same for the bottom right line of the
meter. The meter is finished now,
but the cross–hair remains (in
case you want to do another
circular scale), so click the
Selection Mode tool (pointer) to
get the normal pointer back.

Finally, click the Save tool or
Library > Save As... and save the
meter as shown on the right. The
meter icon can be found by clicking
Select Icon. Enter ’MTR1’ as the
Name of this new part. Now the
meter will appear in the User Parts
class and can be added to screens
like any other part.

At this point we could move all of
the straight lines and the meter to
the middle of the part boundary
and add numbers (in text) around
the meter face, but that’s left for
you to do later if you choose.

Lastly,press Shift + X which sizes
the part boundary to the part.
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Inside a Part

Each Screen Part may have one or more Control component, and may have a Part
Program (see the next page) and a Background (made up of Figures, Textures and
colors).

Numerical Input Display Part

34.62

Figure (Text & Lines, etc.)

Background Texture

Background Color

Displays data from the PLC

Writes data to the PLC

if...
endif

endevent

event

Part Background

Part Program

The components of a Part can be thought of as layers
of lenses: some clear and some with Figures, colors,
text or symbols.

PLC

Control Color

Control Texture

Control

The Control component of
a part reads data from, and
may write data to, the PLC
address. In the Part
Properties box, shown on
the right, controls
associated with a part are
listed under Operation
Parameter. The Operation
Parameter settings for
each control are found in
the small box to the right of
the list, when the specific
control is selected. For the
part shown on the right,
there is only one control, a
Pushbutton/Switch.

Control
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The settings for a control may be accessed and edited by clicking on ’Edit
Details’. This brings up the box below, with the three tabs: Settings, Arrangement
and Color, and Operation Parameter. These settings are discussed in detail in
Chapter 5.

The Part Background is made up of any Figures (Text, lines, etc.), Textures, and
Colors that have been built into the Part.

Control Texture
and Color

Part Background
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3–12
Key Concepts

To view the various Control(s), Figure(s) and Texture(s) of a given part,
double–click the part on the screen and then click ’Edit Contents’. Now the part is
displayed again in the editing window, click the Browse List tool and the Browse List
box will appear. Figures and Text are denoted by a square and triangle icon and
Controls are denoted by a C icon. The ten–key pad List, shown here, is an example
with Figures, Text and Controls.

Click on a component, then click Attributes/Properties to edit it or
click Select to identify it.

Viewing and
Editing Part
Components:
Browse List
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The diagram below will help you understand the elements of a Part.

Numerical Input Display Part

34.62

Figures (Text & Lines, etc.)

Background Texture

Background Color

Control Color

Control Texture
Any data from the PLC is
displayed by the Control.

The Texture and Color for ON
and OFF are specified here.

The Part Background Texture and
Color.

Control

How the
Components of a
Part fit together
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Key Concepts

This is a very important point to understand for using any parts that change color
depending on the state of a bit (either ON or OFF). As an example we will use the
pushbutton we created in the Project Tutorial.
The key is to know that when the bit is ON, the Control “ON Color” replaces
anything that has the “OFF Color” (whether it is in a figure, like a circle or
rectangle, or the part Background Color itself), and the “OFF Color” remains
when the bit is OFF.

Double-click on the pushbutton
and the Part Properties window
pops up.

Click on Edit Details, select the
Arrangement and Color tab and
move the Pushbutton/Switch
window to the left as shown. This
allows you to see both the Part
Background Color and the OFF
Color at the same time.

Notice the Part Background Color.

Notice that the Part Background
Color is the same as the OFF
Color. If it were different, the
pushbutton color would not work
(that is, it would not change from
dark green to light green when it
went from OFF to ON).
Also, the Image (ON/OFF)
specifies which color to show on
the part in ScreenCreator only, not
on the panel itself.

For Example 2, add the
pushbutton shown on the right to a
screen, Edit Contents, then
Browse List, select the second
Circle and click
Attributes/Properties. In this case,
the part background color is gray
(the frame of the button) and not
the same as the OFF color.
Notice that the line and fill colors
are the same as the OFF Color.
See the Index for information on
the Fore and Back Colors (Tile).

Consider the two examples below, which illustrate this concept.

Example 1: Part Background
Color is the OFF Color.

Example 2: Another compoent is
the OFF Color. (Locate the
component with the OFF Color .)

How ON/OFF
Colors work in a
Part
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The Project Register:  Screens, Registered Text and Textures

Every Project has a Register, containing Screens,  Registered Text and Registered
Textures.

opens the Register to Project dialog box for viewing the registered screens, text
and textures of the current project. Note: these items cannot be edited from this
window.

Screens, covered at the beginning of this chapter, must have both a unique name
and a unique Registration number (except the Global screen, which is not
registered).

Click the Register to display
Screens in order of
Registration number.

Project > Register...

Screens
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Key Concepts

Screens, covered at the beginning of this chapter, must have both a unique name
and a unique Registration number (except the Global screen, which is not
registered).

With the New Text window
open, you can begin typing
in the new text to be
registered. Then click the
save tool to save and assign
a registration number.

Use the Open tool to open
existing registered text, or to
view all registered text.

Registered text is used in
Registered Text Displays
and Warning Displays to
display text messages
which correspond to the
value in a PLC address (bit
or word).

Select Project > New
Text... to open the New Text
window.

Registered
Text

Creating or editing
Registered Text
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Registered Textures are different from both Screens and Registered Text, in that they exist in
the Library and may be registered as shown below.

Select Project > Register... to
open the Register to Project
window. Select a Texture and click
Reference...

Select a Texture and then click the
Cancel button.

The Texture is now registered and
may be used in the Registered
Texture Display part.

Registered
Textures
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3–18
Key Concepts

Textures are made up of lines, circles, rectangles and so on, grouped together as a
single object. Often Textures are used as components of Parts, providing a visual
image of some physical device such as a pushbutton or switch. Textures may also be
placed on a screen directly, similar to Parts, but are typically only found inside a part.
Textures are essentially identical to Parts (see the ’Screen Part versus Library Part’
discussion above), except a texture may be placed in a part or on a Screen. The
Library Texture are still the Originals and Screen or Part Textures are the Copies.

When a screen or part is
open, the Texture tool is
active. After clicking it, the
Texture dialog box appears;
click Select to view and
select from the Library. Use
the Repeat in X or Y to
duplicate the Texture
horizontally or vertically.

The ISO 7000 Textures may
be used as symbols on
screens or in building new
parts. Click on the different
classes and scroll down to
see all of the members of
each class.

The General Parts Class
List of Textures are those
textures used already in the
built-in Library Parts.

Click on the Texture that you
want and place it on a
screen or part as you would
any Figure or object.

For help with adding
Textures, see the Library >
Add from External File >
Texture... section in the
Menus chapter

Textures

Screen (or Part)
Textures versus
Library Textures

Adding Textures to
a Screen or Part
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Key Concepts

Bitmaps

Bitmaps may be used in a variety of ways including screen or part background,
importing a company logo onto a screen or simply displaying a picture.

When a screen or part is
open, the Bitmap tool is
selectable. After clicking it,
the Bitmap dialog box
appears; click Select to view
and select from the Library.

There are no bitmaps
provided in ScreenCreator,
since these tend to be
custom images. So, when
you open the Select Bitmap
it will be empty (unless you
have added bitmaps before
this). For help with adding
bitmaps, see the Library >
Add from External File >
Bitmap... section in the
Menus chapter.

Transparent makes all Black portions
of the Bitmap transparent.

Converts all colors (except black) to this color.

Adding Bitmaps to
a Screen or Part
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3–20
Key Concepts

Figures (Drawing Objects)

Any Drawing Object (line or lines, ellipse/circle, rectangle, text, etc.) is referred to as
a Figure since it may be used as a component in a Part.

When a screen or a part is open, the Drawing tools are selectable. The individual
tools are covered in greater detail in the Menus chapter. Two attributes common to
many of the Drawing Objects are Line and Fill (Tile), shown below.

The Line of the object has a color (default is usually white) and a style (thin, dotted,
and thick).

The Fill feature involves two colors “tiled” together by the selected Tile pattern. The
white represents Tile Back color and the black represents Tile Fore color. One
color is never actually in front or back of the other, but Fore and Back is just a
means of distinguishing between the two. The default is usually as shown above,
with Tile Back alone chosen (set as Transparent) and Tile Fore being white. By the
way, since there is no Tile Fore in the mix, it could be any color. We recommend
experimenting with lots of Tile Fill combinations to get a feel for how it works.

Adding Figures to
a Screen or Part

Tile Color (Fill)
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ScreenCreator has toolbars that give quick access to various menu items. The Standard
Toolbar has the typical Windows tools (Cut/Paste/Undo etc.) along with Move to Front/Back,
display and download options. The drawing, part and control toolbars have all of the tools
associated with specific functions. There is also a Reference and a Status bar at the bottom of
the window for programming and compiling. Note: The drawing toolbar is shown both
anchored and floating to show both options. You can drag and drop the toolbars into place
and move them around the desktop as needed or anchor them in any location around the
application window, either horizontal or vertical.

Standard Toolbar

Drawing Toolbar
Part Toolbar

Control Toolbar

Reference Bar

Status Bar

Current Project – Screen

The Toolbars
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3–22
Key Concepts

A Quick Reference for the Toolbars

Selection Mode

Select Figure

Select Part

Select Control

Straight Line

Arc

Spline

Line-shaped Scale

Continuous Straight Line

Polygon

Set Attribute

Parallelogram

Rectangle

Fill

Circle/Ellipse

Text

Texture

Bitmap

Circular Scale

Drawing
Toolbar

Part
Toolbar

Lights

Pushbuttons/ Switches

Ten-Key Pads/ Keyboards

Screen Select Parts

Meters

Text Displays

Numerical Displays

Clocks/Calendars

Host Command Commu-
nication Parts

Graphs

Alarms (Errors/Faults/Warnings)

Texture Displays

Special Parts

User Parts

Figure Display

Pushbutton/ Switch

Clock Display

Plot

Bar

Text Display

Numerical Display

Band

Meter

Dotted Line

Circle

Free

Slider

Light

Selector Switch

Pipe

Control
Toolbar

Like most Windows  programs, ScreenCreator has a standard toolbar with the
normal tools and additional graphical and screen tools.

New
Screen

Open Screen

Save
Redo

Operation Parameter

Copy
Cut Undo

Attributes/Properties

Refresh

Move to
Front

Move to
Back Program

Option

Display

Snap to Grid

Browse List

Cascade Vertical
Tile

Horizontal
Tile

Size Window to
Screen

Download/BuildPaste

Edit Corner

Standard Toolbar
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The Drawing Toolbar has the standard drawing tools and provides separate
selection for Drawing Objects (called Figures), Parts and Controls.

Selection
Mode

Select
Drawing
Object

Select
Part

Select Control

Straight
Line

Arc

Spline
L-shaped Scale

Continuous
Straight Line

PolygonSet Attribute
Parallelogram

Rectangle
Fill

Circle/Ellipse Text
Texture

Bitmap

Circle
Scale

The Part Toolbar, shown below horizontally , selects the various types of parts to be
added to a screen.

Text Displays

Numerical
Displays

Indicator Lights

Clocks/Calendars

Host CommandKeypads

Pushbuttons/
Switches

Select Screen
Graphs

Meters Alarms/Faults

Texture Displays

Special User Parts

The Control Toolbar contains the controls which operate within a part. The controls
can only be used when editing a library part (new or existing) or editing the contents
of an existing screen part.

Figure Display

Pushbutton/
Switch Clock Display Plot

BarText Display

Numerical Display Band Meter

Dotted Line Circle

Free

Slider
Light

Selector Switch

Pipe

TIP: This is another reminder to get in the habit of using the various tools instead of
selecting the functions through the menu bar. We promise you’ll save a lot of time!

Drawing Toolbar

Part Toolbar

Control Toolbar


