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Turn Documentation On and Off
Documentation is the text associated with the components and structure of a DirectSOFT6 
program which is added for greater clarity. It may refer to the elements, wiring, rungs or stages. 
All documentation options are turned ON by default when the Options dialog is first opened.

The Options Dialog
DirectSOFT6 allows the programmer to turn ON/OFF the documentation in each available 
view. A quick way to open the Options dialog is to place the mouse cursor in the displayed view 
and right click the mouse. A pop-up window will appear with Options as one of the selections. 
Select Options and the dialog will appear like the one shown below. When the dialog opens, 
the Ladder tab is in view by default. The other views can be selected by clicking on the tab at 
the top of the dialog.

The Ladder tab is showing all of the documentation types checked. Leaving each selection 
checked turns ON that documentation type to be shown in the program. Unchecking the 
documentation type will turn it OFF in the program. Most of the Options dialog features 
have been discussed in Chapter 4. For turning the documentation ON/OFF, only the Ladder, 
Stage, XRef and Data View (under Doc tab) options need to be accessed.
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Documentation Selections
Most documentation refers to individual elements, therefore, it is specific in nature. Listed 
below are four types of documentation

•	 Elements  s the references for the individual elements, i.e. X1, Y10, etc.

•	 Nicknames s these are alpha-numeric names that are used for the various 
types of program elements. It is usually easier to remember the name Start 
Switch than it is to remember that X1 is the input for the switch.

•	 Descriptions s detailed description of an element. This can 
also be used to add brief trouble-shooting steps, etc.

•	 Wiring s this can be used to identify panel wiring for the project.

General Documentation
Comments are general descriptions that are best suited for descriptions of a program rung, or 
a section of the program.

•	 Rung Comments s rung comments are assigned to an individual rung.

•	 Stage Comments s if you are using the Stage instructions, you can also add comments 
that describe the contents of any stage.

Description 

Wiring Info

Nickname 

Element

Rung Comments

Stage 
Comments are 

in this area
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Using the Documentation Editor
Nicknames, wiring information and descriptions for program elements are entered using the 
Documentation Editor. The editor can be accessed using Tools > Documentation Editor on 
the Menu bar, Ctrl + D or by pressing the Documentation button on the Tools toolbar.

Using the Scroll Buttons
There are scroll command buttons (arrowheads) located at the top of the editor. They are 
shown (both directions) as E, EE, ER, E., etc. Each button has a unique function:

E s Moves one element forward.

EE s Moves one page forward.

ER s Moves to the beginning of the next data type (X, Y, C, etc.)

E — Moves to the last document type.

F s Moves one element back.

FF s Moves one page back.

RF s Move to the beginning of the previous data type.

.F s Moves to the beginning of the first document point.
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Copying Documentation Between Elements
If it becomes necessary to use the Documentation editor, all of the familiar Windows keyboard 
shortcuts (copy, cut, paste, etc.) can be used within the editor. For example, if there is a lengthy 
description for a point, and other points are similar, the information can be copied. The 
following example will demonstrate how this is accomplished.

1.	 Position the cursor in the cell to be copied.

2.	 Double click to highlight the information.

3.	 Press Ctrl + C to copy the information in the cell.

4.	 Move the cursor to the element cell where the information is to be 
copied to. (Use the Find button, Ctrl + F shortcut or scroll).

5.	 With the cursor in position to paste the information, press Ctrl + V.

NOTE: When copying a nickname, the new nickname will have a “?” before and after the newly pasted entry. 
This occurs because each nickname must be unique.
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Documenting and Assigning Nicknames
Create an Unassigned Nickname

Element nicknames are used more often than any other type of documentation. As a program 
is developed using nicknames, element references do not have to be entered when a contact, 
coil, etc. is entered. Wiring information and descriptions can also be entered without knowing 
the actual element reference.

Assign the Nickname to an Element
If unassigned nicknames have been created in the program, element references must be assigned 
before the program can be written to the PLC (the PLC does not recognize nicknames, only 
element references). The Assign Nicknames dialog is used to assign nicknames to element 
references. A quick way to open the dialog is to either press F9 (hotkey) or the Assign 
Nicknames button (if the Tools toolbar is displayed). Another way is to use Tools > Assign 
Nicknames from the Menu bar. Also, if the Element Browser is open, nickname information 
can be assigned by clicking on the Assign Nicknames button in the Element Browser and the 
Assign Nicknames dialog will appear as shown on the facing page.

Tip: Nicknames can be compiled and saved to disk; and then assigned later, just before downloading to the 
PLC.

The nickname is 
accepted without 
being linked to an 
element.

Dialog appears when 
a nickname is entered 
without being linked to 
an element.

Unassigned nickname 
is entered (red 
indicator remains on).

Click OK
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The Assign Nickname dialog will appear with the list of unassigned nicknames appearing in 
the Source Nickname column. Select the nickname in the list and enter the element reference 
for the nickname in the Source Element Column. 

The reference will be duplicated in the Result column to help avoid accidental entries. Press 
Assign and the following dialog will appear as a confirmation of the element entry.

Open the Element Browser

Click here to open the Assign Nicknames dialog.
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If the reference entered is correct, click OK. The Element Browser will be in view again so that 
wiring information and a description, if any, can be added. Pressing Exit will close the browser 
and the program will have the new element in the program as shown below.
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Entering Rung Comments
Each rung in a DirectSOFT6 program can have associated comments. Unlike some 
programming packages from other vendors, the comments are not tied to the outputs. Instead, 
the comments remain with the rung where the comments are added regardless if other rungs 
are deleted before a commented rung. To edit a comment, the cursor must be on the rung to 
where it is to be added. Now, either press the keyboard shortcut Ctrl + K, Tools > Comment 
Editor on the Menu bar or press the Comments button on the Tools toolbar if it is displayed. 
The Edit Comments dialog, shown below, will appear.

Comments are Free-form
The appropriate comment can be added as necessary. The Ladder view is a full screen editor, 
therefore, backspacing the entire comment is not necessary to fix a spelling error. Instead, 
position the cursor over the word to be edited and double-click the left mouse button to 
highlight the word, then type in the corrected word.

Selecting Rungs for Comments
Once you have edited a rung comment you can use the Page Up and the Page Down keyboard 
buttons to scroll to another rung comment to edit. A specific rung can be found by using the 
Goto button on the editor dialog. 

Rung 
Comment
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Using the Scroll Buttons
There are scroll command button (arrowheads) located at the bottom of the dialog. They are 
shown for both directions as E, EE, E., etc. Each button performs a different function:

 
E s Moves to the next rung comment.

EE s Moves ahead five rung comments.

E.s Moves to the comment for the last rung.

F s Moves to the previous rung comment.

FF s Moves back five rung comments.

.F s Moves to the comment for the first rung.

Click on the OK button after entering the rung comments.

Use the Editing Keys
The keyboard shortcut keys can be used to copy, cut and paste comments between rungs.

1.	 Position the cursor at the beginning of the text to be copied or cut.

2.	 Press and hold the left mouse button and move the cursor to highlight the text, then 
release the button. The Shift + Arrow keys can also be used to highlight the text.

3.	 Use the Ctrl + C keys to copy the text or the Ctrl + X keys to cut the text.

4.	 Locate the rung where the information is to be pasted (Use Previous, Next or Goto).

5.	 Position the cursor where the text is to be pasted and click the 
left mouse button, then press Ctrl +V to paste the text.

6.	 The Delete key can also be used to delete text.
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Move Rung Comments
Rung comments can easily be moved from one rung to another with DirectSOFT6. This 
feature is useful after one or more rungs have been inserted by a handheld programmer or by 
another computer which did not have the documentation files available. The Move comment 
feature can be used to match the comment(s) with the correct rung(s). Comments can be 
moved for a single rung or a group of rungs. To move comments, click on the Move button on 
the dialog. The window will appear within the dialog.

Fill in the appropriate fields to specify the source and destination for moving a comment.

•	 Source s This is the beginning of the group of comments to be moved. Enter the rung 
number (or address) of the rung with the comments to move.

•	 Destination s Enter the rung number (or address) of the rung to move the comments to.

•	 Number to Move s Chose All or enter the number of comments to move from the 
source to the destination.

•	 Units s Select either Rung Number or Address.
Press OK to complete the move or Cancel to exit without performing the operation.

NOTE: You can overwrite existing rung comments with this feature. DirectSOFT6 always provides a 
confirmation prompt before it completes the move. The message reminds you that any overlapping 
comments will be changed. This message will appear even if there are no overlapping rungs. It is a reminder 
that existing rungs can be overwritten.
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Entering Stage Comments
Use Stage View

If you are using Stage instructions, comments can be entered for each stage. The Stage View 
must be displayed in order to enter the comments. With a Ladder View open, the Stage View 
is opened by clicking on View > Stage View on the Menu bar.

In order to enter Stage comments, the cursor must be positioned in either of the upper quadrants 
of the Stage view. To open the comment editor, either click on the keyboard shortcut Ctrl + 
K, Tools > Comment Editor on the Menu bar or press the Comments button on the Tools 
toolbar if it is displayed. The Comment editor can also be opened by double-clicking the left 
mouse button with the cursor positioned in the stage comment area. Note that the comment 
editor is for Stage comments.

Stage 
Comment Area

Stage 
Comments
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Comments are Free-form
A new comment can be edited immediately. The appropriate comment can be added as 
necessary.

Selecting Stages to Comment
Once you have edited a rung comment you can use the Page Up and the Page Down keyboard 
buttons to scroll through the Stages. A specific Stage can be found by using the Goto button 
on the editor dialog. After the comments have been entered, press the OK button to save the 
comments and close the editor.

Editing the Comments
The keyboard shortcut keys can be used to copy, cut and paste comments between stages.

1.	 Position the cursor at the beginning of the text to be copied or cut.

2.	 Press and hold the left mouse button and move the cursor to highlight the text, then 
release the button. The Shift + Arrow keys can also be used to highlight the text.

3.	 Use the Ctrl + C keys to copy the text or the Ctrl + X keys to cut the text.

4.	 Locate the stage where the information is to be pasted (Use Previous, Next or Goto).

5.	 Position the cursor where the text is to be pasted and click the 
left mouse button, then press Ctrl +V to paste the text.

6.	 The Delete key can also be used to delete text.

NOTE:  All documentation edits are written to the documentation files when they are entered/edited.
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Importing and Exporting
DirectSOFT6 can import and export ladder programs, element documentation (nicknames, 
wiring info and descriptions) and rung comments from a project. The Import/Export data 
is expected to be in CSV format (comma-separated variables) which is a popular import/
export text format for applications like Microsoft Excel and AutoCAD. For example, Microsoft 
Excel can be used to generate an element documentation file to be imported directly into a 
DirectSOFT6 project. The existing element documentation can be exported to a CSV file that 
can be used in diagrams in an AutoCAD program.

Exporting Program Documentation
The project must be open in order to export program documentation. Three export options 
are available to choose from, Program, Element Documentation and Rung Comments. The 
following steps will show how to export a program. There are two ways to export a program, 
either select File > Export > Program from the Menu bar or select the Export button on the 
File toolbar if it is displayed. Either method used will open the Export Program dialog shown 
on the facing page.

File Toolbar

File Export 
Options
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In the Export Program dialog, select where the program is to be exported to, enter the program 
name and click the Save button.

The following dialog will appear so options can be selected and saved.

Click the OK button to save the program to a text file.

Select where to save the 
 exported program.

Enter the 
program 
name



DirectSOFT6 User Manual, 2nd Ed. Rev. B6-16

Chapter 6: Documentation

The text file can be opened with Notepad or equivalent word processor. The Notepad example 
below shows what can be exported. Note the Rung Comments and the Element Documentation.

Export Element Documentation
Element information can be exported from a project to a .csv file. The following illustrations will 
show the steps to use to export the documentation. Press the Export Element Documentation 
button on the File toolbar or select File > Export > Element Documentation to export the 
documentation.

There are three different formats to select from to export. Standard, C-more and KEPDirect 
Server formats. All formats generate a .csv file in spreadsheet form.
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This is a standard format showing an Excel spreadsheet with the element reference in column 
A, the nickname in column B, wiring information in column C and description in column D.

The illustration below is the C-more format showing an Excel spreadsheet with the tagname 
(element) in column C, the data type in column D and element reference (Address) in column 
G.

NOTE: If unassigned nicknames are exported, they will appear in the resultant text as the following types: 
UB - unassigned bit 
UBY - unassigned byte (useful only for R memory in the DL305) 
UW - unassigned word 
UDW - unassigned double-word 
UU - unassigned unknown (used for uninitialized types, should never be used)
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Export Rung Comments
The program rung comments can be exported from a project to a text file and a printout can 
be obtained using Microsoft Notepad or equivalent word processor. The following dialog will 
appear when either pressing the Export Comments button on the File toolbar if it is displayed 
or by pressing File > Export > Rung Comments. Select where the file is to be saved, then 
name the text file and press the Save button.

The illustration below is an example of an exported comment text file shown with Microsoft 
Notepad.
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Importing a Program
There may be a time when it is necessary to import a DirectSOFT6 program which has been 
previously edited and exported as a text file. This could be an entire program or just a few 
rungs with element nicknames and comments. Use the following illustrated steps to guide 
you through the import procedure.

Begin by opening the New Project dialog from the DirectSOFT6 Launch window (page 
3-4). Cancel the New Project dialog, then either select File > Import > Program or press the 
Import button on the File toolbar if it is displayed.

File Toolbar

File Import 
Program
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The Import Program dialog will appear so the program text to be imported can be selected. 
Select a previously exported DirectSOFT6 program to import. Choose the program text file 
and click Open.

The complete imported program will appear as shown below. In this example, all elements, 
element descriptions, nicknames and rung comments appear in the program along with the 
cross reference.
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Exported programs, element documentation and rung comments can be imported using the 
DirectSOFT6 programming window if it has been opened to edit another program. This 
is done by first saving and closing the current program. Next, either select File > Import 
> Program or press the Import button on the File toolbar. The program to be imported is 
selected and opened as shown in the previous example.
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Importing Element Documentation
To import program documentation, a project must be open. This project can be the one 
currently open. The typical method for importing element documentation is to import a .csv 
file which has been previously exported. It is possible to generate element documentation using 
a spreadsheet such as Microsoft Excel, but it is important to follow the correct import format. 
The standard format is in spreadsheet form which should be setup in columns similar to the 
example below: element reference in column A, the nickname in column B, wiring information 
in column C and element descriptions in column D.

To import element documentation, 
select File > Import > Element 
Documentation or press the 
Import Doc button on the File 
toolbar. The window shown here 
will appear. Select the folder and 
the .csv file to be imported. Notice 
the Import Method box located 
on the right side of the window.
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There are three import methods to select: Merge (.PRJ priority), Merge (.CSV priority) and 
Delete existing. Selecting one of the three methods will determine the course of action which 
will be taken if the currently open project and the imported file have duplicate nicknames. 

•	 If .PRJ priority is selected, the nicknames in the imported file will be added to the project 
file. If there are duplicates, the nickname in the project file will be kept.

•	 If .CSV priority is selected, the nicknames will be added to the project file. If there are 
duplicate nicknames, the import file will overwrite the ones in the project file.

•	 If Delete existing is selected, all of the element documentation of the open project will be 
deleted, then it will be rebuilt with the contents of the .csv file. 

•	 Press the Open button to execute the import.

NOTE: If the following element types are imported, they will appear in the DirectSOFT6 documentation 
editor with “       “ under the element type column: 
UB - unassigned bit 
UBY - unassigned byte (useful only for R memory in the DL305) 
UW - unassigned word 
UDW - unassigned double-word 
UU - unassigned unknown (used for uninitialized types, should never be used)

Once the element documentation is imported, the Documentation editor will be updated 
with the imported information. This can be verified by opening the Documentation editor 
from Tools on the Menu bar, the Documentation Editor button on the Tools toolbar if it is 
displayed or use Ctrl + D. When the elements are created or if they are already used in the 
program, the element will be updated with the new information.
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Importing Program Comments
Exported program comments are imported like the element documentation as described on the 
previous two pages. To do this, select File > Import > Rung Comments  on the Menu bar or 
press the Import Comments button on the File toolbar. The following window will appear. 
Select the folder and the .txt file to be imported. 

Also select the Import Method to use. Merge (.PRJ priority) if the current project is to remain 
in place when the import is executed. If comment matching occurs, a message will appear 
asking which one to update, the imported file or the existing file. Selecting Merge (.TXT 
priority) will allow the imported comments to overwrite the existing ones. Delete Existing will 
delete the current comments and update with the imported comments.

Insert Instructions
The Insert Instructions From File 
feature will allow the insertion of 
mnemonic text files as instructions 
within an open project. Mnemonic 
instructions can be inserted one time 
or several times within a program. 
To use this feature, there must be 
an existing text file, such as, a file 
written with MS Notepad. This 
file must be written in mnemonic 
text form like the example on left. 
Note that rung comments, element 
descriptions, element nicknames and 
wiring information can be edited 
within the text file to be inserted. 

PLC type

Ladder mnemonics

“Nickname”

“Wire number”

“Reference” “Element Description”

Rung Comment
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The text file needs to be edited in the same format as shown, with a PLC type at the beginning, 
#BEGIN, the documentation and #END. Quotation marks are placed around each line of rung 
comments. Of course, the ladder mnemonics are also edited with the text file. The element 
documentation must be in this form: “element reference”, “element nickname”, “wire number”, 
“description”. Quotation marks must be used with each entry followed by a comma. If an entry 
is to be left blank, the quotation marks must not be omitted.

The mnemonics text which is to be inserted can also be edited without comments like the 
example below. Note the PLC type is at the beginning of the text.

To insert the mnemonic text in a program being edited (Edit Mode), either use the Tools > 
Insert Instructions From File on the Menu bar or press the Insert Instructions button on the 
Tools menu if it is displayed.

PLC type
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The Insert Instructions dialog will appear. Select the folder where the text file is located, then 
select the text file to be inserted. Next, choose either Insert at Beginning, End or Before 
Rung Number. How the element documentation can be imported involving “collisions” 
with existing program documentation can also be chosen. Select Merge (.PRJ Priority) if the 
existing project documentation is to remain unchanged. Select Merge (.TXT Priority) if the 
new documentation is to overwrite the existing documentation in the program. If the program 
element documentation is not to be changed, select Ignore Element Documentation. Press 
the Open button to execute the instruction.

The DirectSOFT6 Ladder view now displays the inserted instructions and documentation.
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Restore
One option which the Insert Instructions function has that can be useful is the Restore feature. 
Each time the Insert Instructions is executed, a backup copy of the entire program is made 
before the insert occurs. If an error is made, i.e. wrong code, just press the Restore button and 
the program will be restored to its original state.
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Prevent Documentation Loss
The documentation which is created with DirectSOFT6 is stored on disk. Each time a project is 
opened with DirectSOFT6, there are multiple project files opened. Apply the same precautions 
to your project as you would with any other database package to avoid data loss.

Backing up the project files is the best insurance to prevent loss. Any time changes are made 
to a project, make a copy of the project before starting. If something goes wrong, the original 
will remain intact and unchanged. There are four different methods to preserve a project as a 
program is created and after the project has been completed. The four methods are: Save Project 
(to disk), Save Project As, Backup Project and Export Program.

Save Project
Save Project to Disk should be used to save your project often. Your entire project, i.e., program 
and all documentation will be saved to the drive that is being worked from, usually the C: drive. 
From the Menu bar, select File > Save Project > to Disk or press Ctrl + S (keyboard shortcut).

To save a project to a different folder than the one being worked from, select File > Save 
Project As from the Menu bar. The save as window will appear so the folder can be selected 
where the project is to be saved. Name the project, press the Save button and the entire project 
will be saved.

NOTE: The Write to Disk button on the Offline toolbar only saves the ladder logic program.
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Backup Project
The backup feature is another way to save your project. Selecting File > Backup Project on the 
Menu bar or pressing the Backup button on the Offline toolbar will open the following dialog 
asking if the project is to be saved. Press the OK button to save the project.

The following Backup Project dialog will appear, the project can be saved with the default 
date/time stamp or rename the folder. A different drive can also be selected to save the project.

The last backup method is to use the export program feature as explained previously. This 
method will save a program to a text file. One advantage of the text file is that the program or 
comments can be edited without using DirectSOFT6.

Close all other applications that may be running to allow as much free RAM as possible. This 
not only lessens chances of memory conflicts, but also allows DirectSOFT6 to run much faster.

Consider printing a hard copy of the program at longer intervals. If your computer breaks down 
or you lose all of the data due to a disk crash, you will at least have a hard copy of the program.

Date and Time Stamp
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