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Tutorial: Building a Simple Project
This section explains, using a step-by-step tutorial, how to build a simple project, as well as how to 
select and confi gure an I/O driver.
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Creating a New Project
This part of the tutorial shows how to create a new project, including how to give it a name and 
select the target platform.

1) Click the Application button in the top-left corner of the development environment, and then 
click New on the Application menu. The New dialog is displayed.

2) Click the Project tab.

3) In the Project name box, type the name of your project. For this tutorial, type Tutorial.
The development application automatically creates a new directory of the same name and 
assigns your project fi le to that directory. (Notice the Confi guration fi le text box in the fi gure.) 
To put your project fi le somewhere other than in the default projects folder, click Browse and 
navigate to the preferred location.

4) In the Product type list, select the type of project that you want to build. For this example, 
select Windows Standard. This is a tag and feature-limited product type that can be safely 
deployed on Windows PC Platforms.

5) Click OK.
The New dialog is closed and the Project Wizard dialog is displayed.

6) In the Template list, select Empty Application.

Selecting the target platform and product type
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7) In the Resolution list, select 640 x 480.

8) Click OK. 
The Project Wizard dialog is closed and the new project is created in the development 
environment.

Specifying an empty Application with 640x480 resolution
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Specifying the Startup Screen
This part of the tutorial shows how to open the project settings and then specify which screen 
should be displayed on startup.

• Use the Information tab to provide information that identifi es the project (such as project 
description, revision number, Company name, Author's name, fi eld equipment, and general 
notes).

• Use the Options tab to specify generic settings for the project, such as the Target System, 
Automatic Translation, Alarm history and Events, Default Database and Shared Tags.

• Use the Viewer tab to enable/disable the runtime desktop parameters.

• Use the Communication tab to specify communication parameters relating to the project in 
general.

• Use the Preferences tab to enable/disable warning messages when using the development 
application.

To specify the startup screen:

1) On the Project tab of the ribbon, in the Settings group, click Viewer.
The Project Settings dialog box is displayed with the Viewer tab selected.

2) In the Startup screen box, type main.scr.
When you run the project, it will automatically display the main screen (or whichever screen 
you specify) fi rst. You can specify a screen before you create it, but if the screen has been 
created, then you can also select it from the list.

3) Click OK. 
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Creating tags
This part of the tutorial shows how to create new tags by adding them to the Project Tags datasheet.
A tag is any variable that holds a value. All tags created in an project are stored in the Project Tags 
folder, on the Global tab of the Project Explorer.

1) In the Project Explorer, click the Global tab.

2) Double-click Project Tags to expand the folder.

3) Double-click Datasheet View to open the Project Tags datasheet.

4) Use the following parameters to create a tag for the sample project.

a. Name: Specify a unique tag name. For this tutorial, type Level.

b. Array: Specify the top array index of the tag. (Simple tags have an Array of 0.) For this 
tutorial, type 3.

Each array index relates to one of the three tanks:

• Level[1] is the level of Tank #1

• Level[2] is the level of Tank #2

• Level[3] is the level of Tank #3

You will not use Level[0] in this tutorial, even though it is a valid tag.

c. Type: Specify the data type of the tag: Boolean, Integer, Real, String, or Class. For this 
tutorial, select Integer.

d. Description (optional): Type a description of the tag for documentation purposes only.

e. Scope: Specify how the tag is managed between the Server and the Thin Client stations.

• Select Local if you want the tag to have independent values on the Server and Client 
stations.

• Select Server if you want the tag to share the same value on the Server and Client 
stations.

For this tutorial, select Server.

Project Tags folder
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5) Save and close the Project Tags datasheet.

You will create additional tags as you build the project.

NOTE: You can sort the data in the Project Tags datasheet or insert/remove additional columns by right-
clicking on it and then choosing the applicable option from the pop-up menu.

Creating the Level tag
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Creating the Main Screen
This part of the tutorial shows how to create your fi rst screen, which will contain a single button 
that opens another screen.

1) In the Project Explorer, click the Graphics tab.

2) Right-click Screens, and then click Insert on the shortcut menu.
The development application stores all screens created for an project in this Screens folder.

The Screen Attributes dialog box is displayed.

Screen Attributes dialog box
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3) Use this dialog to set screen properties such as size and type.
For this tutorial, click OK to accept the default settings.
The Screen Attributes dialog box is closed, and the new screen is opened in the workspace for 
editing.

4) On the Graphics tab of the ribbon, in the Screen group, click Background Color. A standard 
color picker is displayed.

5) In the color picker, select a light gray color.

That color is applied to the screen.

Drawing the Main Screen's Title
This part of the tutorial shows how to draw the main screen's title using a Text object.

1) On the Graphics tab of the ribbon, in the Active Objects group, click Text.
Your mouse cursor changes from an arrow to a crosshair.

2) Click on the screen, type Welcome to the Tutorial Application, and then press Return.
This creates a new Text object with the specifi ed text.

3) Double-click the object to open its Object Properties dialog box.

• Double-clicking on any screen object opens an Object Properties dialog box containing the 
properties for that object. The properties shown in the dialog change depending on the type 
of object.

• The Object Properties dialog box also contains a pin button that controls whether this dialog 
remains open. The button changes state (and function) each time you click on it, as follows:

Color Picker

Object Properties: Text dialog box
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• When the pin button is released, the focus is passed to the object on the screen as soon 
as it is selected. It is recommended that this button is kept released when you want to 
manipulate the objects (Copy, Paste, Cut, or Delete). Although the Object Properties 
dialog box is on the top, the keyboard commands (Ctrl+C, Ctrl+V, Ctrl+X, or Del) are 
sent directly to the objects.

• When the pin button is pressed, the focus is kept on the Object Properties dialog, even 
when you click the objects on the screen. We recommend you keep this button pressed 
when you want to modify the settings of the objects. You can click an object and type the 
new property value directly in the Object Properties dialog (it is not necessary to click on 
the window to bring focus to it). Also, when the pin button is pressed, the Object 
Properties dialog does not automatically close when you click on the screen.

4) Click Fonts to open Font 
dialog box, and then specify 
the font settings.
For this tutorial…

• Font is Arial

• Font style is Regular

• Size is 20

• Color is Blue

5) Click OK to close the Font dialog box.
The font settings are applied to the Text object.

Specifying the font settings

Font settings applied to Text object
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6) Close the Object Properties dialog box (i.e., click the Close button in the dialog box's top-right 
corner).

Drawing a Button to Open Another Screen
This part of the tutorial shows how to draw and confi gure a button that will open another screen.

1) On the Graphics tab of the ribbon, in the Active Objects group, click Button.
Your mouse cursor changes from an arrow to a crosshair.

2) Click and hold on the screen, and then drag the cursor to draw the Button object.

3) Double-click the object to open its Object Properties dialog box.

4) In the Caption box, type the following text: Click here to open the synoptic screen.

5) Click Command.
The Object Properties dialog box changes to show the properties for the Command animation.

6) In the Type list, select Open Screen.

7) In the Open Screen box, type synoptic.scr.

Adding a caption to the button

Confi guring an Open Screen command on the button
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You can specify a screen that you have not yet created.

8) Close the Object Properties dialog box.

Saving and Closing the Main Screen
This part of the tutorial shows how to properly save and close a screen.

1) Click the Application button at the top-left of the development environment, and then click 
Save on the Application menu.
A standard Windows Save dialog box is displayed.

2) In the File name box, type main.

3) Click Save.
The fi le is saved in your project folder (at […]\Documents\Point of View v7.1 Projects\
projectname\Screen\main.scr), and the Save dialog box is closed.

4) Click the Application button at the top-left of the development environment, and then click 
Close on the Application menu.



Chapter 4: Tutorial: Building a Simple Project

1

2

3

4

5

6

7

8

9

10

11

A

B

4-13Point of View Software Reference Guide, 1st Edition - PV-SWREF-M

Creating the Synoptic Screen
This part of the tutorial show how to create your second screen, which will include an animated 
tank of liquid and some basic controls for that tank.

1) In the Project Explorer, click the Graphics tab.

2) Right-click the Screens folder, and then click Insert on the shortcut menu.
The Screen Attributes dialog box is displayed.

3) Use this dialog box to set attributes such as size and type.
For this tutorial, click OK to accept the default settings.

4) Click the Application button at the top-left of the development environment, and then click 
Save on the Application menu.
A standard Windows Save dialog box is displayed.

5) In the File name box, type synoptic.

6) Click Save.
The fi le is saved in your project folder (at […]\Documents\Point of View v7.1 Projects\project_
name\Screen\synoptic.scr), and the Save dialog box is closed.

Do not close the screen like you did the main screen when you saved it. You still need to draw the 
synoptic screen.

Drawing the Synoptic Screen's Title
As in a previous part, this part of the tutorial shows how to draw the synoptic screen's title using a 
Text object.

1) On the Graphics tab of the ribbon, in the Active Objects group, click Text.

2) Click on the screen, type Synoptic Screen, and then press Return.

3) Double-click the object to open its Object Properties dialog box.

4) Click Fonts to open Font dialog, and then specify the font settings.
For this tutorial…

• Font is Arial

• Font style is Bold

• Size is 20

• Color is Blue

5) Close the Object Properties dialog box.

6) Move the Text object to the top left corner of the screen.

7) Click the Application button at the top-left of the development environment, and then click 
Save on the Application menu. 

This fi gure shows how your screen should look after you've created the screen title. 

Finished screen title
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Drawing "Date" and "Time" Displays
This part of the tutorial shows how to draw "Date" and "Time" displays by linking Text objects to 
system tags. Date and Time are system tags that hold the current date and time of the local station. 
These tags are available to any project.

1) On the Graphics tab of the ribbon, in the Active Objects group, click Text.

2) Click on the screen, type Date: ##########, and then press Return.

3) Double-click the object to open its Object Properties dialog box.

4) Click Text Data Link.
The Object Properties dialog changes to show the properties for the Text Data Link animation.

5) In the Tag/Expression box, type Date.

During runtime, the project replaces the ########## characters of the Text object with the 
value of the system tag Date.

6) Close the Object Properties dialog box.

7) On the Graphics tab of the ribbon, in the Active Objects group, click Text.

8) Click on the screen, type Time: ##########, and then press Return.

9) Double-click the object to open its Object Properties dialog box.

10) Click Text Data Link.
The Object Properties dialog changes to show the properties for the Text Data Link animation.

11) In the Tag/Expression box, type Time.

Specifying the Date system tag

Specifying the Time system tag
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During runtime, the project replaces the ########## characters of the Text object with the 
value of the system tag Time.

12) Close the Object Properties dialog box.

13) Click the Application button at the top-left of the development environment, and then click 
Save on the Application menu.

This fi gure shows how your screen should look after you've created the date and time objects.

Placing an "Exit" Icon
This part of the tutorial shows how to place an icon (by selecting and confi guring a Linked Symbol) 
that allows the user to exit the runtime project.

NOTE: If any part of the project doesn't work as expected (or to exit the runtime application), switch back to 
the development application (ALT+TAB) and then click Stop on the Home tab of the ribbon. Then if needed, 
begin troubleshooting.

1) On the Graphics tab of the ribbon, in the Libraries group, click Symbols.
The symbols library is displayed.

2) In the Symbols menu tree, open the System Symbols folder and then open the Icons sub-folder.

3) In the Icons sub-folder, select exit01. 
The symbol will be displayed in the symbol viewer to the right of the menu tree.

4) Click on the symbol.
The mouse cursor will change to show that the symbol is ready to be placed in a screen.

5) Switch back to the screen where you want to place the symbol and then click in it. The symbol 
is placed as a Linked Symbol object. 

Finished date and time objects

Selecting the "exit01" symbol

Placing the Linked Symbol object
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6) With the object still selected, click Command (on the Graphics tab of the ribbon, in the 
Animations group) to apply this animation to the object.

7) Double-click the object to open its Object Properties dialog box.

8) In the Type list, select VBScript.

9) In the On Down box, type $Shutdown().
Shutdown is one of Point of View's built-in scripting functions, but it can be used within 
VBScript by prefacing it with a dollar sign ($).

10) Close the Object Properties dialog box.

11) Click the Application button at the top-left of the development environment, and then click 
Save on the Application menu.

Now, when a user clicks this icon during runtime, the project will stop and exit to the station's 
desktop.

Testing the Project
This part of the tutorial show how to test the project so far.

1) On the Home tab of the ribbon, in the Local Management group, click Run.
The project runs and the startup screen is displayed.

2) Click the button to open the synoptic screen.
The synoptic screen is displayed.

3) Click the exit icon to shut down the project.

If any part of the project doesn't work as expected, switch back to the development application 
(ALT+TAB) and then click Stop on the Home tab of the ribbon.

Placing an Animated Tank
This part of the tutorial shows how to select an animated tank from the Symbol Library and place it 
on the screen (similar to how you selected and placed the "Exit" icon), then associate some project 
tags with the tank's properties.

1) On the Graphics tab of the ribbon, in the Libraries group, click Symbols.

2) In the Symbols menu tree, open the System Symbols folder and then open the Tanks 

Specifying the Shutdown command on the symbol
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sub-folder.

3) In the Tanks sub-folder, select a tank symbol.
You may select any tank you like; they all function basically the same way.

4) Click on the symbol.
The mouse cursor will change to show that the symbol is ready to be placed in a screen.

5) Switch back to the screen where you want to place the symbol and click in it.
The symbol is placed as a Linked Symbol object.

6) Double-click the object to open its Object Properties dialog box.

  A tank is an arrangement of different objects and animations (for example a rectangle, a bar 
graph, etc.), all combined together as a Linked Symbol. You can modify the properties of this 
symbol by editing the properties list. For this tutorial, you will modify the tag associated with 

Selecting a tank symbol

The tank symbol's properties
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the tank level.

7) For the property TagLevel, delete the existing value and then type Level[Index].
Note that you do not need to reopen the Project Tags datasheet to create tags as you develop the 
project. 
Because you have not previously created the tag Index in the Project Tags database, an alert 
message asks you if you would like to create it.

8) Click Yes.
A New Tag dialog is displayed.

9) Confi gure the new tag with Array as 0, Type as Integer, and Scope as Local.

10) Click OK to close the New Tag dialog.
You can use the tag Index to set the array position of the tag Level, and show the level for any of 
the three tanks in the same object:

• When Index equals 1, the tank object shows the level of Tank #1 (i.e., Level[1]);

• When Index equals 2, the tank object shows the level of Tank #2 (i.e., Level[2]); and

• When Index equals 3, the tank object shows the level of Tank #3 (i.e., Level[3]).

  Also, because the tag scope is local, the tag can have different values for the Server and 
Client stations at the same time. Consequently, the local user (i.e., the Server station) can be 
monitoring the level of Tank #1 while the remote user (i.e., the Client station) is monitoring 
the level of Tank #2.

11) Close the Object Properties dialog box.

12) Click the Application button at the top-left of the development environment, and then click 
Save on the Application menu.
 This fi gure shows how your screen should look after you've created the tank object.

Confi guring a new tag

Finished tank object
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Placing a Level Slider
This part of the tutorial shows how to select a slider control from the Symbol Library and then 
connect it to the animated tank.

1) On the Graphics tab of the ribbon, in the Libraries group, click Symbols.

2) In the Symbols menu tree, open the System Symbols folder and then open the Sliders 
sub-folder.

3) In the Sliders sub-folder, select a slider control.
You may select any slider you like; they all function basically the same way.

4) Click on the symbol.
The mouse cursor will change to show that the symbol is ready to be placed in a screen.

5) Switch back to the screen where you want to place the symbol and click in it.
The symbol is placed as a Linked Symbol object.

6) Double-click the object to open its Object Properties dialog box.

7) For the property TagName, delete the existing value and then type Level[Index].
Just as with the tank, you need to modify the symbol property associated with the slider level.

8) Close the Object Properties dialog box.

9) Click the Application button at the top-left of the development environment, and then click 
Save on the Application menu.

Selecting a slider symbol

Finished level slider object
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Drawing a Tank Selector
This part of the tutorial shows how to draw a text input box that can be used to change which real-
world tank is represented by the animated tank on the screen.

1) On the Graphics tab of the ribbon, in the Active Objects group, click Text.

2) Click on the screen, type Tank: #, and then press Return.

3) Double-click the object to open its Object Properties dialog box.

4) Click Text Data Link.
The Object Properties dialog changes to show the properties for the Text Data Link animation.

5) In the Tag/Expression box, type Index.

6) Select the Input Enabled option.
This allows the operator to enter a new value for the tag during runtime.

7) In the Minimum Value box, type 1.

8) In the Maximum Value box, type 3.

9) Close the Object Properties dialog box.

10) Click the Application button at the top-left of the development environment, and then click 
Save on the Application menu.

  This fi gure shows how your screen should look after you've created the tank selector object 
(shown with a red arrow).

Confi guring the "Tank" text input

Finished tank selector object during runtime
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Testing the Project
This part of the tutorial show how to test the project again with the animated tank, the level slider, 
and the tank selector.

1) On the Home tab of the ribbon, in the Local Management group, click Run.
The project runs and the startup screen is displayed.

2) Click the button to open the synoptic screen.
The synoptic screen is displayed.

3) Type the tank number (1, 2, or 3) in the Tank label, and then use the slider to adjust the tank 
level.
Note that you can view/adjust the level of each tank independently.

4) Click the exit icon to shut down the project.

If any part of the project doesn't work as expected, switch back to the development application 
(ALT+TAB) and then click Stop on the Home tab of the ribbon.
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Confi guring the Communication Driver
This part of the tutorial shows how to select and confi gure a driver to communicate with an external 
I/O device.

NOTE: If you are using a DirectLOGIC or P3000 controller, see the Quick Start Guide for AutomationDirect 
Drivers manual (PV-ADCDRV-M) for information pertaining to those controllers.

1) In the Project Explorer, click the Comm tab.

2) Right-click the Drivers folder, and the click Add/Remove Drivers on the shortcut menu.
The Communication Drivers dialog is displayed.

3) Select a driver from the Available drivers list, and then click Select.
For this tutorial, select MODBU.
The driver is moved to the Selected drivers list.

4) Click OK.
The Communication Drivers dialog is closed, and the driver is added to the Drivers folder in 
the Project Explorer.

5) In the Project Explorer, right-click the MODBU folder, and then click Settings on the shortcut 
menu. 

MODBU driver selected
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The Communication Settings dialog is displayed.

6) Confi gure the communication settings as needed for the target device. For this tutorial, accept 
the default settings.

NOTE: For more information about a specifi c driver, click Communication Drivers on the Help tab of the 
ribbon.

7) Click OK to close the dialog.

8) In the Project Explorer, right-click the MODBU folder and then click Insert on the shortcut 
menu.
A new driver worksheet named MODBU001.drv is created and opened for editing.

9) Confi gure the worksheet header:

a. In the Description box, type Tutorial Modbus.
This setting is for documentation only; it does not affect the runtime project in any way.

b. In the Enable Read When Idle box, type 1. 
This setting is a trigger that takes a Boolean value. A value of 1 — either entered manually 
as above or evaluated from a tag/expression — forces your project to continue reading tag 
values from the target device even when there are no changes in value.

c. In the Enable Write On Tag Change box, type 1.
This setting is also a trigger. A value of 1 forces your project to write tag values to the target 
device only when those values change, rather than continuously. This saves system resources 
and improves performance during rutime.

d. In the Station box, type 1.
This indicates the I/O device number to be accessed by this driver.
Typically, the PLC is specifi ed as Device #1.

e. In the Header box, type 4X:0.
You must use a driver-specifi c format. The format for the MODBU driver is:
register_type:initial_offset

Communication Settings dialog for MODBU driver
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10) In the worksheet body, enter the tags and their associated device addresses — for each tag:

a. In the Tag Name fi eld, type the name of the project tag.

b. In the Address fi eld, type the value to be added to the header to form the complete device 
address.

Register Type Description
0x Coil Status

1x Input Status

3x Input Register

4x Holding Register

ID Slave ID Number

Completed worksheet header

Tag Name Address Complete Device Address
Level[1] 1 4X:1 (Holding Register 1)

Level[2] 2 4X:2 (Holding Register 2)

Level[3] 3 4X:3 (Holding Register 3)

Completed worksheet body
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11) Click the Application button at the top-left of the development environment, and then click 
Save on the Application menu.

12) When prompted to choose the driver sheet number, type 1 and then click OK.

Monitoring Device I/O During Runtime
This part of the tutorial shows how to monitor device I/O during runtime by using the Log 
window.

1) On the Home tab of the ribbon, in the Local Management group, click Run.
The project runs and the startup screen is displayed.

2) Press ALT+TAB to switch back to the development application.

3) Right-click in the Output window, and then click Settings.
The Log Settings dialog is displayed.

4) Select the Field Read Commands, Field Write Commands, and Protocol Analyzer options.

5) Click OK to close the Log Settings dialog.

You can now monitor the device I/O during runtime.
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Deploying Your Project as a Web Application
This part of the tutorial shows how to deploy your project as a web application, to which remote 
users can connect with Internet Explorer.
For Internet Explorer to work as a web thin client, it must install an ActiveX control that "plays" 
POV project screens. If your computer is connected to the Internet, then IE will automatically 
download the control from AutomationDirect.com's public server when you connect to a project 
runtime server for the fi rst time.
To deploy your project as a web application:

1) Confi gure the IP address of the data server.

a. On the Project tab of the ribbon, in the Thin Clients group, click Web.
The Project Settings dialog box is displayed with the Web tab selected.

b. In the Data Server IP Address box, type the IP address of the web server.
For this tutorial, type 127.0.0.1, which is the standard loopback address (a.k.a. "localhost").

c. Click OK to close the dialog.

2) Make sure the data server is set to start up when you run your project.

a. On the Home tab of the ribbon, in the Local Management group, click Tasks.

Web tab of Project Settings dialog box
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The Execution Tasks dialog box is displayed.

b. In the list of tasks, select TCP/IP Server Runtime, and then click Startup.
The Startup dialog box is displayed.

c. Select Automatic, and then click OK.

d. Click OK to close the Execution Tasks dialog box.

3) Save and close all open screens and worksheets.

4) Click the Application button at the top-left of the development environment, and then click 
Publish > Save All As HTML on the Application menu.

  Your project screens are saved as HTML fi les in the Web sub-folder of your project folder 
(i.e., \project_name\Web).

Execution Tasks dialog box

Startup dialog box
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5) Confi gure a web server to make the Web sub-folder available to the network. 
For this tutorial, use NT Web Server, the free, lightweight web server program that is included 
with POV. Simply copy the program fi le from […]\AutomationDirect\Point of View v7.1\Bin\
NTWebServer.exe to the Web sub-folder, and then double-click the fi le to run it. It 
automatically serves the contents of whatever folder it is in, without any further confi guration.

WARNING: NT Web Server is provided for testing purposes only. It should never be used in a real 
production environment or on a secure network.

  You can also confi gure the "root directory" or "home directory" setting of some other web 
server program (e.g., Microsoft IIS) to point to the Web sub-folder, or you can copy the 
Web sub-folder to an existing web server on your network. The web server (which makes the 
HTML fi les available to clients) and the data server (which actually runs your POV project and 
exchanges data with the clients) do not need to be the same computer.

6) On the Home tab of the ribbon, in the Local Management group, click Run.

7) Open a web browser (e.g., Microsoft Internet Explorer), and then enter the URL address of the 
synoptic screen on the web server. For this tutorial, type http://127.0.0.1/synoptic.html and 
then press Return. (127.0.0.1 is the standard IP address for the loopback network interface, 
a.k.a. "localhost.")
After a few moments, during which the browser downloads and installs the ActiveX control, the 
synoptic screen is displayed in the browser.

Notice that you can modify the level of any tank either locally using the project viewer or remotely 
using the web browser, and changes on one client appear immediately on the other. They work 
equally well.
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