Datallynx User Manual

5.0 DatalLynx PLC

5.1 Server

Overview

The Datallynx Server's primary function involves dialing up
to PLC(s) and recording the data into text files in the format
specified by the user.

The format of the text file is set with the Datallynx Monitor.
For more information on configuring the Server with the
Monitor, refer to the Monitor section.

5.1.1 Installing Service

The Datalynx Server needs to be installed and run in order
to run without user intervention. Doing so is a simple
process. Go to: Start Button -> Program Files -> Datalynx -
> Datalynx Server

) Documentation >

| % Documents y (7] FreeSMTP.het » DataLynx Moritor

[J Settings y [T Games K

) Search y 7 Ghost Installer Studio » [ Uninstall Datalynx

©) Help and Support () HP > [T) TeamWave Workplace

Z7 Run... [T HTML Help \Workshop » | [T) TeeChart Prové Active!

) InduSoft Web Studio 5.1 » 7] TOSHIBA

AT 8  Srd [T Indusoft Web Studio v6.0 » | 7] TOSHIBA applications

(8] Turn OFf Computer... ) Infragistics i) Visual Reports
B3O 0O S EHE mnupo » | ) ‘War FTP Daemon
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. (5] d
Click the "Install" button. o

Semer Bl2waREDIRECT

P Address: 192.168.0.50

Status

Mot installed

This window should appear (@ DataLynx Server - Trial ]
. « » File Help
showing Status as

Installed, Stopped.

Server Bl2wWAREDIRECT
IP Address: 192.168.0.50

Statug

Note: This does not start the
Datalynx Server. To start the
Server, refer to the Running
Service section.

Inztalled, Stopped

Start/Continue

Q Urinstall
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5.1.2 Running Service

If you do not already have the Datalynx Server Window

open, go to: Start Button -> Program Files -> Datalynx ->
Datalynx Server

) Documentation ¥
| % Documents y () FreeSTP.Met ’ Datalynx Monitar
[} Settings y [ Games ;
) Search y ] Ghost Installer Studio » 7 Uninstall Datalynx
©) Help and Suppart :) HP 'E TeamWave Workplace
&7 Run... [T} HTML Help ‘Workshop b 7] TeeChart Pro w6 Active!
: T InduSoft Web Studia 5.1 » | ) TOSHIEA
Il A ) Indusoft Web Studio v6.0 » | ) TOSHIBA Applications
[8) Turn OFf Computer... ) Infragistics b i) visual Reports

@ é J (') ‘@' % 7] InputPro

b |77 War FTP Daemon

This window will appear @ DataLynx Server - Trial %]
. . Eile Help
assuming Datalynx is not
. N 5 : BlZwWAREDIRECT
installed. Click the I:::; 2163050
. ress: 192.168.0.
"Start/Continue" button.

Statug

Ihztalled, Running

Note: It may take a couple of
minutes for the Server to start
running.
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5.1.3 Pausing

Pausing forces the Server to stop polling for PLC input. This
can be useful when configuring the Server because it will

prevent irrelevant data from being stored.

If you do not already have the Datalynx Server Window
open, go to: Start Button -> Program Files -> Datalynx ->

Datalynx Server

| % Documents » (D) FreeSMTP.het ’ Datalyrix Moritor
[J settings » :J RIS ’
) Search y 7] Ghost Installer Studio » [ Uninstall Datalynx
©) Help and Suppart ::) HP ’E Team'Wave Workplace
&7 Run... [T} HTML Help Workshop ] TeeChart Pra vé Active!

) InduSoft Web Studio 5.1

4| Log OFf IudskowesK: 7] Indusoft Web Studio v6.0
(8] Turn OFf Computer... o) Infragistics

"" @ @ e J (") ‘@' % 7] Input Pro

This window will appear -
Assuming Running

"'}_;-_‘_ElDataLynu Server - Trial x|

File Help

Server Bl2w/tREDIRECT
IP &ddress: 192 168.0.50

Status

Inztalled. Running

) TOSHIBA

[T TOSHIEA Applications
) Visual Reports

7)) War FTP Daemon

v v v v v
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Clle the " Pause (Stop "';{:;‘_Elnatalynu Server - Trial ﬂ
. . " il |
Listening)" button, and Hle el

. . Server BlZwWAREDIRECT
this window should
IP Addres=: 152 168.0.50

ap p car Status

Installed, Pauzed

Note: This does not stop
the DatalLynx Server. To
stop the Server refer to the
Stopping section

Start/Continue

5.1.4 Stopping

Stopping the Datalynx Server completely stops the
program, instead of stopping polling. This feature is useful
because the Server must stop before you can uninstall it.

If you do not already have the Datalynx Server Window
open, go to: Start Button -> Program Files -> Datalynx ->
Datalynx Server

) Documertation ¥
| % Documents y [T FreeSMTP.Net » Datalynx Maonitor
[ settings y ([T Games X
) Search » (7] Ghost Installer Studio » [} Uninstall Datalynx
©) Help and Suppart :] HP '-3 TeamWave Workplace
& Run... (7] HTML Help Workshop » 7] TeeChart Pro v6 Active!
= 7] InduSoft Web Studia 5.1 » | \T) TOSHIEA
PULAGIR ) Indusoft Web Studia v6.0 b |7 TOSHIBA Applications
(8] Turn OFf Camputer... ) Infragistics | () visual Reports
Start @ é J G) ‘@' % 7] Input Pro » | /) War FTP Daemon
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In the Datalynx Server [EIEEFEoEmai |
. . File Hel
Window, click the "Stop" =% ™"
. . Server BEwsREDIRECT
button, and this window
h ld appear IP &ddress: 192.168.0.50
shou :

Status
’]nstalled, Stopped

| Start/Continue

E : Pause [Stop Polling)

5.1.5 Diagnosing

Diagnosing the Datalynx Server allows the user to
troubleshoot and view real-time events.

If the Datalynx Server Window is not open, go to: Start
Button -> Program Files -> Datalynx -> Datalynx Server

| % Documents p ) FreeSMTP.Net » {5 Datalyrix Maritor
P ;earch » 7] Ghast Installer Studio » [ Uninstall Datalynx
©) Help and Suppart :? HP '-B Team'Wave Workplace
£ Run [T HTHL Help Workshop 7] TeeChart Pro v Active!

) InduSoft Web Studio 5.1
() Indusoft Web Studio v6.0
T Infragistics

7)) TOSHIBA

7] TOSHIBA Applications
) visual Reports

[T War FTP Daemon

| Log OFf Jkulakowski. .
(8] Turn OFf Computer...

v v Vv Vv v
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In the Datalynx Server Window, go to the menu:

File->Error Log

JIDatalynx Server - Trial ] ﬂ
File Help

[Imtalled, Pauzed ‘

_I Start/ContinLe
g Pause [Stop Palling]
Stop

EI Uninztall

The Diagnostics Window below should appear.

~Log Entries

741972004 8:53:47 &AM Server started.

873172004 8:50:34 AM Server stopped,

873172004 851:33 AM Server stopped.

843172004 3.55:23 A Server stopped.

9/3/2004 85359 &AM Server started,

94342004 34355 PM Server stopped.

97372004 50715 PM  Server stopped,

9/3/2004 51538 P Server stopped.

97342004 5:21:24 PM Server stopped.

94342004 5:23: 30 P Server stopped.

9/4/2004 111514 &M Server stopped,

9/4/2004 11:56:53 AM Server stopped,

3/4/2004 122816 PM Server started.

9442004 12:29:27 PM Server stopped.

57472004 12:38:42 PM Server started.

9/6/2004 85353 AM 9/6/2004 8:59:53 AM:Poll Error; 918876206 : Cannot connect
9/6/2004 30452 AM 9/6/2004 9:04:52 AM:Poll Error: 918876206 : Cannot connect
/642004 9:08:35 &AM 9/6/2004 3:08:35 AM: Tried to start polling while it iz not stopped
9/6/2004 91338 &AM 9/6/2004 9:13:38 AM:Poll Error: 918876206 : Cannot connect
E2004 31807 &M Server stopped,

9/6/2004 3.20:27 AM Server started,

8/6/2004 32255 &AM Server stopped,

9/6/2004 92559 &M Server started,

9/6/2004 9.26:38 &AM Server stopped,

9/6/2004 9.55:34 AM Server started,

9/6/2004 3:32.19PM Server stopped,

8/7/2004 B:32:40 &AM Server started,

9/7/2004 93737 AM Server stopped.

4

|»
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5.1.6 Uninstalling

For troubleshooting reasons, it is a good idea to uninstall the
Server entirely.

To open the Datallynx Server Window, go to: Start Button
-> Program Files -> Datalynx -> Datalynx Server

| % Documents y [T FreeSMTP.Net » Datalynx Monitor
(3 settings y (@) Games ki
) Search , 7] Ghost Installer Studio » 2 Uninstall Datalynx
©) Help and Support :J HP » 7 TeamWave Workplace
&7 Run... [T}) HTML Help Workshop ¥ ) TeeChart Pro v6 Active!
™) InduSoft Web Studio 5.1 » | ) TOSHIEA

d)|LogieXf Raakowsld, ) Indusoft Web Studio v6.0 » 7] TOSHIBA Applications

(3] Turn OFF Computer. .. o) Infragistics b () visusl Reports
: @ o J (") ‘@' % 7] Input Pro » || War FTP Daemon

& x|

File Help

Click on the "Uninstall"
button, and this window

should appear.

Sermver Bl2wWaREDIRECT
IP &ddress: 152.168.0.50

Status

Mot installed
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5.2 Monitor

Overview

The Datalynx Monitor allows the user to configure the
Datalynx Server and retrieve its data files over the network.
Also, the Datalynx Monitor permits the user to
troubleshoot. Below is the main screen and the explanations

of each field:

IShDatal ynx Monitor - TRIAL VERSION x|
File Tools Options Help

- Modemlz]-

: : ; COM Port J Status | Date
alhos i D t :
I =l | Dscomed || | 13 sk, Schodied GT272007  7/2000 SRS AN

Last Update

Server Address:

Status -

Urlocked Lock
Palling Modems Stop Paliing

Messages:
[Connected to Server

Server Address: Field where one enters the address of the
Datalynx Server

Last Update: Denotes the most recent PLC input time
Status: Displays the Server's locked and listening state

Modem(s): Displays list of currently configured modems on
the Server as well as each modem’s status

Note: Modems only lists the last update. Check the date to verify if
you are receiving information when expected.

Messages: Displays updates from the Server as well as from
the Monitor itself
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5.2.1 Configuring

Note: The Server must be connected in order to configure the
Server.

'-@DataLynu Monitor - TRIAL YERSION

Go to the menu: AT E
File Tools | Options Help

Options -> Configure R —
Server Server Addr Configure Server

: Stop Polling
Shut Down Server

A list of modems, if any, configured for the Server will

appear.

d’{'l Server Configuration 5]

Server Configuration

- Modem(s)
COM Port [ Alias | hdd ]
COM1 My Modem

Moadify/iew |
Delete |

Duplicate
q P e

oK | Cancel
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To add a modem, click on the "Add" button, and a Modem
Configuration screen like the following will appear.

'}f{_hModem Configuration X

Modem Configuration @« TextFiles  Daiabase
-Modem Settings -

Alims | Baud Rate:  |3600 ~| #Reties]3
COM Port: |EDM1 "I Browse... | Parity: 1None =
Phaone Murmber: | Add Delete
I—  Timedir 3| Ever_l,l--'r it ,_
iy [ TP = Daylnterval ST MIC T W ThE FC ST
)| At Time HH: [o0| MM [o0°
e Alizs i il o Alias |Address | Type |Attributes |1
I~ [ Log Phor | Belete
'— .. 1=
-
I
I |
vl e
I H
< | i
F Q + Madbuz RTL " Directlagic Memany

Cancel |

Below is an explanation of each of the Modem’s
Configuration Window's fields:

Alias: Optionally, a more descriptive name for the modem,
e.g., ‘My PC's Modem”

COM Port: The port the modem will use
Baud Rate: The speed that the modem will connect at

Parity: Parity that the modem will use; “none” is the default
parity and is preferred for most modems.

# Retries: Number of times Datalynx will try to read data
before it reports an error
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Below is an explanation of each of the Phone Number’s
Configuration fields:

Phone Number: The phone number Datalynx is to dial
Data Directory: Where the data files will be stored

Alias: Optional, a more descriptive name of the phone
49 . »
number, e.g., “Plant One in Atlanta

Use Alias in Filename: Configures Datalynx to use the alias
in the data logged file name

New Data file Cycle: Configures Datalynx’s new file
creation cycle

Field Separation: Configures either tab or comma to be
used in separating individual fields

Log Phone Number: Configures Datalynx to log the phone
number in the data file

Log Alias: Configures Datalynx to log the alias in the data
file

Display header for fields: Configures Datallynx to log the
headers in the first line of the data file

Log Timestamp in Data Files: Configures Datalynx to log
the date and time in the data file

Example Filename: Illustrates an example file name given
the current configuration

Archiving and Deleting:

Archive Files Cycle: Configures Datalynx to archive
monthly/yearly. Archives by zipping files into a zip file.

Archived Files Directory: Where the zipped files will be stored
Delete Files Cycle: How often Datalynx will delete the files

Modbus: Station #- the station # configured in the PLC

25



Datallynx User Manual

Diagnostics: One-Dial Test: Allows the user to perform a
trial dial up and poll to confirm that the configuration will
work

Poll Interval:

Timed Interval: allows the user to specify the poll to occur at
specific timed intervals

Note: If you have multiple phone numbers, each poll will dial each
of the phone numbers at the poll interval. In contrast, if each
phone number had an individual poll interval, there eventually
would be a conflict in poll times.

Day Interval: Allows the user to specify the poll to occur at
certain days and times

Fields: User-entered fields that Datalynx will request when
polling

26
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5.2.2 Modifying a Modem

To modify a modem, go to menu:

Options-> Configure Server

File Tools | Options Help

Server Sddr ':l:lrll:il;]ure Server
StopPoling e

Shut Down Server e

-

localhost

A list of modems, if any, configured for the Server will
appear:

% Server Configuration x|

Server Configuration

~Modem(s)
CDM qu l Aﬁas | ; ............ Kaa..uu......;‘
COM1 My Modem

Modify/iew |
Delete |

q |L| Duplicate |

oK | Cancel
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Click on the "Modify/View" button, and a Modem
Configuration screen will appear with the PLC data.

The Modem Configuration window below is an example:

i Modem Configuration x|

Modem Configuration « TextFiles © [
-Modem Settings

Alias My Modem Baud Rate; [3600 ~] #Reties]s
CO FPort: |CDM1 "I Browse. . | Farity: INone o

Phone Number: | Add | Delete

112222 |

-Diata Files -Pall Intersal
Fhone Mumber: [1112222 € Timed Interval Every HH: 00 Mu:[00
Data Directory: [C:\My Data Browss... |  Daylnterval SV M TT W Thl F[_ SI
Aliss (Optional) | At Time HH: [12 MM:[30°

Fields

I~ Use Alias in Filename

) Add Aliaz | Address | Type | Attributes | 1
New Data File Cycle: |Daily -vI I ‘water Level 40004 Integer [

Field & tion: : Temperat.. 40010 Float b
ield Separation:Conma =] Edit ] PatMum. 40100  ASCH Lengthd F
I~ |Log Phone Number | Delete

Display header for fields (Uses field
alias for header label)

[™ Log Time Stamp in Data Files

Example Fename [1112222an1-2003 csv

-Archiving and Deleting -
Archive Files Cycle: [Never =l
Archived Files Directory: [ Browse.. |
Delete Files Cycle: [Never |
Modbus RTU Diagnostics q | i
Staon Nuber. [T | OneDialTea | @ Modbus RTU € DirectLogic Memmary

Cancel |

Once finished making changes, click the "OK" button or

"Cancel” to discard your changes.
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5.2.3 Deleting

@& Datalynx Monitor - TRIAL YERSION

To delete modems, go =
to menu: Options- File Tools | Qptions Help
>Configure Server s Configure Server I

Stop Polling
Shut Dawn Server

COnnet

localhost

A list of modems, if any, configured for the Server will

appear:
(3 Server Configuration i x|
Server Configuration
~hodem(s)
COM Port | Alias
COM1 My Modem
Modify/iew
Delete
Duplicate
| [ ——
0K | Cancel |

Select the modem to delete and click the "Delete" button.
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5.2.4 Duplicating

A modem listing may be created and duplicated. This
duplicating option is a great time-saving feature for those
with many modems with similar configurations.

To duplicate a modem
listing, go to menu:
Options  ->Configure

Server Addr Configure Server
rver :
Serve lnrallvast Stop Polling

Shut Dawn Server

'fi;f,_i}DataLynu Monitor - TRIAL YERSION
File Tools  Options Help

A list of modems, if any, configured for the Server will

appear.
i:".-.f*Server Configuration %]
Server Configuration
-Modemis)
e aien T
COM1I My Modem
ModifyAiew
Delete
Duplicate
| |+
0K | Cancel |

Click the "Duplicate” button, and a window will appear
asking for COM Port, Alias , Baud Rate, Parity, and #
Retries. Enter the necessary information and click “OK” to
save changes, otherwise click “Cancel” to discard changes.

i
"—l
COM Port: | j i Browse. . II
Alias (Optional): |

Baud Rate: |SEUU v|
Parity: I Mone - |

# Retries: o

ok | cance |
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5.2.5 Connecting

Connecting to a Datallynx Server is important because it
allows the user to configure the Datalynx Server and
retrieve its data files.

In the main screen portion labeled Server Address: enter the

Address.

Server Address:
|I|:u:alh|:|3t ﬂ Cannect

Then press the "Connect" button. If the connection has
been made, the "Connect" button text will become
"Disconnect.”

Server Address:

| J Dizconnect
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5.2.6 Hiding

Hiding is a convenient feature for temporarily placing the
Monitor out of view for later access. To hide the Monitor,
go to the menu: File->Hide

3 DataLynx Monitor
'Ele Tools Options Help

Exit |

Notice that the Datalynx icon

appears on the task bar: @ ;pl ‘i ﬂ

Conversely, the application may be restored by right clicking
on the icon and selecting the "Restore” item:
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5.2.7 Backing Up and Restoring

Backing Up

Backing up the configuration allows the user to safely restore
all changes in the event of a hardware failure. To back up the

configuration, go to the menu: Tools->Backup
Configuration

3 DataLynx Monitor

File ‘Toals- Options  Help

Gep,  Report
Restore Configuration =

B £ackup Configuration —

Lz Lock Server

You will be prompted for a filename. Click "Save" and note
where you saved the file for a possible future restoration.

Restoring

To restore the configuration, go to the menu: Tools->

Restore Configuration The following window should
appear.

(=) DataLynx Monitor

File T]_oals- Options Help
G Report

Restore Configuration
Backup Configuration
~Le Lock Server

You will be prompted for a filename. Click "Open" and the
Server/Monitor should be restored to its original state.
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5.2.8 Polling

The Datallynx Server maintains "polling” and "not polling"
states for PLC input. The user may change the polling state
from the Monitor as well as from the Server program.

Changing the polling state can be useful when in the process
of installing new PLCs or changing the PLC configuration
to prevent the Server from receiving irrelevant data.

Click on the "Start Polling" button (If the button states
"Stop Polling” that means the Server is already listening).

Mot Paolling Modems Start Polling

If successful, the status should now read "Polling Modems."

Palling Modems Stop Polling

To Make the Server Stop Polling, click on the “Stop
Polling” button.

Falling Modems Stop Polling

If successful the status should now read "Not Polling
Modems."

Mot Polling Modems Start Polling
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5.2.9 Locking / Unlocking

Locking/Unlocking is a useful feature for preventing
unwanted modem configurations and Server polling state
changes. Steps to lock/unlock are below:

Click the "Lock" Status
button. Unlacked Lock

A screen will appear 5

aSklng for the lock Flease enter the password to lock the server.
code.

Password:||

0K Cancel |

Enter the lock code, and Click "OK." If successful, the

status section should now display a locked status:

Status

Locked Unlock

Warning: If you forget/lose the lock code you will NOT be able to
unlock the Server.

Conversely, to unlock the Server, click the "Unlock" button,
enter the code, and Click "OK.”
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5.2.10 Reporting

Reporting is one of the most useful features of the Monitor.
The user may view or save files generated by the Server over
a network without having physical access to the Server.

To view a report, go to menu: [SIEEETRIEITTET
Tools -> Report ie | Tools Options Help
W ot
r Restore Configuration D
Backup Configuration
~ Lz Lock Server N

hlmsna

A report screen like the following dialog box should

appear:

{TReport i =] )
Selecta phone line and then select a file, optionally vou can select the madem

To open afile click the Open or the Open With... button.
To save the file to this computer click the Sawve ... button
—Filelz)

Modem: | (My Madem] COM?1 =]
~ Phone Ling(z]

| | »] Cloge
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Select the desired PLC data you wish to view in the
modem/phone number list:

;E‘th Report

=0} x|
Selectaphone line and then select afile, optionally vou can selectthe modem

To open afile click the Open or the Open With... button.
To sawve the file to this computer click the Save... button

—File[z) -
Modem: | [ty Modem) COM1 =]

Phone #

1 8876206-September-06-2004, cov

918876206~ anuary-01-2004. cav e
i~ Phone Line(s] 918876206~ anuam-02-2004, cav G
- 9B8ETE206-) anuam-03-2004. cav

1 | ¥ Cloge

Now select a file in the File(s) list and click either the
"Open,” "Open With..." or the "Save" button. There is a
difference between the "Open" and "Open With...."
buttons. "Open" uses the default application to open the

file. "Open With..." prompts you for the application in
which to open the file.

Note: If you open the current log file outside of DatalLynx (Example:
log file straight from Excel), it will lock the file and not allow
Datalynx to store data.
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