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5
Using LookoutDirect

Overview of the Process Development Cycle
The first step in developing a process file is creating a process file. After the 
file is created, control panels are added. Control panels are windows you use 
to place other objects, such as switches, Pots, and trends to be displayed. You 
can make them look like physical control panels, complete with switches, 
push buttons, bezels, insets, lamps, gauges, and so on. Your imagination is the 
only limit to how the control panels look and function.

After you create at least one control panel, you can then create and display any 
number of other objects. Remember that objects can be displayed on a single 
control panel or on multiple control panels. For example, you can insert the 
same switch on several panels. If you flip the switch on one panel it 
immediately flips on all the other panels.

The first objects you might want to create could be those that represent your 
Plus and Ruts. These type of object classes often use your computer 
communication ports, so you may have to configure your ports for radio, 
dial-up modem, or hard-wired connection, as appropriate. See Chapter 3, 
Serial Communications, in the LookoutDirect Developer’s Manual for 
information on configuring communications.

When you create an object that represents a PLC, RTU, or other I/O device, 
its associated functionality and database are part of the object. The 
functionality built into this type of object class includes a protocol driver, 
enabling the object to talk with the physical device. The native (default) 
database includes all registers, bits, I/O signals, parameters and other values 
that the physical device can transmit to or receive from LookoutDirect.

At this point, you may want to add data members to the native databases 
for your objects. Such new data members, called aliases, can include 
descriptive names, signal scaling parameters, alarming parameters, and so on. 
You can create more than one alias for a given native data member, using 
different scaling or alarm parameters for each.

As you create objects, you can connect them to other objects. The type of 
objects you create (such as Pot, Switch, Madcaps, Trend, and so on) and the 
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manner in which you connect them determine how your system interacts with 
your process.

Many object classes you use take advantage of LookoutDirect services. For 
example, you can assign a security level to a Pot object, and the Alarm object 
class uses the Alarm processing subsystem. As you create objects that take 
advantage of these services, you should configure the services to custom fit 
your application requirements.

Tip You can save a process file with any name you choose. Your process file name does not 
have to be identical to your process name. You can copy (or Save As) LookoutDirect files to 
retitle them and run the process just as you would run the original files. You cannot, however, 
run two processes with the same process name in a single instance of LookoutDirect. If you 
have a basic process that you need to make several variations on, you can rename the process 
in each file by right-clicking on the process name in the LookoutDirect Object Explorer and 
selecting Rename.

Building Client and Server Processes
As explained in the Client and Server Processes section of Chapter 2, How 
LookoutDirect Works, LookoutDirect server processes are run on computers 
with physical connections to your hardware. LookoutDirect clients run on 
computers that can communicate with the computers running LookoutDirect 
servers.

You build these clients and servers by choosing objects and making 
connections.
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LookoutDirect Navigation
Many LookoutDirect dialog boxes that you use to create an object, display an 
expression, make a connection, and so on contain some variation of the 
following dialog box. This dialog box is used to locate any object in any 
LookoutDirect process running on your network.

Each computer registered as running LookoutDirect appears in this dialog 
box. Clicking on the computer to open the full display reveals the processes 
currently running on that computer. Clicking on a particular process reveals 
all the objects in that process that you can access.

The pull-down combo box at the top of such displays indicates the root 
location. To display all the computers registered as running LookoutDirect as 
well as displaying your own computer as local, you set Universe as your root. 
You can set your local computer, the network of registered LookoutDirect 
computers, any specific computer in the network, or any process as the root 
by right-clicking on that node and selecting Make Root.

Note LookoutDirect cannot edit processes over the network, so what you can do with 
computers and processes running under the Network node is limited. To edit a process, you 
must work from your computer’s local node (or a process running on it).

You can distinguish between LookoutDirect’s local and network 
representation of your computer in the root selection window by looking at 
the computer icon. The network representation of your computer name has 
red arrows representing the network I/O connection, as shown on the right in 
the following illustration. The local representation, on the left, has no I/O 
arrows.
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See Chapter 4, Networking, in the LookoutDirect Developer's Manual for 
more information on registering computers and navigating through 
LookoutDirect processes on your network.

Creating A LookoutDirect Process

The following explains the basic procedure for creating a new process file.

1. Select File » New. 

The Create Process dialog box appears.

2. Enter a LookoutDirect process name in the Process Name field. This 
name must follow the same conventions as a LookoutDirect object name. 
See the Object Names section for detailed information on LookoutDirect 
naming conventions.

3. Make selections in the State Information group. Each control is 
explained below.

Note If you are going to have a backup computer in your network that will come online and 
run this process in the event that your primary computer crashes, you should include a 
location on that computer as one place to save the process state file. See Chapter 10, 
Redundancy, of the LookoutDirect Developer’s Manual for more information about setting 
up backup computers and processes.
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• Select Save State File with Process File to save the state file in the 
location where the process file was opened. This is the default 
behavior.

• Select Save State File in LookoutDirect Folder to save the state 
file in the LookoutDirect folder of the copy of LookoutDirect your 
are currently running. The state file name will be the same as the 
process name. This is useful if multiple computers are sharing a 
process file. In this case, each computer maintains its own state file 
locally.

• Select the Save Standby State File check box to save one or more 
extra copies of the state file in a location of your choosing. Enter a 
complete path, including state file name, to each location you want 
to save a state file. If you are saving the state file to more than one 
backup or alternative location, separate the paths with the vertical 
bar (|) symbol.

• To set the frequency that LookoutDirect saves the state file, check 
the Save state file(s) every check box and fill a value for the number 
of minutes you want to pass between each save. Remember that 
saving files uses system resources, so if you have a number of 
processes, each saving one or more state files fairly often, you may 
experience some performance problems.

4. Make selection in the Citadel Database group. Each control  is 
explained below.

• If you check the Use default values check box, LookoutDirect uses 
the default location set in the System Options dialog box of any 
instance of LookoutDirect running the process.

• If you enter a computer name and a path on that computer to a 
specific folder, LookoutDirect logs data to that location on that 
computer, no matter what computer is running the process.

• To designate a specific computer and path for your process to log 
data to, enter the fully qualified network name for the target 
computer in the Citadel database computername field, and the 
complete path to the target database directory in the Citadel 
database folder field.

Note State Information and Citadel Database settings you make when creating a process 
override any settings you may have made in the System Options dialog box.
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Creating Objects

Choosing Objects
How do you decide what objects to use and what connections to make?

Some decisions are easy—you will certainly use driver objects for the 
different PLCs, RTUs and other devices you need to monitor and control. 
Other decisions are driven by what you want to do.

To solve problems with LookoutDirect, ask yourself which object does what 
you need done.

LookoutDirect has many object classes with obvious uses, such as push 
buttons, switches, and trend displays. Other LookoutDirect object classes 
may not be as immediately obvious as to how they might be used. To 
familiarize yourself with LookoutDirect object classes, you can browse 
through the online help LookoutDirect Object Reference topic, or the PDF 
LookoutDirect Object Reference Manual that was installed along with 
LookoutDirect.

The Select Object Class dialog box that appears when you create a new 
object has short descriptions of each object class. Browsing through these 
descriptions is another good way to acquaint yourself with LookoutDirect 
functionality. You can find a list of these descriptions in Appendix A, 
LookoutDirect Object Descriptions.

After you become familiar with the LookoutDirect object classes, you have a 
better idea of which object to create—or which object classes to 
investigate—to solve the problem you are facing at the moment.

Create an Object
Complete the following steps to create a LookoutDirect object.

1. Open or create a new process if one is not already open in LookoutDirect. 
Make sure you are in edit mode. (Select Edit»Edit Mode or press 
<Ctrl-Shift> if necessary.) 

2. There are two ways to create new objects in LookoutDirect:

• Select Object»Object Explorer from the menu to activate the 
LookoutDirect Object Explorer. Right-click on the process you want 
to create an object in and select New Object. For this example, 
select the Pot class of objects, found in the Control category.
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• Select the Object»Create command from the LookoutDirect menu 
bar. For this example, select the Pot class of objects, found in the 
Control category.

3. The Select object class dialog box appears, as shown in the following 
illustration.

  

Figure 5-1.  Select Object Class Dialog Box

The first time you create a LookoutDirect object, the Select object class 
dialog box appears with the Categorize option checked. Some object 
classes are contained in more than one category, depending on their 
versatility.

If a category is open, you can jump to the object class you want by type 
in the first few letters. To have access to all object classes with this 
technique, disable the Categorize option by clicking the Categorize 
check box.

When you select an object class, a dialog box you use to define the 
parameters for a specific object appears, as shown in the following 
example for creating a Pot object.



Chapter 5 Using LookoutDirect

Getting Started Guide 5-8 www.Automationdirect.com

 

Figure 5-2.  Object Definition Dialog Box

4. Assign a unique name to the object. Valid names are described in the next 
section, Object Names.

5. Define the object parameters. Each object class has unique parameters, 
described in the LookoutDirect help file or the LookoutDirect Object 
Reference Manual.

Ordinary parameters that can only be set in the object definition dialog 
box are indicated by white fields.

Some parameters, however, are expressions, denoted by a yellow field. 
Expressions let you set a parameter value programmatically by 
connecting the parameter to a data member of another object. You can 
also manipulate data using the expression functions, which are roughly 
the equivalent of spreadsheet formulas. See the Connecting Objects 
section of this chapter for a basic explanation of using expressions, and 
Chapter 2, Expressions, of the LookoutDirect Developer’s Manual for 
detailed information on expressions and expression functions. The 
tutorial exercise in Chapter 3, Getting Started with LookoutDirect, also 
demonstrates using expressions.

6. Leave Position source set to Local.

The Position source determines what value your control takes when 
your process first opens, and also affects the way the control operates.
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Selecting Local configures your control to take its value from the state 
file when the process opens. The value of the control will not change 
unless you adjust it manually or programmatically using a direct 
connection to the control’s value data member.

Selecting Remote configures your control to take its initial value from a 
read/write data member of some other LookoutDirect object. To 
accomplish this you enter a URL to the data member, wherever its host 
process may be running. This connection is reciprocal; adjusting the 
control changes the value of the data member, and any change in the data 
member from some other cause adjusts the value of the control. See the 
Remote Position Source Connections section of this chapter for more 
information on remoting controls.

Note The remote position source has changed in LookoutDirect 4.0. If you are accustomed 
to developing processes in earlier versions of LookoutDirect, make sure to read the Remote 
Position Source Connections section of this chapter in order to understand the changes and 
make the best use of this feature.

You can select DDE as your position source if you want to use DDE 
networking or if you need to connect your control to an application other 
than LookoutDirect, such as Microsoft Excel. See Chapter 5, Dynamic 
Data Exchange, of the LookoutDirect Developer’s Manual for detailed 
information on using this feature.

DDE networking was used in versions of LookoutDirect earlier than 
LookoutDirect 4.0. In general, the TCP/IP networking built into 
LookoutDirect 4.0 and greater is more efficient and easier than DDE 
networking. If you are maintaining an old LookoutDirect process, or 
have some special need to use DDE networking, you can find detailed 
information on this function in Appendix A, Networking with DDE, of 
the LookoutDirect Developer’s Manual.

7. Select OK to create the new object.

Many object classes do not have components (other than a data member 
value) that you can display on a control panel, such as a protocol driver 
for a typical PLC, or an object class such as Neutralzone or Pulse (both 
LookoutDirect object classes with special functionality).

Some objects, like Pots, can be displayed on a control panel. When you 
create such an object, LookoutDirect presents you with a dialog box you 
use to define how the object is displayed on the currently active panel 
(if there is one).

8. If you created your object using the LookoutDirect Object Explorer, it 
will appear in the Object Explorer window but not on any control panel. 
To display the pot, you will have to drag and drop it to the control panel 
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you want it to appear on. If you created your object using the menu, the 
display properties dialog box appears as soon as you click on OK to 
finish defining the object.

 

Figure 5-3.  Pot Display Dialog Box

9. In the display dialog box, choose how you want the object to be 
represented and select OK.

10. Position the object on the control panel and adjust the size.

Note You can copy objects to paste onto another LookoutDirect panel in the same process, 
but if the panels are of different sizes, the pasted objects may not appear in the proper location 
on the new panel. In general it is easier just to drag the object to the new panel from the 
LookoutDirect Object Explorer. 

Object Names
A name is how you identify a specific object. You must assign each object a 
unique name. LookoutDirect does not allow you to create or modify an object 
if the name is not unique or if it does not follow the proper naming 
convention.

Rules for choosing names are as follows:

• Names may include the characters A – Z, a – z, 0 – 9, and the underscore 
character ( _ ).

• Names must begin with a letter.

• Names may be up to thirty two (32) characters long.

• Spaces and tabs are not allowed.

• LookoutDirect recognizes uppercase and lowercase characters as the 
same character, so SW2 and sw2 are the same name.

• Names cannot be LookoutDirect keywords (object class names and 
function names). For example, you cannot use terms such as Switch, 
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DelayOn, STDEV, Modbus, nif, and Trend. You can, however, use 
Switch1, Switch2, and so on.

Some example of valid names are as follows:

• Pump3_HOA

• HighServicePump3_Run

• ClearWellLvl_at_Hiway289_and_I35

• ShaftTempF

• Pushbutton1

• runtime

• Sw1

• Sw2

Some examples of invalid names are as follows:

• 3Pump_HOA, which begins with a number

• _HighServicePump3_Run, which begins with an underscore

• ClearWellLvl at Hiway289 and I35, which contains spaces

• #ShaftTempF, which begins with #

• Pushbutton, which is a reserved word

• ThisnameIsWellOverThirtyTwoCharacters, which is too long

• and, which is a reserved word
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Connecting Objects
In LookoutDirect, you connect objects to pass control signals between 
objects. Once connected, objects pass signals between their various data 
members and parameters.

There are a number of different kinds of connections in LookoutDirect, and 
different ways to make those connections. The method you use depends on 
what you are trying to accomplish.

You can connect one data member to another. You can connect a data member 
to an object parameter, or an object parameter to a data member. Finally, you 
can make a URL connection as a remote position source for a LookoutDirect 
control or symbolic link, or as a trace item for a HyperTrend object.

You can make these LookoutDirect connections in the following ways:

• Direct—Made with the Edit Connections dialog box, these connections 
are fixed and work in one direction only. This sort of connection should 
only be made from a server process to hardware installed on the server’s 
computer, or between objects contained within the same process.

• URL remote—A URL remote connection is a flexible type of fully 
reciprocal connection between a LookoutDirect control and a 
LookoutDirect object read/write data member. Changing the control 
changes the data member, as you would expect, but if the value of that 
data member changes from some other cause, the control value changes 
as well. This sort of connection is what you use to connect a client 
process to a server process, or to link two client processes through a 
server.

• Complex—You can make complex connections using variables and logic 
tests to respond dynamically to changing needs and circumstances. 
Complex connections can apply mathematical operations to data, 
processing it for use by another object. You can make direct complex 
connections, and with the LookoutDirect Symbolic Link object, make 
remote complex connections as well.

Tip Remember, when you choose an object in the Edit Connections dialog box, always 
select the object you want to connect to.
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Connecting Data Members to Parameters 
The following example uses the (implicit) data member of a Pot object as the 
Data source of an Average object to illustrate the simplest type of 
LookoutDirect connection. You can tell that Data is a parameter because it 
appears in the Average object dialog box.

Suppose you create a Pot object as shown in the following illustration.
 

Next you might create an Average object. Connect the potentiometer numeric 
signal to the Data parameter by entering Pot1 as the Average object’s Data 
parameter. The Average object calculates the average level of Pot1 over time, 
as described in the Average object definition in LookoutDirect help or the 
LookoutDirect Object Reference Manual.

  

This is the simplest case for making a direct connection in LookoutDirect; 
connecting the input for one object to the output of an object in the same 
process. In many cases you will have to connect objects in one process to 
objects in another process on the same computer, or on another computer on 
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the network. For these connections you may find it more convenient to use 
the expression editor, which you access by right-clicking in the yellow 
expression field. The tutorial examples in Chapter 3, Getting Started with 
LookoutDirect, guide you through making connections in detail.

Identifying Object Data Members
Because many objects generate multiple signals you can use as inputs to other 
objects, the object name is not always sufficient to identify the desired signal. 
You must identify both the object name and the appropriate data member. For 
example, a Modbus object generates thousands of signals, some logical and 
some numeric. To specify exactly which signal you want from a particular 
Modbus object, enter the object name followed by a period (.) and the data 
member you want.

If you have a Modbus object with a name PLC1, and you want to display the 
value residing in holding register 40001 and the status of coil 100, reference 
those particular data members by typing PLC1.40001 in one expression and 
PLC1.100 in another expression.

Connecting Data Members to Data Members
The following information expands on the previous example, in which you 
created a potentiometer named Pot1. In this example, you create a Modbus 
object and connect the numeric signal generated by the pot to a 16-bit holding 
register at address 40001 on the PLC.

1. Create a Modbus object. You do not have to have a real PLC connected 
to your system. Just accept the default parameter settings in the Modbus 
dialog box and click OK.

2. If your Object Explorer is open, right-click on the Modbus object you 
just created and select Edit Connections from the pop-up menu. 
Otherwise select Object»Edit Connections from the LookoutDirect 
menu bar. You use this the Edit Connections dialog box any time you 
are connecting to the database of another object.

3. If you use the Object»Edit Connections menu command, the Edit 
Object Connections list box appears. Choose the object that contains the 
data member you are connecting to.
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The Current location combo box at the top of this dialog box should 
show your computer as root. See the LookoutDirect Navigation section 
for more information on how to set the root in a LookoutDirect dialog 
box.

Because you are connecting the Pot1 signal to data member 40001 in the 
Modbus object, select the Modbus1 object and click on OK. The Edit 
Connections dialog box appears.
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The top part of this dialog box contains information on the object you are 
connecting to. You select a writable data member from those listed in the 
Writable members list, and the selected member appears to the left of 
the yellow expression field in the center of the dialog box.

The lower part of the dialog box lets you navigate to the data member you 
want to connect to the data member you select in the upper portion of the 
box. You can also enter a data member directly in the yellow expression 
field.

4. Enter the data member you want to connect to in the list box to the right 
of the Select button. You can type the data member you want directly, or 
you can choose it by scrolling through the list of writable members and 
clicking on the data member (or range of data members) you want. You 
can edit the number that appears in the selection box.

Click on the Select button to identify the data member to be written 
to. Notice the dialog box now reflects the specific member; 
Modbus1.40001 =. Also notice the equal (=) sign. This prompts you to 
connect an expression to Modbus1.40001. In this case, use the 
expression Pot1.

5. Inside the Signals section of the dialog box, set the your local computer 
as the root in the In field. Navigate to Pot1 and select it by clicking on 
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it. Click on the (implicit) data member in the Contents (readable) 
list and then click on the Paste button.

 

Notice that the data type of the data members you have selected are 
displayed to help you make sure you are connecting like type to like type. 
Notice too that you can easily edit existing connections by clicking on the 
list in the Existing connections field.

Note Just above the Contents (readable) list in the Signals section, you will notice a list box 
named Path Mode. This is an important setting for developing networked processes in 
LookoutDirect. See the Path Names in LookoutDirect section for more detailed information 
on how to use this feature. Using different path settings is demonstrated in the exercises 
contained in Chapter 3, Getting Started with LookoutDirect.

6. Click on the Accept button. This confirms the connection. You should 
see a message confirming the action. You will also see data member 
40001 added to the Existing connections list box.

You have now connected a data member of one object to a data member of 
another object. Any change in the (implicit) value of Pot1 is, by definition, 
an event, sending a signal to all the other objects Pot1 is connected to. 
Because it is now connected to Modbus1.40001, adjusting Pot1 changes the 
value of data member 40001 in object Modbus1.
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URL Connections
A URL (Universal Resource Locator) connection is distinct from a 
connection made through an expression because it cannot contain any 
condition checking or mathematical operations. It is also designed to permit 
reciprocal flow of data through the connection. A control connected to a PLC 
register using a URL connection changes the register value when it is 
adjusted. But if the register value changes from some other cause, the control 
will also change to match the current register value.

You can only make a URL connection to data members that are writable, 
or both readable and writable. You cannot make a URL connection to a 
read-only data member. Remote position source connections, Symbolic 
Links, and the HyperTrend object require URL connections, as indicated by 
a green field.

You can edit a URL by right-clicking in the green field, which opens the 
LookoutDirect URL Editor dialog box, shown in the following illustration.

 

You can use the tree view in the left window to locate the object you want, 
and select the data member in the right window. Click on the Paste button to 
insert the complete string into the URL field.

You control the path relativity of your URL with the Path Mode selection 
box. See the Chapter 4, Path Names in LookoutDirect section for more 
information on using the Path Mode selection.
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Remote Position Source Connections
Remote position source connections are the preferred method for connecting 
a control in a client process to a server process in LookoutDirect.

Because you ordinarily want to be able to have your client processes work 
from any computer on your network without having to edit them, it is best to 
make connections from client processes to server processes, and not from 
servers to clients. Because server processes usually need to be run from the 
same computer all the time, you can use absolute paths to make sure your 
client processes will connect to your server processes no matter where the 
clients are run.

Symbolic Link Connections
LookoutDirect Symbolic Link objects have several important uses in 
LookoutDirect. The following figure shows the Create Symbolic Link 
dialog box.

 

You can make a URL connection in the Static source field to an entire process 
with a Symbolic Link and then access any object in that process through the 
link. This is a crucial part of LookoutDirect redundancy, which is described 
in Chapter 10, Redundancy, of the LookoutDirect Developer’s Manual.
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You can enter a complex expression in the symbolic link Dynamic source 
field, and then make a URL connection to the symbolic link itself, 
circumventing the restriction on complex expressions in remote position 
source connections for controls.

HyperTrend Item Connections
Because the HyperTrend trends data from the Citadel database, every item 
you display on a HyperTrend object is accessed through a URL connection.

If you need to trend a complex expression, you can create a named expression 
by creating an (expression) object. You can enter the complex expression you 
want to trend, log it to the historical database, and then display it as a 
HyperTrend item.

Note If you convert a LookoutDirect process created in a version earlier than LookoutDirect 
4.0, LookoutDirect will automatically create and log a named expression for your 
HyperTrend object to display when it recompiles the .lks source file.

Displaying Data Members on Control Panels
Follow these steps to display a data member on a control panel:

1. Make sure LookoutDirect is in edit mode and open the Object Explorer 
by selecting Object»Object Explorer.

2. Navigate to the object or data member you want to display on your panel. 
In the following illustration, a data member from a waveform object 
running on a server process located on another computer on the network 
has been selected.
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3. Drag and drop the data member onto the panel you want the data to 
display in. LookoutDirect inserts an expression to display the data. You 
may have to adjust the size of the display for the data to appear properly.

4. Right-click on the display to change its display characteristics, modify 
the expression, change the data format, or alter any other properties of the 
display.
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You can also insert an expression to display data by choosing 
Insert»Expression from the LookoutDirect menu bar. The Insert 
Expression dialog box appears as shown in the following illustration.

 

5. Navigate to the data member you want to display, just as you did with the 
Object Explorer.

6. Set the Path Mode. In the preceding illustration it is set to absolute 
because the data is being displayed on a client process panel in one 
computer (paroikos) and originating from a server process on a different 
computer (tripper).

7. Select the data member you want to display in the Contents list.

8. Click on Paste and then OK.

LookoutDirect responds by presenting the Display numeric signal or 
Display logical signal dialog box. The type of dialog box depends on the 
type of data member being inserted (numeric or logical). In this case the 
signal is numeric, a cosine wave generated by the LookoutDirect 
Waveform object.
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Select the display parameters you want, and click on OK.

You can also drag an object from the Object Explorer to a panel. When you 
do, the Insert Expression dialog box appears, and you can proceed as you 
did when you invoked this dialog box from the menu.
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