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Graphics 

This chapter describes how to add static and dynamic graphics to a control 
panel and how to create and use custom graphics.

Any visible item on a LookoutDirect control panel is a graphic. All graphics 
are either static or dynamic. Static graphics never change state, but dynamic 
graphics change state to represent process variations. LookoutDirect provides 
an extensive graphics library. These graphics range from switches, 
potentiometers, and pushbuttons to bar graphs, valves, tanks, pumps, plates, 
insets, scales, and more. However, there might be times when the standard 
LookoutDirect graphics do not exactly fit your needs. You can use any other 
drawing software to create your own custom graphics.

Note Consider screen resolution when creating display panels (VGA versus Super VGA). 
The same panel appears differently on computers using different resolution display drivers. 
Read about screen resolutions in the description of Panel objects in the online help or the 
online PDF LookoutDirect Object Reference Manual before you design your panels.

Setting Snap to Grid
You can activate the snap to grid feature in LookoutDirect by selecting 
Edit»Snap to grid. This feature aligns objects you are positioning to a grid on 
the LookoutDirect panel. 

You can adjust this grid by selecting Edit»Options. The Edit Options dialog 
box appears. 
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Use this dialog box to set the distance (in pixels) between grid points, show 
or hide the grid, and select different color options for the grid display.

Static Graphics
Static graphics never change state. They exist on a control panel much the 
same way a picture hangs on your wall, never changing or moving. Static 
graphics range from text labels, plates, insets, and scales to complex 
schematic overviews and scanned photographic images.

Displaying Text, Plates, Insets, Rectangles, and Lines 
Effective use of text, plates, and insets make control panels intuitive and easy 
to use. The example below demonstrates how plates and insets organize 
information about two pumps.

 

To create static text, plates, insets, rectangles, or lines in LookoutDirect, 
select Insert»Text/plate/inset. The Insert text/plate/inset dialog 
box appears.

Plate

Inset
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If you want to create a rectangle, line, plate, or inset, leave the Text field 
blank and choose a Background style. The preview window displays the 
element as it appears on a control panel.

To create a vertical or horizontal line, choose Rectangle. After clicking 
on OK, size the rectangle to the desired length, and reduce the width to the 
thickness you want your line to be. If you need the rectangle an exact size, use 
the yellow status bar, which indicates dimensions.

Note LookoutDirect uses color grids in many dialog boxes. The grids make selecting colors 
quick and visually helpful. However, they might look slightly different from computer to 
computer.

Some computer display adapters can display only 16 solid colors on the 
screen. The standard VGA adapter in conjunction with the Windows VGA 
driver supports only 16 colors directly. Windows uses a technique called 
dithering to simulate the display of colors not directly supported as solid 
colors. For example, LookoutDirect might display orange as an alternating 
pixel pattern of red and yellow bits on the screen.

Some objects in LookoutDirect require solid colors, so if you specify a 
dithered color, LookoutDirect uses the nearest solid color instead. For 
example, a Trend object requires a solid color for its background and solid 
colors for the trend lines. Furthermore, LookoutDirect always displays text in 
a solid color. If you specify pastel green for a trend line color, you might get 
yellow instead. Bar graphs and control panel backgrounds can display 
dithered colors.
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Note Some display adapters support 256 or even 16 million colors on the screen at one time. 
Even though LookoutDirect allows you to specify only 28 colors, LookoutDirect displays 
custom graphic files on control panels using all available colors. 

Displaying Static Custom Graphics
LookoutDirect supports two graphical file types—Windows 
Device-Independent Bitmap (.BMP) and Windows Metafile (.WMF).

To display static bitmap and metafile graphic files on a control panel, select 
the Insert»Graphic command. The Select graphic dialog box appears.

From the Select graphic dialog box, you can scroll through various 
directories containing a variety of graphic files. The list box includes all 
bitmaps and metafiles located in the GRAPHICS subdirectory under the 
root LOOKOUTDIRECT directory. As you select each category, you see 
thumbnail sketches displayed in the preview window to the right of the list 
box. Because graphics might stretch or shrink to fit in the preview window, 
they might not appear exactly as they do on a control panel.

Note If you know the name of the file, type the first letter of the filename. The list box 
automatically scrolls to the first file beginning with that letter.

If you choose a bitmap (.BMP) file, you can use the Transparent pixel 
data fields to specify which color pixels in that graphic you want to be 
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transparent in LookoutDirect. Imagine the viewing area as an X-Y coordinate 
plane with (0,0) being the top left corner of the graphic (not the entire viewing 
area). You can enter any X and Y coordinates, and the corresponding pixels 
become transparent, as do all other pixels that color. The Transparent pixel 
fields do not have any default values. If you leave the X and Y fields blank, 
no pixels become transparent.

You can use a multicolor bitmap as a type of mask. For this to work, some part 
of the bitmap (usually the interior) must be transparent and the rest of the 
graphic opaque—masking the underlying part of the control panel. In the case 
of the interface selected above (the second from the left in the second row), 
the pixels to be made transparent are gray. You can insert another 
LookoutDirect element, such as a bar graph, to furnish a convenient visual 
warning, such as a rising color level.

You could guess the X,Y coordinates of any grey pixel on the graphic. It helps 
to know that the center of the graphic is (–1,–1). In the example above, 
(–1,–1) is a black pixel; to select a gray pixel, you would have to offset your 
choice to (–1,0). Because this is a gray pixel, all other gray pixels become 
transparent when inserted on a control panel.

Note Windows metafiles are normally easier to use and manipulate than bitmap 
images. Unlike bitmaps, metafiles can be resized in LookoutDirect. Because of their inherent 
structure, you can also use metafiles as masks without specifying transparent pixels. Had the 
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example above used a .WMF graphic, the area in gray would have appeared in the 
LookoutDirect window as a crosshatched area. 

Dynamic Graphics
Many process control panels require some type of animation, such as a pump 
changing colors to represent on and off. Table 2-1 lists the LookoutDirect 
elements that use animation or change states. 

     
Table 2-1.  Tools for Displaying Dynamic Graphics

LookoutDirect 
Component Description

Animator object 
class

An Animator object provides full graphical animation including horizontal 
and vertical motion, dynamic resizing and visibility, dynamic sequencing, 
and color changing.

Multistate object 
class

A Multistate object displays up to six different custom graphics based 
on advanced if-then-else logic.

Pipe object class A Pipe object makes a rectangle or line (of any dimension) change colors or 
blink, based on advanced if-then-else logic.

DialGauge object 
class

A DialGauge object displays a numeric signal as a sweeping needle on an 
analog gauge or dial.

Gauge object 
class

A Gauge object makes a numeric expression (digital number or barchart) 
change colors or blink based on advanced logic.

Spinner object 
class

A Spinner object is a small rotating disk. It can be turned on and off with a 
logical signal, and its rotation speed and direction are controlled by a 
numeric value.

Switch object 
class

A Switch object can represent its two positions using standard switch 
symbols or custom graphics.

Pushbutton 
object class

A Pushbutton object looks like a button that changes when depressed, but 
you can also make it transparent. You might use transparent pushbuttons over 
custom graphics.

Pot object class A Pot object can be displayed as a knob, vertical slider, horizontal slider, 
increment and decrement buttons, or a digital number.

Logical expression When you create an expression that results in a logical value, you can 
represent that value using standard lights, text, or custom graphics.
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For information on a specific object class, refer to the online help or the online 
PDF LookoutDirect Object Reference Manual. For information on 
expressions, refer to Chapter 1, Expressions.

Displaying Dynamic Logical Signals
Logical expressions and Switch objects are two commonly used graphical 
animation tools. You can display the signal a Switch object generates in a 
variety of ways.

 

The Switch is shown in the On and Off positions. The graphics on the right 
side of the control panel show three ways of graphically displaying the logical 
signal generated by the Switch. The graphics representing the Switch signal 
are expressions of the (implicit) value of the switch, created through the 
Insert»Expression menu command.

Numeric 
expression

When you create an expression that results in a numeric value, you can 
represent that value using a digital number or a vertical or horizontal bar 
chart.

Text expression When you create an expression that results in a text value, you can represent 
that value using any style and size font loaded on your computer.    

Table 2-1.  Tools for Displaying Dynamic Graphics (Continued)

LookoutDirect 
Component Description

Switch ON

Switch OFF
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To create a Switch object, first choose the logical signal that you want to 
represent with dynamic graphics (for example, a logical input from a PLC). 
Then, select an object to display the logical signal. For this example, use a 
Switch to simulate a contact from a motor starter relay.

Create a Switch and call it PumpSwitch. After you define the Switch 
parameters, LookoutDirect presents the display parameters dialog box for the 
Switch object (as shown in the following figure). You can choose to represent 
PumpSwitch with one of the standard graphics, or you can use custom 
graphics. For this example, select a standard graphic and click on OK.

To insert an expression representing the signal generated by the Switch 
object, use the Insert»Expression command and select PumpSwitch, 
or drag and drop the signal from the LookoutDirect Object Explorer.
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When you click on OK, the Display logical signal dialog box appears. From 
the Display logical signal dialog box, select display characteristics for a 
logical signal expression.

Click on the Custom selection, and then on the On and Off list boxes, 
scrolling through the choices until you find the appropriate graphic. Your On 
and Off graphic selections appear as thumbnail sketches in the two preview 
windows to confirm and verify your selection.
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Click on OK and test your example by flipping the switch. The graphics 
should change according to your selections in the On and Off preview 
windows. To customize your switch, experiment with the Text selection 
in the Display logical signal dialog box.

Use this same basic method to display any dynamic signal on a control panel. 
If you want to represent more than two conditions with dynamic graphics, use 
a Multistate object. Similarly, you can use a Pipe object to make a line or 
rectangle dynamically change colors and blink.

Displaying Dynamic Numeric Signals
You can use a Pot object to display dynamic numeric signals. The following 
illustration shows the Pot as a slider, a digital entry, and increment and 
decrement buttons—all are graphical representations of the same Pot object. 

 

To use a Pot object to display a signal, first choose the numeric signal that you 
want to represent with dynamic graphics, such as an analog input from a PLC. 
Then, select an object to graphically display the dynamic numeric signal. For 
this example, create a Pot object and name it PumpSpeed. After you define 
the Pot parameters, a display parameters dialog box appears. In this example, 
the dialog box is named Insert: Pot1. You can choose to represent the Pot 
with any of the standard graphics.

Slider

Increment Decrement

Bar Graph Display

Digital Entry
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Use the Insert»Expression command (or click and drag) and select 
PumpSpeed to insert an expression that represents the signal generated by the 
Pot object.

When you click on OK, the Display numeric signal dialog box appears. 
From this dialog box, select the display characteristics for a numeric signal 
expression.

If you choose Digital display style, you can use the Font button to select the 
desired font style and size. You can also specify a Numeric format for the 
value. For more information on numeric formats, refer to the LookoutDirect 
Getting Started Guide, Chapter 3, Getting Started with LookoutDirect

Click on OK and test your example by adjusting the Pot. The graphics should 
change according to your selections.

If you want to represent the numeric signal with moving custom graphics, use 
the Animator object class.
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Displaying Dynamic Text Signals
You can display dynamic text messages on a control panel with text 
expressions. You can easily display up to two separate text messages using 
logical signals, but there are times when you need to display three or more 
separate text messages in a single statement. If you have more than two 
separate messages, a numeric signal might determine which message 
to display.

To graphically display a dynamic text signal, first choose the numeric signal 
that you want to use to control which message is displayed, perhaps an analog 
input from a PLC. Then, select a graphical object to display that signal. This 
example uses a Pot object.

Create a Pot object and call it Pot1. Define the Pot minimum, maximum, and 
resolution parameters as 1, 4, and 1 respectively. Select the 
Insert»Expression command and enter the following expression in the 
dialog box that appears.

TCHOOSE(Pot1, “Do you recall”, “Those roadside signs”, 

“That used to promote”, “Burma Shave”. 

See Chapter 1, Expressions, for information on the TCHOOSE function.
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When you click on OK, the Display text signal dialog box appears. From this 
dialog box, select display characteristics for a text signal expression. Use 
Plate as your background style.

  

Click on OK and test your example by adjusting the Pot. The text should 
change according to your expression.

Finding a Lost Graphics File
LookoutDirect uses a standard missing graphics bitmap to mark a location on 
a panel where a graphic should be present but cannot be found in the location 
LookoutDirect expects. The status bar at the bottom of the LookoutDirect 
screen displays the path and filename of the missing graphic.

Right-clicking on the missing graphic bitmap displays a standard screen that 
also tells you the name of the missing graphics file and the previous path.

To restore the look of your panel, either put a new copy of the graphic in the 
location in which LookoutDirect expects to find it, or delete the missing 
graphic bitmap and place a new copy of the graphic from its current location.
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Creating Custom Graphics
There might be times when none of the LookoutDirect standard graphics 
exactly fits your needs. You can use any drawing software to create your own 
custom graphics. LookoutDirect supports both Windows 
Device-Independent Bitmaps (.BMP) and Windows Metafiles (.WMF).

After you create a custom graphic file, copy it to the GRAPHICS subdirectory 
of your choice in your LookoutDirect root directory. Because LookoutDirect 
can use only graphics located in the GRAPHICS directory and subdirectories, 
keep all standard and custom graphics in the GRAPHICS subdirectories. 
LookoutDirect can access your custom graphic file any number of times in 
the same or different process files from the GRAPHICS subdirectories.

Creating Custom Graphics Example
This section describes how to create custom graphics for use in 
LookoutDirect. This example sketches out the creation of an elevated tank 
graphic you can use to show water level in a real tank. You export that tank 
graphic to LookoutDirect, implement the display in LookoutDirect, and test 
it. The example might only parallel what you would have to do with your own 
graphics creation program, but should serve as an illustration of the important 
points.

If you have not already mastered using a drawing program, you should allow 
yourself time to become accustomed to using the drawing application of your 
choice. The illustration below is from a third-party drawing application.

Creating the Graphic
1. Draw half of the tank.

2. Copy the tank half and mirror the image to create the other half.

3. Connect and refine the halves to create an enclosed tank object.
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4. Refine your image until it looks the way you want.

5. Draw a rectangle around the tank and connect both the rectangle and tank 
into a single object.

6. To match the background color of the mask to the control panel, select 
the object group and click on the gray color bar selection.

7. Select invisible for the line style.
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Save or Export the Graphic and Place in LookoutDirect 
1. Save or export your new graphic from the drawing program as a 

Windows Metafile (.WMF) in the directory 
C:\LOOKOUT\GRAPHICS\TANKS and name your new graphic 
ELEVTANK.WMF.

2. Export.

Testing the Graphic in LookoutDirect
1. Launch LookoutDirect.

2. Create a Pot object using the Object»Create command.

3. Select Insert»Expression, choose the Pot object, and click on OK.

4. In the Display numeric signal dialog box, select Bar (up) for the 
Display style, Rectangle for the Background Style, and click on OK.

 

5. Use the Insert»Graphic command to insert your new graphic, 
ELEVTANK.WMF, over the bar graph.

6. Position the graphic over the bar graph and stretch it to size.

7. Toggle out of edit mode and test your example by moving the slider up 
and down.
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Graphic File Types
LookoutDirect accepts both Windows Device-Independent Bitmaps (.BMP) 
and Windows Metafiles (.WMF).

Bitmaps
Bitmaps are raster files, made up of differently colored pixels. Because each 
pixel in the bitmap takes up one pixel on the screen, bitmap images are always 
rectangular and never resizable. You can display raster images on control 
panels that are not rectangular in LookoutDirect by using transparent pixels 
for the parts of the rectangle you do not want to show.

Bitmap files typically have a .BMP file extension. The Paint program that 
comes with Windows can read .PCX bitmap files (another very common 
bitmap format) and convert those files to Windows bitmaps.

Metafiles
Metafiles are vector files, consisting of coordinates that are connected by 
lines and curves, as well as area-fill commands. A vector file can consist 
solely of two sets of coordinates connected by a line or a complex set of 
colored area fills and colored lines and curves to create line art images. 
Metafile images are not necessarily rectangular.

Because metafiles contain a set of coordinates, they can be resized and 
stretched to any size or aspect ratio. Microsoft does not add information in the 
basic metafile file format for metafile size information. The Aldus 
Corporation (authors of PageMaker) created a metafile header that contains 
metafile size information. Most software packages that generate metafiles 
also add this header information. Without the header, LookoutDirect cannot 
maintain the correct aspect ratio (width to height ratio) for a metafile. To 
determine if a metafile has this information, resize the graphic on a control 
panel while holding down <Ctrl>. If aspect information is available, 
LookoutDirect does not stretch the metafile drawing out of proportion.

Bitmaps or Metafiles?
Which format is better: bitmap or metafile? Both have strengths and 
weaknesses. You might want to use a combination of metafiles and bitmaps. 
Bitmaps effectively handle large background schematics or system 
overviews, and metafiles work well for individual pumps, valves, lamps, and 
other miscellaneous graphics.
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Bitmaps usually display faster than metafiles. In fact, a complex drawing 
rendered as a bitmap can display 100 times faster than the corresponding 
metafile. If you want to display scanned photographic quality images with 
hundreds of colors, use bitmaps.

Metafiles are resizable—you can stretch them to any size or aspect ratio. 
Metafiles are typically smaller than bitmap files, so they take up less disk 
space and consume less memory than bitmap files. You can use one file that 
contains a metafile drawing of a pump to display several pumps of various 
sizes on the screen. With most drawing programs, you can save your line art 
images as metafiles. You can also copy the image on screen to the Windows 
clipboard and paste it into a paint program for bitmap conversion.

Memory Considerations
LookoutDirect loads each graphic into computer memory the first time it is 
displayed. The image remains in memory until LookoutDirect or another 
application needs more memory than is available. When more memory is 
needed, the graphic is discarded from memory and reloaded from disk the 
next time it is displayed, so that you can display more bitmaps and metafiles 
on the screen than can be held in memory at one time.

If you are running Windows in enhanced mode on a 386 or 486 computer, you 
have virtual memory. Windows uses virtual memory to swap memory images 
between RAM and disk, giving applications the appearance of more memory. 
If available memory becomes low and Windows must use virtual memory to 
handle applications and data between disk and memory, you might notice a 
slower application speed. For more information on virtual memory, refer to 
your Windows user guide. If your computer disk drive light flashes every 
time you pull up a new control panel in LookoutDirect, consider purchasing 
more RAM.
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