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Tabbed Views
Using the Ladder View to create ladder logic programs has been discussed to this 
point. There are other views that are output only. These views will help to organize 
and better visualize the program. These additional views are Mnemonic, Stage 
(RLLplus), Cross Reference (XRef), Documentation Editor, Trend and PID Views. Once 
these views are opened, each view is easily accessed by a tab located at the top of 
the display window.

The Primary Views
Ladder, Stage, Mnemonics, XRef and Trend Views are the primary views in 
DirectSOFT 6, and can be accessed by selecting the View submenu from the Menu 
bar and then selecting the view of your choice with the mouse cursor. When a 
new project is started, the Ladder and XRef Views appear as the default (refer to 
page 2-12). The Stage and Mnemonic Views can only be opened from the View 
submenu or by right-clicking when the mouse cursor is in any open View and 

selecting a different View from the Local Menu. The Trend View can be opened 
from the View submenu or from the Trend button on the Online Toolbar.
It is possible to open the Stage, Mnemonic and Trend Views along with the Ladder 
View by selecting the views one at a time from the View submenu, thus providing 
a Multi-Tabbed Interface (MTI) view. Once the views are open, you can switch from 
view to view by clicking on the appropriate tab in the display window. The Stage 
View also displays the Ladder View in the lower part of the view, therefore, it may 
not be necessary to open the Ladder View. This choice is left to the programmer.

Primary Views

Tabs
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One option is to have the Documentation Editor open as a tabbed view while 
editing a program. Selecting the Documentation Editor tab allows easy access to 
the editor. To open the editor, either press the Documentation Editor button on 
the Tools toolbar (if it is displayed), use Tools > Documentation Editor on the 
Menu bar or the keyboard shortcut Ctrl + D.
The Trend View is used to visually monitor the values of DirectLOGIC controller 
data elements over time. This View can monitor any readable numeric location or 
any readable bit location or any constant value. Trend View also logs the values of 
the controller elements on each pane of the Trend. Those values are displayed on 
a moving graph. 
One more view, the PID View, will be useful if a PLC with PID loops is being used. 
This view is only available to the user after at least one PID loop has been setup. 
Once a PID loop has been setup, the PID View is opened from the View submenu 
on the Menu bar.

If multiple views are open in the Program display window at the same time, the tabs 
will appear as in the illustration below.



DirectSOFT6 User Manual, 2nd Ed. Rev. C7-4

Chapter 7: Other Views

Stage (RLLPLUS) View
Most of the DirectLOGIC PLCs support the RLLplus instructions. The instructions 
(Stage, Jump, etc.) enable you to create a structured program that can be viewed 
as a flowchart when the Stage View is enabled. A program flowchart may be easier 
to follow than a comparable ladder logic program.

Troubleshooting RLLplus vs. RLL
The old saying, “can’t see the forest, because of all the trees” often holds true 
in ladder logic programming. Some RLL programs may contain many interlocks 
and complex rungs. It may be difficult to follow the logical flow of activity and 
the relationships between different parts of the program. This is where Stage 
programming can be better than ladder logic programming. As a ladder logic 
program is edited with stages, DirectSOFT6 will translate the RLL into the equivalent 
Stage View using much more compact, and easy-to-follow flow diagrams.

NOTE: Consult the PLC User Manual, Chapter 7, to learn how to incorporate Stage Instructions in a ladder logic 
program.

An illustration of a Stage View is shown below. The flowchart area is shown in 
the upper left part of the display while a ladder logic area is shown in the lower 
half of the display. The two windows are synchronized, in other words, when 
the flowchart is activated with the cursor, the ladder logic will scroll to the same 
position in the program. This can aid with troubleshooting the program. When 
testing a program online with a PLC (status ON), both the flowchart and the ladder 
logic will track each other, showing the power flow and transitions as they occur. 
It is possible to look at another part of the program by opening the Ladder View 
and tile the two views (refer to page 4-30). The right-hand corner view contains 
the stage comments. These comments are synchronized with the flowchart area 
of the display (refer to page 6-12 for details).

Stage Components
If the flowchart area of the Stage View is being viewed and there is an uncertainty 
of what a component means, click on the component and the corresponding 
equivalent in ladder logic will come into view. Help (F1) can also be consulted for 
more clarity.

Ladder Logic

Flowchart Stage Comments
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Mnemonic View
Handheld Programmer Aid

There may be times when a DirectSOFT6 user will need to use a handheld 
programmer (HPP) to modify a DirectSOFT6 ladder logic program. Since the HPP 
only uses mnemonics, the Mnemonics View will prove to be useful as a guide. 
Just open the Mnemonics View and print it on a printer. The hard copy can be 
carried to the PLC location. Consult the PLC User Manual (Chapter 5) for the proper 
keystrokes required for entering the mnemonic instructions.

NOTE: There are no display options for the Mnemonic View.
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Cross Reference (XRef) View
As mentioned on page 2-12, the Cross Reference (XRef) and Ladder Views open by 
default whenever a new project is started. The XRef View can be closed if desired, 
but since it is a dockable view, it is a good idea to dock it if you do not want to 
view all the time. Just click on the push-pin to dock it, and hover the mouse cursor 
over the XRef tab to bring it back into view. Then, click on the push-pin again or 
double-click on the XRef View bar at the top to “lock” it in position again. The XRef 
View has two viewing modes, XRef Mode and Usage Mode.

XRef Mode
The XRef Mode is the default mode when the XRef View is first opened. When 
in XRef Mode, the Cross Reference Table reports information for all elements 
that meet the current Query which determines the elements to be included in or 
excluded from the XRef and Element Usage Tables. The table is divided into four 
columns:

•	 Element ‒ �reserved for the element ID, but will display whatever 
Query is selected in the Options dialog.

•	 Rung ‒ rung number where the element is used.

•	 Address ‒ the address where the element is located in the program.

•	 Instruction ‒ type of instruction that contains the element.
A useful feature of the XRef Mode is to double-click the left mouse button on 
the Rung, Address or Instruction and the program will move to that location. 
Also, double-clicking the left mouse button on an element will cause the Element 
Browser to appear.

Usage Mode 
button

Push-pin to 
dock the XRefXRef Mode 

button
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Change the XRef Query
The XRef Element column can contain all four types of documentation available in 
the Options dialog. To change the Element XRef Query definition, first enable the 
XRef View by clicking the mouse on the table. Next, open the Options dialog from 
the Menu bar using View > Options or press the Options button on the Offline 
toolbar. You can also right-click anywhere in the XRef View and choose Options 
from the Local Menu. Choose the XRef tab and make the Query selections in the 
Documentation section to be displayed in the Element column. Press OK after 
making the selections.

The other two sections located in the dialog, Display Mode and Usage Options, 
contain options that can be selected on the XRef View toolbar. Also notice the 
box to the left of the Follow Ladder Cursor option under the Display column. The 
box can be checked in this dialog or selected at will in the XRef Toolbar which is 
explained on the facing page.
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XRef Toolbar
The Cross Reference View has a toolbar to move quickly to different locations and 
views in a program. The available buttons can be seen in the illustration below.

•	 XRef Mode ‒ this button brings the Cross Reference table into view if it is not 
in view.

•	 Usage Mode ‒ pressing this button brings the Element Usage table into view.

•	 Follow Ladder Cursor ‒ when the XRef View is enabled, the rung information 
will be placed at the top line of the table for any rung where the ladder cursor 
is positioned.

•	 Rung XRef ‒ this button transfers the current mode to a one rung mode which 
only displays one rung in the table.

•	 Specify XRef Rung ‒ enabled only in the single rung view. Enter a rung number 

or an address in the dialog pictured below, then click OK. The program will go 
to and display the rung number entered.

•	 Previous XRef Rung ‒ the Ladder View will display the previous rung while 
only in the Rung Mode.

•	 Next XRef Rung ‒ the Ladder View will display the next rung while in only the 
Rung Mode.

•	 Manual Rebuild XRef and Element Usage Tables ‒ manual rebuild for 
elements either added or deleted later in a program. This button will be inactive 
unless Auto Rebuild is not selected in the XRef DB dialog (see page 7-11).

XRef Mode 

Usage Mode

Follow Ladder 
Cursor

Rung XRef

Specify XRef 
Rung

Previous 
XRef Rung

Next XRef 
Rung

Manual rebuild 
XRef and Element 

Usage Tables
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Usage Mode
The Usage Mode is selected to display the Element Usage Table in the current 
Cross Reference View. The Element Usage Table displays all elements that meet 
the current Query. The table is an effective way to see which points have been 
used, which points are free and whether or not they have been used in a range. 
The elements are shown in groups of 8, 10 or 16 bits as determined by the current 
Usage Field Size setting

Usage Mode Toolbar
The Usage Mode toolbar is used to select various options for viewing the Element 
Usage table.

Usage 
Mode 

Usage Mode 
Selected

Element Usage 
Table 

Select the 
XRef Mode 

Usage Table 
select button

Follow Ladder 
Cursor

Toggle element 
references to read 

left to right or right 
to left.

Limit range of elements to 
the current PLC.

Set usage field 
display length.

Rebuild XRef 
and Element Usage 

Tables
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XRef DB
There is another tab on the Options dialog that can be used for setting up the 
Query for the XRef View. It is the XRef DB tab as seen in the dialog below. This 
dialog opens with the default selections as shown. In most cases, this dialog should 
remain as is. The Auto Rebuild may be the only selection to be disabled if it is 
desired to manually update the Cross Reference View whenever an element is 
added or deleted.
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PID View
The PID View will be useful as a PID loop tuning aid. To access this view, at least 
one PID loop must be setup.

NOTE: 1 Refer to your PLC User Manual, Chapter 8, PID Loop Setup to setup a PID loop. 
NOTE 2: PLC View is not available until you are connected with a PLC and at least one PID loop is configured. 

PID Setup
To setup a PID loop, the PC must be connected to a PLC which is online. To begin, 
either press the PID button located on the PLC Setup toolbar (if displayed) or use 
PLC > Setup > PID. This will open PID Address dialog as pictured below.

After this dialog has been completed and saved, the Setup PID dialog, pictured 
below, is opened. The Setup PID dialog is a series of dialogs used to setup one or 
more PID loops. Use the PLC User Manual as a guide to setup the loop(s).
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Once a PID loop has been setup, open the PID View by selecting it  from the View 
submenu on the Menu bar. A Data View can also be open to assist in tuning the 
PID loop(s).
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Trend View
The Trend View can be used as a debugging tool. As mentioned previously, it is 
used to visually monitor the values of DirectLOGIC controller data elements over 
time. It has the ability to monitor any readable numeric location or any readable 
bit location or any constant value. Those values are displayed on a moving graph 
and can be logged and exported to a CSV file for importing into a third-party 
application for further research. 

Creating a new Trend View
A new (empty) Trend View can be created by selecting Debug > Trend View 
> New from the Menu, or clicking the Trend button on the Online toolbar. The 
following dialog is displayed prompting for the number of Panes to initially create.
Enter the number of Panes in the Number of Panes field or use the Up or Down 
arrow to set the value. Click the OK button to accept or the Cancel button to abort.

A Trend View can also be created and pre-filled with the critical elements by the 
following methods:

•	 �Right-clicking anywhere in a Data View and selecting Trend All.
•	 Highlighting a range of elements in a Data View, 

then right-click and select Trend Selection.

The next window to appear is the Trend View Options window as seen on following 
page. This window contains all of the parameters available for the new Trend View. 
Enter Starting and Ending elements, desired display characteristics and historical 
options in this window. 

NOTE: Refer to the DirectSOFT6 help file for more information on configuration options and features of Trend 
View. 
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If the element to be added is not a bit or a 
constant, then this causes a secondary dialog to 
be displayed so that the Format and Size can be 
determined. Once determined, the OK button 
will accept the selections. An example Trend 
View is shown below. 
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Output Window
There may be an occasion when a mistake(s) has gone unnoticed while a program 
is being edited. The mistake(s) will be detected by DirectSOFT6 whenever the 
program is accepted (compiled), and displayed in the Output window as shown 
below.

The Output window will appear below the view being displayed, in this case, the 
Ladder View. Each mistake or error message will be listed. Double-clicking on the 
error in the Output window will move the edit cursor to the error rung in the ladder 
view. Once all of the errors are corrected, the program can be compiled. The error 
messages in the Output window will disappear but the window will remain in view 
as can be seen in the diagram on the facing page.
In the diagram above, notice the push-pin in the upper right-hand corner of the 
Output window. Clicking on this push-pin will auto-hide the window, and a tab will 
be displayed in the lower left-hand corner. More about auto-hide and dockable 
views will be discussed beginning on page 7-19.

Double-click on the 
error message

Edit cursor will 
move to the error 

rung.

Output 
tab
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The Output window can be closed just like other windows are closed. If you desire 
to open the Output window, press the Output button located on the Windows 
toolbar if it is displayed.
If the Output window is displayed with error messages, it can be cleared by pressing 
the Clear Output button located next to the Output button on the Windows 
toolbar.
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Bookmark
A feature which can be used as either an editing or a debugging aid is the 
Bookmark feature. This feature allows the programmer to mark one or more rungs 
in his program if he wants to quickly go to a marked rung. To use the feature, 
simply have the cursor located on a rung and hold the <Ctrl> key down and 
press the left mouse button (this will only work with the mouse button). The rung 
which is bookmarked will appear in the Output window. Once the bookmark has 
been made, you can double-click on the bookmark in the Output window and 
DirectSOFT will jump to that rung and display it. The Output window can also be 
hidden by clicking on the push-pin. The Output window can then be recalled by 
clicking on the Output tab. Closing the Output window will clear all bookmarks.

Double-click on the 
marked rung to quickly 

display.

Use the push-pin to hide and 
recall the Output window or 

close the Output window to clear 
all bookmarks.
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View Terminology
The terms “docked view” and “floating view” have been used in this manual and 
will be clarified in this section. A “Docked View” or a “docked toolbar” is a view, or 
toolbar, that is “docked” to a specific edge of the Programming window. Initially, 
the Offline toolbar is docked at the top of the Programming window below the 
Menu bar. The Online toolbar is also docked at the top, but below the Offline 
toolbar. The Ladder Palette toolbar is initially docked on the right edge of the 
Programming window, and the Cross Reference View is docked on the left edge 
of the window. Primary views (Ladder, Stage, PID, Trend, etc.) appear within the 
“Tabbed MDI View” (Multiple Document Interface) area between the various 
docked views/toolbars. The primary tabbed views are shown in the diagram below.

Viewing the example on the next page, each of these docked views/toolbars can 
be docked on any edge (e.g. the XRef View can be moved and docked on the right 
or on the bottom). Notice that the XRef View has been unpinned and placed in a 
floating position. In this position, the XRef View cannot be placed in a auto-hide 
position by pinning it until it is back in a docked position.
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All docked views/toolbars can also be Floating views/toolbars, and float outside the 
application frame (very handy if multiple monitors are being used). The remaining 
area, bounded by all of these docked views/toobars, is where the primary MDI 
Views are positioned.
One final user interface for dockable views is the capability to group only the 
dockable views to create a tabbed group of multiple docked  views (e.g. 2 Data 
Views and the XRef View can all be placed in a single tabbed group). This tabbed 
group can then be docked, floated or auto-hidden as a single entity. To create this 
tabbed group, open all of the Data Views to be placed in the group, then drag one 
Data View on top of a second Data View, and so forth. You can also drag the XRef 
View over the top of this group to complete the single dockable, tabbed group.

tabbed group of 
dockable views
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The following table lists all of the different views/toolbars and all of the possible 
frame behaviors.

Note that the Docked/Floating/Auto-hidden/Tabbed Framed windows can all 
be independently set on a frame by frame basis. For example, you can have the 
Ladder Palette and the PLC Setup toolbars floating on a second monitor, with the 
Offline and Online toolbars being docked on the top edge; then have one Data 
View floating and three other Data Views grouped as a docked tab to the right side 
of the application; and have the Cross Reference View auto-hidden, and docked on 
the bottom edge of the application.
However, the two different MDI Frame behaviors are exclusively either/or. This 
means that within a DirectSOFT6 session, all of the MDI views behave either as 
individual MDI frames or as tabbed views, but not both at the same time. You 
cannot have the Ladder View be a tabbed view and the Stage View and PID View 
be cascaded as Individual MDI frames. All MDI Views will have Individual behavior 
or Tabbed behavior.

Window Frame Behaviors

DirectSOFT6 
Window Type

Individual MDI 
(cascade, tile, 
etc. like Rel 4)

Tabbed 
MDI 

Docked 
to Edge

Auto-
hidden 

Docked to 
Edge

Floating
Tabbed Group 

of Docked/Auto-
Hidden/Floating

All Toolbars √* √
Ladder View √ √*
Stage View √ √*
Trend View √ √*

Documentation Editor √ √*

PID View √ √*
Mnemonic View √ √*

Cross Reference/ 
Usage View (XRef)

√* √ √ √

Data View √* √ √ √
Output Window √* √ √ √

* Default behavior
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Examples of the various Window Frame Behaviors are in the picture below.

•	 Ladder View and Documentation Editor ‒ Tabbed MDI View with Ladder View currently 
selected.

•	 Offline toolbar, Online toolbar and PLC toolbar ‒ Docked to the top edge of the 
application, just below the Menu bar.

•	 Ladder Palette toolbar ‒ Docked to the right edge of the application.

•	 Data View Data10 ‒ Docked to the left edge of the application.

•	 Data Views Data8 and Data9 ‒ Docked as a Tabbed Group to the left edge of the 
application, with Data9 currently selected.

•	 Data View Data7 ‒ Auto-hidden/docked Data View that is docked to the left edge of 
the application.

•	 XRef View ‒ Floating XRef View that is floating outside the borders of the DirectSOFT6 
application window.

•	 PLC Setup ‒    Floating toolbar that is floating outside the borders of the DirectSOFT6 
application window.
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